RPC over HTTP connection to directory problem.

I'm pretty far along in that I can do the outlook /rpcdiag and get connected to my mail server via HTTPS but the directory access to my global catalog servers are still TCP/IP.
I have a primary and secondary domain controller (2003), and an exchange server 2003 which is not a catalog server. (is this a problem?)
I went through the Microsoft instructions for a single server on my exchange server, but because it is not a catalog server, it doesn't have the registry key, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS
I added the entries to DC01 and DC02 as specified - NSPI interface protocol sequences  ncacn_http:6004

I tried installing RPC over HTTP on the domain controllers also, but didnt fix anything.
I'm testing on the local lan, and not through any firewall.
Thanks,
mgaudieAsked:
Who is Participating?
 
SembeeCommented:
I have another list of registry entries from when I was setting up RPC over HTTP before SP1.
I have posted them here: http://www.amset.info/exchange/rpc-http-server.asp 
You may want to compare yours with mine. I read everything I could when setting up my first server and these were the entries that I found worked for me.

Simon.
0
 
mgaudieAuthor Commented:
Also, OWA works fine via HTTPS. certificate is installed on exchange server, and seems valid. DC01 and 02 have no certs.
0
 
SembeeCommented:
You have added entries for both domain controllers?
Don't think that is right. Try removing one so there is only one there.

Don't need Exchagne to be installed on a GC - infact any kind of DC.
You also don't need the RPC Proxy service on any other machine.

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mgaudieAuthor Commented:
Both domain controllers are catalog servers and have the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS
the exchange server does not have this key (I assume because it is not a catalog server)
I have added the NSPI interface protocol sequences value to this registry key on both catalog servers.
0
 
SembeeCommented:
How are you configuring RPC/HTTP? Are you using the GUI in ESM (Exchange 2003 SP1) or doing it by hand using registry modifications?

Simon.
0
 
mgaudieAuthor Commented:
I did the registry entries manually, following microsoft kb833401. (just went through it again to verify the entries)
I didn't do anything in ESM,
I did the IIS virtual directory configuration per the same article.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.