DNS Shows Old IP Addresses

Windows 2k server, DC with DNS installed.  Clients use DHCP.  When I look at DNS it shows anywhere from 1 (which I would expect) to 4 different computer names for 1 IP address (internal addresses, 10.1....).  Why is DNS not releasing these?  I just tested one.  I had a PC that hasn't been turned on in a while which was one of the multiple address PC's.  I booted it up and it grabbed a new address through DHCP.  I looked in DNS and it removed the old address and listed it under the new address (which it now shares with another old PC).

Thanks,

bshort1023
bshort1023Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
SembeeConnect With a Mentor Commented:
That is the option I was referring to.

Have you got scavenging/aging enabled on DNS?
Look at your AD integrated zone and then choosing "Aging" on the general tab.

Simon.
0
 
SembeeCommented:
Have you configured DHCP to discard the records when the lease is deleted?
Look at that the properties of the DHCP server and then click on the second tab "DNS".

Simon.
0
 
bshort1023Author Commented:
On the DNS tab the box is checked for "Discard Forward Lookups when lease expires".  Is that what you were referring to?

Sorry so late with the reply I have been on vacation.

Thanks.
0
 
bshort1023Author Commented:
Also in DNS the forward and reverse lookup zones have many different entries, should they be the same?

Increased the points.
0
 
bshort1023Author Commented:
Sorry but I don't know what the integrated zone is and I couldn't find it.  I checked the setting for scavenging by right clicking the server in DNS and chose Set Aging/Scavenging for all zones.  The check box is NOT checked for Scavenge stale resource records.  Both the No-Refresh and Refresh intervals are set to 7 days.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.