Creating a New Project In MS Interdev

I have a network set up in my home. I have a Windows 2000 Server running on one box and Windows 2000 Professional on another. I have just installed Version 6.0 of Visual Interdev. I want to do web development on client.

I have installed VI 6.0 on the client, and the server portion of the install on 2000 Server. I believe that ISS 5.0 and FrontPage Extensions are installed and running properly.

When I've gone to create my first New Project in VI, I requested its location be on the server. Specifically, I entered "\\Bflat77\Inetpub\Project1" in the New Project location textbox. "Bflat77" is the name of my server.

I am getting an error immediately after pressing the Next button. This is in Step 1 of 4 of the VI Create New Project wizard. The wizard, however, did find my server (Bflat77) without any help. So the network appears to be working and some communication is taking place.

But, when the button is pushed on the wizard, I get the following error message:

"The web server does not appear to have any authentication methods enabled. The server has asked for user authentication, but did not send a WWW - Authenticate Header (Error Message = 800040005)."

Now, in a development mode here at home I personally don't need any authentication or security. In fact, I don't want any, as I would think it would slow down in a development mode.

To try to eliminate the problem I went to the Properties dialog of the "Inetpub" directory on the server. Under the tab "Web Sharing", it said that the "Share On" value was "Default Web Site".  I checked "Share this folder". The alias section indicated "Inetpub".  I highlighted it, and edited its properties to include all "Access permissions" (i.e., I checked everything).

But, I still can't get Interdev to cooperate... the same error message comes back.

Two remaining factors to consider. First, I am not on a domain. Both computers are part of a workgroup called "WORKGROUP" and everything is tied to a Lynx router and from there to Comcast.

And, second, I am logged in on the client box as "Administrator". I believe the server sees me trying to come in as IUSR_BFLAT77. I believe that means that I should be treated like a "Guest". In the Computer Management tool, I have indicated that IUSR_BFLAT77 has a Profile of "Administrator"  - and the Administrator has full authority.

So what's the problem here? Any ideas?


 
gbmcneilAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
smolamConnect With a Mentor Commented:
Visual Interdev needs an http:// name to be able to create the project through Frontpage extensions, so you need to type in http://Bflat77/Project1 to create the new project, assuming that the server extensions are all working fine.

HTH
0
 
LlamaJoeCommented:
Also be sure to check your security settings in Internet Services Manager - the changes you made to inetpub only take effect if you do not allow anonymous access in IIS (of course you have to ensure that the iusr_computername user has access to the inetpub directory...  also, in IIS, right click on your web site, go to all tasks, and configure Front Page Server Extensions (FPSE).  You may also want to download a new version of FPSE since it fixes a number of things...

http://msdn.microsoft.com/library/en-us/dnservext/html/fpse02win.asp?frame=true
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.