Solved

Win98SE + crossover cable + WinXP Home Not working Why?

Posted on 2004-09-25
25
213 Views
Last Modified: 2010-03-18
I have a Win98SE + WinXP Home Edition (latest service pack 2) I can see the both computers in Network Neighbour hood, but can only access the Win98SE computer through WinXP Home. I cannot connect to the WinXP Home computer through the Win98SE computer. I have spent 2 days going through all these replies relating to this problem on this site, i have done everything possible that has been suggested.
Win98SE:
Workgroup = Workgroup
User name  = Julie
password - julie
Client = Client for Microsoft
File and Print Sharing for Microsoft Networks
CardBus 10/100Mbps Ethernet Card
Protocols = NetBEUI  + TCP/IP, the TCP/IP has in it an ip address of 192.168.0.10 subnetmask 255.255.255.0, The DNS, gateway, WINS are empty. NetBIOS has enabled 'I want to enable NetBIOS over TCP/IP. Bindings has ticked, Client for Microsoft Networks and File Print Sharing for Microsoft Networks.
I have shared the C drive on the Win98SE computer.
WINXP HOME:
I have gone into safe mode and made sure that the c: drive has got Everybody enabled also the specific user name (Julie) enabled with everyone and Julie having Full Control.  I have installed via the XP Home CD the NetBUIE and placed them into the appropriate directories on the WinXP Home comptuer.
I have TCP/IP installed with an IP addres of 192.168.0.10 subnet 255.255.255.0. have gone to the advanced properties and ensure the 'Enable NetBIOS over TCP/IP has been selected. I have even tried turning on the guest acount. I have run out of ideas. I have to have this computer back to the client today and i cannot understand what i am missing. Please Help.  Marissa
0
Comment
Question by:m_civitarese
25 Comments
 
LVL 5

Expert Comment

by:abu_deep
ID: 12153906
Protocols = NetBEUI  + TCP/IP, the TCP/IP has in it an ip address of 192.168.0.10>>>>>>>>>>

I have TCP/IP installed with an IP address of 192.168.0.10 subnet 255.255.255.0.>>>>>>>

I think that u type it wrongly because if u do so u will have ip conflict..
Now let…what is the error massage that get when trying to access the winxp through win98…

The only thing that I could say right now is that you have to make the windows xp machine partitioned with fat32 format because win98 can't deal with ntfs partitions…
0
 

Author Comment

by:m_civitarese
ID: 12153962
I have made the XP Home partiton to Fat32. basically what i was saying is that i have assigned each computer (Win98SE) and (WinXP Home) with thier own static IP address. WIn98SE has an IP address of 192.168.0.10 and WinXP Home with 192.168.0.20 (i made a typo error when i posted the question) sorry.  They both have subnet masks 255.255.255.0 and workgroup called 'Workgroup'
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154052
WinXP default install is Fat32 for Home edition and NTFS for Pro edition. It also depends on what you installed it as. u may have Pro installed as a Fat32 file system.



The most elementary answer as I've been said already: winXP probably uses NTFS, which means win98 or Me won't be able to access any files from that machine unless you used FAT32 on winXP or use 3rd party utilities for win98, windows 98 does not support NTFS directly ,Third party tools will allow you to do so but not built into windows itself.
There 'are' tools to read NTFS in 98 - see here: http://www.sysinternals.com/ntw2k/freeware/ntfswin98.shtml

Another issue that can cause the problem that is if u use a software firewalls in your winxp machine…
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154054
sorry but I post this replay before I read you comment ...so do u have a software firewall on your winxp pc...? if so try to disable it or trust local ip addres
0
 

Author Comment

by:m_civitarese
ID: 12154119
I have no firewalls turned on. I definetly am talking about WinXP Home Edition ,and it is FAT32. i have tried using the NTFS for Win98. I am having no luck. i have to have this sorted out by the morning :(  
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154143
do u share the root driver on winxp or just share a folder...
because u have to be aware of the folder name length of share winxp folder ,,win98 can't deal with large file name...
0
 

Author Comment

by:m_civitarese
ID: 12154183
I am sharing the root drive which is c:\ drive. I have given it all the appropriate permissions by going to safe mode (WinXP Home) and assigning full control to the user. i have tried giving full control to 'Everyone' i am at a loss. i have installed NetBUIE etc... on both systems. i have done everything that is in these forums regarding this topic.  :(  I desperately have to get this sorted out. Please what i wrote to begin with. It will tell most of what i have done :) Thanx
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154218
try to change the computer name at your winxp pc.....to somthing like " server "
0
 

Author Comment

by:m_civitarese
ID: 12154229
OK. I have tried that but no luck. Not quiet sure what the difference is between the name 'server' and the computer name i already had for WinXP Home; whic was just 'XP' as i have tried all sorts of names :|
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154231
Is browser service running and set up for automatic startup in the win98 "services"  control panel applet?
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154233
If the server service isn't started then you will not be able to see the win98 machine from the other machines.  (although you should still be able to access the others from the 98 machine;
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 5

Expert Comment

by:abu_deep
ID: 12154238
also try to check the error log ,may be you goanna figure out somthing like netbui was corrupt and went souninstalled and reinstalled may fixed the problem.
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154247
Worst case senario, you could install IPX/SPX protocol on each machine.  However, you can already see the Windows 98 machine.

Additionally, you can always open Windows Explorer and type \\192.168.0.20\ into the address bar instead of its NetBIOS name.  Sometimes that will bring up a file  listing as well.
0
 

Author Comment

by:m_civitarese
ID: 12154253
i have uninstalled all the prorocols and reinstalled them. i have ensured that the browser service is running. The Win98 cannot access the WinXP Home c:\ drive which is shared. i can ping both machines, i can see both machine i just cannot get win98 to be able to open the winxp home computer in the network neighbourhood folder.
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154267
just to make sure that u install NetBEUI corectly read this from previose answered quistion
'' how  Install NetBEUI on Windows XP
The files that you need for installing the NetBEUI protocol on Windows XP are Netnbf.inf and Nbf.sys. To install NetBEUI, follow these steps:
Insert your Windows XP CD-ROM in the CD-ROM drive and then locate the Valueadd\MSFT\Net\NetBEUI folder.
Copy the Nbf.sys file to the %SYSTEMROOT%\System32\Drivers folder.
Copy the Netnbf.inf file to the %SYSTEMROOT%\Inf hidden folder.

Note To make a hidden folder viewable, follow these steps:
Click Start, click Run, type Explorer, and then click OK.
Click Tools, click Folder Options, and then click the View tab.
Under Advanced Settings, click to select Show hidden files and folders under the Hidden files and folders Folder.
Click Start, click Control Panel, and then double-click Network Connections.
Right-click the adapter you want to add NetBEUI to, and then click Properties.
On the General tab, click Install.
Click Protocol, and then click Add.
Click to select NetBEUI Protocol from the list and then click OK.
Restart your computer if you are prompted to do this.
The NetBEUI protocol is now installed and working.
"
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154289
You may also need to change the network login preferences in W98 from "Windows Login" to "Microsoft Client for Windows Login" located under "Properties..." when right-clicking on the network Neighborhood icon.
0
 

Author Comment

by:m_civitarese
ID: 12154292
Thanx, but i have already done this. i cant understand why the Win98 can see the WinXP Home in network neighbourhood, but cannot access it. when i click onto i get a box that pops up saying;  Resource: \\SERVER\IPC$. then underneath that it asks for a password. The strange thing is this.... I have given them the both same workgroup name (MSHOME , which i have also tried WORKGROUP) so as i say they both ahve the same nam, but when I get the WIN98 to do a search for the WinXP Home (named 'SERVER') it apears on the screen with Name: Server and Location; UNKNOWN.
I dont understand this. Both machines are set the way everyone is telling me but still no luck. Time is running out. :(
0
 
LVL 5

Expert Comment

by:abu_deep
ID: 12154344
Sorry but here is my last idea ….try to logoff from win98 pc and login with Julie as a use name ..then try to navigate through winxp pc,,,,if u haven't done so..
0
 

Author Comment

by:m_civitarese
ID: 12154346
thanx :(  have also done this. made sure user id and passwords are the samw on the Win98 and WinXP Home. Thanx anyway :)
0
 
LVL 15

Accepted Solution

by:
adamdrayer earned 168 total points
ID: 12156450
A few things to try:

1. Make sure that simple file sharing is OFF!
  (in My Computer, Select Tools -> Folder Options - View)

2. manually create a share.
  right-click a folder and go to "sharing".  configure a share that gives everyone access.

3. Try doing this without NetBEUI.  People seem to have troulbe with it and XP, and it's not particularly useful with your setup
http://www.practicallynetworked.com/sharing/netbeui.htm
0
 
LVL 23

Assisted Solution

by:Tim Holman
Tim Holman earned 166 total points
ID: 12159549
Without stating the obvious... either turn off or reconfigure ICF.  

http://www.microsoft.com/windowsxp/using/networking/learnmore/icf.mspx
0
 
LVL 18

Assisted Solution

by:crissand
crissand earned 166 total points
ID: 12160936
Use another cable. Anyway, lose the netbeui and stay on tcp/ip.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Downtime reduced, data recovered by utilizing an Experts Exchange Business Account Challenge The United States Marine Corps employs more than 200,000 active-duty Marines with operations in four continents, all requiring complex networking system…
A common practice in small networks is making file sharing easy which works extremely well when intra-network security is not an issue. In essence, everyone, that is "Everyone", is given access to all of the shared files - often the entire C: drive …
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now