Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cisco 2950 setup - Gateway Required?

Posted on 2004-09-26
3
396 Views
Last Modified: 2008-02-01
I have 5 Cisco 2950's to replace my old SMC stuff. I've gotten as far as assigning Vlan1 an ip and subnet and setting a hostname and secret password etc..

My question is, Do I have to give the switch a Gateway address?
Is the gateway address supposed to be the Ip of the next switch its connected to or ?
At one point I have 3 switches connected together and the center one is connected to my firewall...should the gateway address be my firewall or the switch that is connected to to firewall or does it even matter?

Also Do I have to set the port that is connected to another switch as a 'trunk' or give it any special settings? (just cat 5 between them)

Thanks for any information.
0
Comment
Question by:Matrix1000
3 Comments
 
LVL 15

Accepted Solution

by:
scampgb earned 300 total points
ID: 12155495
Hi Matrix1000,
The IP address (and gateway!) that is defined on the switch is used for network management purposes.
It's not used by the switch to actually do it's job (switch data).

So, if the machine(s) you're using to manage this switch are on the same IP subnet as it, you don't need to define a default gateway.
If it's on a different IP subnet, you'll need to define it's gateway as being the same as the gateway IP address for all the other device on that (the switch's) subnet.

As for your trunking between switches.  You don't need to define that unless you're using multiple VLANs across the switches.

Does that help?
0
 
LVL 5

Assisted Solution

by:netspec01
netspec01 earned 100 total points
ID: 12155531
1. create a trunk to your next switch
2. create the VLAN on your L3 switch.  Give it an address (if using HSRP it has a virtual address)
3. assign the management VLAN ( VLAN 10 in the case below) an IP address.  In the case below it is 172.17.127.0/24.  This is to manage the switch.
4. connect your trunk ports (Gi0/0 & gi0/1 in this case) to your L3 switch trunk ports
5. clients connected to VLAN 80 on the access prots on this switch are in the DHCP scope 172.17.80.0/24 with default gateway of 172.17.80.1 (HSRP virtual address)

Here are some excerpts from a two-layer architecture (collapsed backbone).  Catalyst 6509 is te L3 switch and 2850 is the layer 2 switch.  Uplinks are dual Gig ports, one on each 6509 using HSRP virtual address as the gateway.  VLAN 1 has been disabled and VLAN 10 is being used as the management VLAN for all switches.  Hope this helps you get started.

L3 switch:

interface GigabitEthernet1/5
 description *** uplink VLAN connected to 2950 L2 switch ***
 no ip address
 speed 1000
 udld port aggressive
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk

interface Vlan80
  description *** access vlan 80 ******
 ip address 172.17.80.248 255.255.255.0
 ip helper-address 172.17.120.21
 ip helper-address 172.17.110.251
 standby 80 ip 172.17.80.1
 standby 80 priority 105
 standby 80 preempt

interface Vlan10
  description *** management VLAN ***
 ip address 172.17.127.2 255.255.255.0
 standby 10 ip 172.17.127.1
 standby 10 preempt

Layer 2 switch (2950 48-port with gig uplinks)

version 12.1
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname TXSW80-04
!
logging console informational
enable secret 5 ccccccccccccccccccccccc
!
clock timezone CST -6
clock summer-time CDT recurring
errdisable recovery cause udld
ip subnet-zero
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 switchport access vlan 80
 switchport mode access
 no ip address
 no cdp enable
 spanning-tree portfast
.
.
.  <output ommitted>
.
!
interface FastEthernet0/47
 switchport access vlan 80
 switchport mode access
 no ip address
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/48
 switchport access vlan 80
 switchport mode access
 no ip address
 no cdp enable
 spanning-tree portfast
!
interface GigabitEthernet0/1
 switchport mode trunk
 no ip address
 udld port aggressive
!
interface GigabitEthernet0/2
 switchport mode trunk
 no ip address
 udld port aggressive
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 ip address 172.17.127.83 255.255.255.0
 no ip route-cache
!
ip default-gateway 172.17.127.1
no ip http server
!
logging 172.17.120.69
snmp-server community cccc RO
snmp-server community cccc RW
snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart
snmp-server enable traps config
snmp-server host 172.17.120.69 version 2c noauth
!
line con 0
 password 7 cccccccccc
line vty 0 4
 password 7 cccccccc
 login
line vty 5 15
 login
!
! core switches provide time service
ntp server 172.17.127.2
end

0
 
LVL 11

Assisted Solution

by:PennGwyn
PennGwyn earned 100 total points
ID: 12161617
> My question is, Do I have to give the switch a Gateway address?

Only if it needs to be managed from outside of VLAN 1 for some reason, such as remote telnet (not recommended).

> Is the gateway address supposed to be the Ip of the next switch its connected to or ?

No.  The gateway address needs to point to a gateway (router, firewall, etc), not a switch.

> At one point I have 3 switches connected together and the center one is connected to my firewall...should the gateway
> address be my firewall or the switch that is connected to to firewall or does it even matter?

The firewall ... but see the first question.


> Also Do I have to set the port that is connected to another switch as a 'trunk' or give it any special settings? (just cat 5
> between them)

Only if you have other VLANs that need to span across multiple switches -- if so, you haven't mentioned them.


0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Stuck in INIT/DROTHER 2 49
VPS for routing recomendations 3 64
E-mail delayed during DNS server reboot 8 51
Draytek (Site to Site VPN using IPSec) 6 37
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question