Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Trying to share files on a LAN

Posted on 2004-09-26
8
190 Views
Last Modified: 2013-11-16
Hi,
I have a local network in my house of 3 or 4 computers. They are all connected to a hub which connects to a bridge via cat5 cable. The brdige communicates with a router wirelessly in the basement. I can access the internet fine, I am just trying to share files with my laptop (which connects directly to the router wirelessly) and am having some trouble. I look in My Network Places and either computer can't see the other computer even though they both have files shares. The desktop is runniing WinXP Pro and the laptop WinXP Home. I try to connect directly using the IP's (\\192.168.0.3), windows pauses for a while and then comes back and says it couldn't find it. Is there anything else I need to do? I remember when running an Win98 network, I would sometimes be able to see computers, sometimes not but I could always connect using the IP, now I can't even do that. Any help would be appreciated. Thanks.
0
Comment
Question by:SKG
8 Comments
 
LVL 8

Expert Comment

by:holger12345
ID: 12156445
If you want to use the IP you have to add the sharename... i.e. \\192.168.0.3\myshare  ... where "myshare" is the name you have chosen on the sharing PC for the shared directory.

Can you ping each other?
Do you use simple sharing (sharing with filepermissions or something similar - i'm german so i dont know the exact translation for the english version) or do you use sharing by user? Dont share with userpermission, as you can use it only well when you are logged in into a domain (and i think you aren't)
0
 
LVL 26

Accepted Solution

by:
Fred Marshall earned 400 total points
ID: 12156611
The ability to "see" other computers on the network depends on the protocols installed on them.
At least what's installed should be the same on all the computers.
It's best to have *only* TCP/IP installed and not NetBEUI or IPX.
(It may take 1/2 hour before the computers figure out they are all there).

The workgroup should be the same on all the computers.

Do you have firewalls installed like Norton Internet Security or Zone Alarm?'
If so, you need to identify the local network's IP range or individual addresses in the Trusted Zone for each of the firewalls/computers.
0
 
LVL 1

Expert Comment

by:CodeDevWiz
ID: 12157408
SKG,
     Are you using DHCP at all (Internet Connection Sharing, or real DHCP through a server)?  If so, did you check the IP addresses they are currently utilizing?  Just run "ipconfig /all" in a command line window to check this.  If they are running on the 169.254.0.0 subnet, they are not seeing the DHCP server.  Instead, they are using Automatic Private IP Addressing.
     Pinging these IP addresses (whether static or dynamic) is a good idea as well.  This will verify connectivity through TCP/IP.  Now, NetBIOS is a different problem, altogether, and you may want to verify the WINS settings on your networking connections to ensure that NetBIOS is being utilized, as this will aid in connecting to other computers.
     Another possibility you may want to check is the security settings on your router.  Is the router allowing traffic to be sent from the wireless connection on your laptop back to the wireless hub?  Just a thought.  

Good luck!
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 

Expert Comment

by:emacyam
ID: 12157531
SKG,

Did you setup your main computer with a domain or just a workgroup?  If it is on a workgroup, try this:

Steps:

1)  Check if your main computer is allowing users to connect remotely on the main computer:
Right click on My Computer.
Properties
Go to Remote Tab
Check and see if remote desktop is checked.

2)  Check if the drive you are trying to connect to and share files is shared.
Right click on the drive and click sharing and security.
Go to Sharing Tab
Look at Network and Security Sharing
See if Sharing this folder on the network is checked.  Name the drive.
If you plan to share/change files on this drive, then check the second option of allowing users to change files.

3)  On your laptop, go to start, run, and then type \\yourcomputername (not the workgroup name)

Hope this helps....

MS




Hope this helps...
0
 

Expert Comment

by:bipinpaulbedi
ID: 12157870
Just Enable File and Printer Sharing in Lan card properties and diable windows firewall.Enable Guest account and share what ever you want to share between computers.
0
 
LVL 8

Expert Comment

by:holger12345
ID: 12161646
@fmarshall: workgroups needn't be the same - they provide no other feature than grouping their members in the explorer together ... nothing else! It's another thing about domains...
0
 
LVL 2

Expert Comment

by:lyle-granger
ID: 12161774
Your computers should be configured to run as either a workgroup or a domain.  It sounds like a workgroup would work best in your situation (for networks with less than 10 computers).  They need to all have the same workgroup name, the defalut workgroup name is "workgroup", you can make it anything you want as long as they are all the same.  However with workgroups you must have the username and passwords all the same (on every computer) when you try to access shared resources (thus the benefit of a domain).  You will not notice this if you are accessing everything using the administrative account.  I am assuming that the router is giving out IP addresses.  If this is the case then you should be able to view the shares and the computers in my network places.  Hope this is helpful.
0
 

Author Comment

by:SKG
ID: 12205486
It was the firewalls that were causing the problem (windows' firewall). Seem to work now, thanks.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question