Solved

Security permission for local drive in windows XP

Posted on 2004-09-26
5
289 Views
Last Modified: 2013-12-04
I need assign full control of hard drive C to Everyone, it is required by our new software implementation. In windows 2000 I could highlight local drive C, go to property and change permissions under the security tub as needed. In windows XP this option is disabled by default. When I go to the property of the local C drive I can see only the sharing tub. How to change security permissions for Everyone? Is there a registry entry that can give access to the security tub? Help….ASAP
0
Comment
Question by:OlgaMaksimovich
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 38

Accepted Solution

by:
Rich Rumble earned 500 total points
ID: 12157110
Try turing off "Simple File sharing" in XP.
http://support.microsoft.com/default.aspx?scid=kb;en-us;307874

To disable simple file sharing, follow these steps:
Click Start, and then click My Computer.
On the Tools menu, click Folder Options, and then click the View tab.
In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box.
Click OK.

Also, when you need to add a group (like the Everyone group) to something in XP, typically you have to click the "Advanced" button, then click Search, and it will make a small list of known users and group's you can pink from. That's a pretty easy way of doing it.
-rich
0
 
LVL 15

Expert Comment

by:harleyjd
ID: 12157339
To display the Security tab
Open Folder Options in Control Panel.
Click Start, and then click Control Panel.
Click Appearance and Themes, and then click Folder Options.
On the View tab, under Advanced settings, clear Use simple file sharing [Recommended].

0
 
LVL 15

Expert Comment

by:harleyjd
ID: 12157344
ahaha caught again

Open a question, then reply an hour later!
0
 
LVL 1

Expert Comment

by:ransoneb
ID: 12161078
Is the volume NTFS?  If not, you won't see a "security" tab.  You will have to convert to ntfs using

convert c: /fs:ntfs

i will require a reboot.  Then you will see a security tab.
0
 
LVL 1

Expert Comment

by:CodeDevWiz
ID: 12163557
Of course, if you don't have NTFS you are running FAT<16 or 32>, C: is already at Everyone:  Full Control.  Otherwise, the Simple File Sharing comments should work for you.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
Users of Windows 10 Professional can disable automatic reboots using the policy editor. This tool is not included in the Windows home edition. But don't worry! Follow the instructions below to install (a Win7) policy editor on your Windows 10 Home e…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question