Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4706
  • Last Modified:

How to increase the buffer size of IIS server?

I have IIS5.0 server and the sql server returns 6000 records. The problem is buffer over flow. I have to increase the buffer size how to do that?

0
ajaypappan
Asked:
ajaypappan
  • 6
  • 6
  • 4
1 Solution
 
alimuCommented:
Just a few questions -
What's the actual error and where did it come from (asp page, event log, iis logs)?  
Is there an error number associated with the error?

Was error generated by IIS or SQL itself? (You can test by running the query directly against SQL and seeing if the result set is returned successfully - SQL will only return about 8KB maximum data in a resultset).

What connection type are you using from your web page? (OLEDB ODBC)?
0
 
ajaypappanAuthor Commented:
Error- Exceeded Buffer Size
0
 
ajaypappanAuthor Commented:
it came from asp page
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
alimuCommented:
ok - have you tried running the query through sql query analyser to check that it is successful there?

Take a look at this ms article about how to change MaxClientRequestBuffer in the registry (and also why it was implemented to protect your server): http://support.microsoft.com/default.aspx?scid=kb;en-us;260694

Would recommend finding a way to pull your data across in chunks so the query responses aren't so huge.
Another thing to take note of is that if you have response buffering turned on, the browser page will remain blank  until all query results/scripts have finished processing (ie. this has the potential to be a very slow page).

0
 
kmorris1186Commented:
Open IIS (right click on My Computer, click on manage. Expand Services and Applications).  Next, Right click on Internet Information Services and goto Properties.  Cick the check box "Enable Direct Metabase Edit". Next goto Start, Run and type in this "Notepad c:\windows\system32\inetsrv\metabase.xml".  Press Control F (Find) and search for this string "AspBufferingLimit".  The default value is 4194304. (4 mb) change that to 10000000 (10mb or higher depending on your needs. Save the file (control S).  Restart IIS.

Again, you should pull that data some other way as other have suggested, but this will be an imediate fix.
0
 
alimuCommented:
um... kmorris1186 - solution is good for iis 6 but the metabase is not in xml under iis 5.  See my previous post for editing the same setting under iis 5.
0
 
kmorris1186Commented:
Sorry, thought you had IIS 6.  Let me see how to change that on IIS 5.
0
 
kmorris1186Commented:
Try adding this to your code

Response.Buffer = False

0
 
ajaypappanAuthor Commented:
i am sorry guys i have IIS6.0, i will give u points to both of u
0
 
ajaypappanAuthor Commented:
i dnt know how to give points to both of u guys alimu and morris
0
 
alimuCommented:
If you want to change points assignment post a link to this question in community support http://www.experts-exchange.com/Community_Support/ with a description of what you'd like to do.

Another tip - if you set Response.Buffer = False, your buffer is off and results are displayed as received.  You need to ensure your script timeouts are long enough that your script won't terminate before your resultset finishes displaying.  

Having the buffer turned on keeps the script running until all processing completes, avoiding timeout issues that you would  have to watch for with no buffer.
0
 
kmorris1186Commented:
FYI = this is the error i get when i try to add "Response.Buffer = False" to my code under IIS6.

Response object error 'ASP 0157 : 80004005'
Buffering On
/untitled-1.asp, line 12
Buffering cannot be turned off once it is already turned on.

Does this even still work in IIS6?
0
 
ajaypappanAuthor Commented:
Yes i am getting the same error...
0
 
alimuCommented:
do you mean in sql (if this is the case you definitely have to change the way you query and split it into chunks - recordsets of less than 1000 rows are more suitable for web delivery).

if you mean same error after increasing buffer - what's the buffer size set to now?
0
 
ajaypappanAuthor Commented:
Yup Iam doing page split
0
 
alimuCommented:
ok - good idea
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 6
  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now