• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 336
  • Last Modified:

Setting up Tape drive in fedora

Hi EE,  I have a linux box running fedora core2 .  I have added a scsi controller and a tape drive. (DDs3)  When I run hardware browser, the tape drive shows up as /dev/st0 .  When I run kdat however it cant read the drive.  Can anyone tell me how to go about setting this up
0
aduhwale
Asked:
aduhwale
  • 6
  • 6
1 Solution
 
EinarThCommented:
uhmm... have you gone into kdat's settings and set the drive option there to /dev/st0 (or created a /dev/tape -> /dev/st0 symlink)?
0
 
aduhwaleAuthor Commented:
Hi, I went into kdat's settings and set the option there but didnt work,  I havent done a symlink how do I do that?
0
 
EinarThCommented:
ln -s /dev/st0 /dev/tape

There is a very old tape backup program called taper that I used in the days of yore (command line tool). it's very simple in its basic form, so if that one works, you'll at least know it's kdat thats bugging you.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
aduhwaleAuthor Commented:
Hi , tried the symlink. nothing happening.  Tried dmesg|more to see the scsi entry, here it is

SCSI subsystem initialized

scsi0 : AdvanSys SCSI 3.3GJ: PCI Ultra: IO 0xB800-0xB80F, IRQ 0x9

  Vendor: ARCHIVE   Model: Python 04106-XXX  Rev: 7550

  Type:   Sequential-Access                  ANSI SCSI revision: 02

st: Version 20040318, fixed bufsize 32768, s/g segs 256

Attached scsi tape st0 at scsi0, channel 0, id 0, lun 0

st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA 1048575


tried using tar directly
tried mt status and it doesnt find /dev/tape, tried -f /dev/st0 still nothing.  Terribly stuck here....
0
 
EinarThCommented:
Post the output from the following commands:
ls -l /dev/st0
mt -f /dev/st0 status
mt -f /dev/st0 rewind

... You are doing this as root, right?
0
 
aduhwaleAuthor Commented:
root@lunmail2 root]# ls -l /dev/st0
crw-rw----  1 root disk 9, 0 Feb 23  2004 /dev/st0
[root@lunmail2 root]# mt -f /dev/st0 status
/dev/st0: No such device or address
[root@lunmail2 root]# mt -f /dev/st0 rewind
/dev/st0: No such device or address
[root@lunmail2 root]#
                                                                               
0
 
EinarThCommented:
well, I'm at a loss. The only thing I can think of is that maybe your scsi driver isn't loaded, but that doesn't really make much sense, since dmesg shows that the driver has probed the scsi bus.

Just to make sure about all this, do a 'lsmod' and post the output. Also post the make and model of your scsi card and how that driver is loaded if you have that info.

cheers.
0
 
aduhwaleAuthor Commented:
Hi Scsi card - AdvanSys SCSI 3.3GJ: PCI Ultra: IO 0xB800-0xB80F, IRQ 0x9

output from lsmod.

Module                  Size  Used by
snd_mixer_oss          13824  2
snd_intel8x0           26280  3
snd_ac97_codec         50436  1 snd_intel8x0
snd_pcm                68872  1 snd_intel8x0
snd_timer              17156  1 snd_pcm
snd_page_alloc          7940  2 snd_intel8x0,snd_pcm
gameport                3328  1 snd_intel8x0
snd_mpu401_uart         4864  1 snd_intel8x0
snd_rawmidi            17184  1 snd_mpu401_uart
snd_seq_device          6152  1 snd_rawmidi
snd                    38372  10 snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               6112  3 snd
i830                   55856  2
parport_pc             19392  1
lp                      8236  0
parport                29640  2 parport_pc,lp
autofs4                10624  0
rfcomm                 27164  0
l2cap                  16004  5 rfcomm
bluetooth              33636  4 rfcomm,l2cap
sunrpc                101064  1
8139too                17792  0
mii                     3584  1 8139too
ipt_REJECT              4736  1
ipt_state               1536  8
ip_conntrack           24968  1 ipt_state
iptable_filter          2048  1
ip_tables              13440  3 ipt_REJECT,ipt_state,iptable_filter
floppy                 47440  0
sg                     27552  0
st                     31132  0
scsi_mod               91344  2 sg,st
microcode               4768  0
dm_mod                 33184  0
uhci_hcd               23708  0
ehci_hcd               21896  0
button                  4504  0
battery                 6924  0
asus_acpi               8472  0
ac                      3340  0
ipv6                  184288  10
ext3                  102376  4
jbd                    40216  1 ext3
raid1                  10240  5
---------------------------------------------------------------------


I dont know how to get the driver info.   could you help there?
0
 
EinarThCommented:
hmm... why isn't your advansys module there?

Try (as root of course) to:
# modprobe advansys
# mt -f /dev/st0 status

and see what happens
0
 
aduhwaleAuthor Commented:
[root@lunmail2 root]# modprobe advansys
[root@lunmail2 root]# mt -f /dev/st0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 512 bytes. Density code 0x25 (DDS-3).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN
[root@lunmail2 root]#


Ur a star!.  After running this, the tape drive worked.  Is there anything I need to do to ensure I dont lose this after I reboot?

0
 
EinarThCommented:
Well, different distros use different mechanisms for this stuff and I have never used fedora myself so I dont know the correct way to do this. Fedora propably _does_ load it at boot time, but if it remains unused for a long time, it may unload it.

Anyhoo, you can manually load the module during boot (if it doesn't happen) by adding 'modprobe advansys' to the correct rc file in /etc/rc.d/

Again, I dont know fedora, but its propably called rc.local or rc.boot or rc.sysinit.... You catch my drift.

Furthermore, your propably going to want to script your backups, so adding the modprobe line there shouldnt be a big deal

cheers.
0
 
aduhwaleAuthor Commented:
Oki doki!  Thanks again!  
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now