3550 cisco switches not talking VTP


I have 2 3550 switches connected via fiber GIBIC ports, they both are set to Here is the config
Switch 1
!
interface GigabitEthernet0/1
 description Fiber to 3570-SWIT-07
 switchport trunk encapsulation isl
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/2
 description Fiber to 3570-SWIT-02
 switchport trunk encapsulation isl
 switchport mode trunk
 no ip address
3570-SWIT-03#show vtp status
VTP Version                     : 2
Configuration Revision          : 6
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 8
VTP Operating Mode              : Server
VTP Domain Name                 : Ai-Shreveport
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x66 0xF3 0x7D 0x35 0x0C 0xF5 0x2E 0x0F
Configuration last modified by 10.6.1.10 at 5-19-93 08:33:52
Local updater ID is 10.6.1.8 on interface Vl1 (lowest numbered VLAN interface found)

Switch 2
interface GigabitEthernet0/1
 switchport trunk encapsulation isl
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/2
 switchport trunk encapsulation isl
 switchport mode trunk
 no ip address
!
3570-SWIT-07#show vtp status
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : Ai-Shreveport
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xA8 0x5A 0x14 0xCE 0x41 0x8D 0xA7 0x98
Configuration last modified by 10.6.1.12 at 6-6-93 18:59:32
Local updater ID is 10.6.1.12 on interface Vl1 (lowest numbered VLAN interface found)

Switch 07 is not receiving Vlan updates from Switch 03, any ideas???
JffishbonesAsked:
Who is Participating?
 
JFrederick29Commented:
A suggestion, use 802.1Q trunking instead of ISL:

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q

In regards to VTP not propogating, do you have a VTP password set?  If so, make sure it is the same on all switches in the VTP domain.

Use the command "show vtp statistics" to view if errors exist and to make sure it is receiving advertisements.
0
 
PennGwynCommented:
Should they both be VTP servers?  Shouldn't one be a client?

(The updater addresses may be a clue.)

0
 
JFrederick29Commented:
VTP Servers still update eachother but they are able to make VLAN changes locally.  VTP Clients receive VLAN changes but can not create updates.  It's good design to have multiple VTP Servers for redundancy and the rest be clients.  Nevertheless, VTP servers update VTP servers as long as they are in the same VTP domain.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
lrmooreCommented:
Why not simply manage the 2 switches as one "cluster" and you don't have to worry about VTP propogating...

>Configuration Revision          : 6

>Configuration Revision          : 1

The switch with the highest Config Rev number will propogate its VLAN configuration to the other. If you used 3570-SWIT-07 to define the VLAN's, then plugged them together, as soon as the trunk was established, the VLAN config from 3570-SWIT-03 (config Rev 6) was propogated to SWIT_07, overwriting the vlan definitions that you put into that switch...

0
 
JffishbonesAuthor Commented:
Switching Trunk encapsulation is not an option as I have a total of 6 switches on this lan all running ISL. No VTP password is set. I am going to try and bounce the interfaces this weekend as these devices are in use 24 hrs 5 days.
0
 
z71mike8379Commented:
VERY VERY EASY ANSWER  (as PennGwyn put it)

make one of them "vtp client"

ALSO....

You should identify a native VLAN for the two interfaces to communicate over.  That will also help with your problem.  The interfaces will default to VLAN 1 if not otherwise specified.  But much like "auto-negotiate on a UTP port" not negotiating properly with some NICs......it is possible to experience similar issues over GBIC ports "auto-negotiating" (defaulting) to VLAN 1 as the native VLAN.

swithport trunk native vlan ???      !take your pick of something other than default

Everything else is fine.  You do not need clustering, nor dot1q encapsulation.  Make those two changes and the interfaces will come right up.
0
 
JffishbonesAuthor Commented:
It was a conflict of vtp passwords. Thanks again to all.

Jim
0
 
dlitty7Commented:
Hey, this was the EXACT question I needed answered today!!!  I wish I could give more points!  this was an EXCELLENT resource!!
0
 
z71mike8379Commented:
glad to see it helped.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.