• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 914
  • Last Modified:

panic: utf16_to_utf8: odd bytelen

i have recently installed activestate on my laptop, which is running xp.  i tried to run a simple test perl script from the dos prompt and received this error message:
panic: utf16_to_utf8: odd bytelen

i installed cygwin and tried again, and got the same prob.  i googled this and  turned up this info:

(P) Something tried to call utf16_to_utf8 with an odd (as opposed
to even) byte length

how do i fix this?  i had no problem at my  work pc.  my home laptop has recently been upgraded.  it has a partitioned drive and is running vm ware.  i don't know if this has anything to do with the problem.  i doubt it.

i am new to this, so please be specific.

  • 2
2 Solutions
This might be more serious than just simple troubleshooting.
I would change the version of the Perl engine to check if this is a version-related issue and if it is, would follow up with ActiveState and send them a support request with the sample of your script that you attempted to run as well as some details of your installation (version of Perl, location of the installation and some generic parameters from your laptop like installed Hotfixes and Option Packs as well as a list of software installed on the PC to see if there are any conflicts)
Collect all the info, at this not-working state, uninstall Perl, get an earlier version (if you have Perl 5.8, then get 5.6) and install it.
If you have installed an earlier version of Perl, then get the latest one just to change the version.

This might be one of those rare cases of untested variations of the code installation.

Any company tests the software before the release, but it is extremely hard to test all possible scenarious and fix the errors and sometimes it requires a fix or a code update.

It might be that even if it was tested before, later on some Microsoft Hotfix blocked functionality in an updated dll or upgraded a dll file, that Perl relies on, so there could be no way for ActiveState to actually prevent it from happening at the first place and it would  require a code change.

What was the test script you tried to run?
worldfearAuthor Commented:
its not the script, which is just to test the install:
print "test\n";
worldfearAuthor Commented:
ok, it seems i am a total moron.  let me explain.  i am a librarian and have just started taking a class on perl programming.  my only other programming experience is javascripting, vba with access, and a little java.  

i saved my program as a plx file and had no problem running it.  i know nothing about perl or unix or dos, but am taking classes.  

i'll split the points for this "very difficult question" (ha!)  if you want, you can enlighten me as to how perl runs scripts -- i am used to writing code in some kind of dev environment and compiling it.

thanks and sorry to take your time.  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now