Solved

Can't Connect to OWA 2003 server that is sitting behind an OpenBSD Firewall/Web server using port forwarding

Posted on 2004-09-27
3
372 Views
Last Modified: 2008-03-03
Our company uses Exchange as it's groupware solution and apache webserver on openbsd unix as the firewall/web server for the company's web site.  We have an SBS 2003 server set up to host exchange. I can connect to OWA 2003 from any internal/private ip computer just fine.  However, I can't connect to OWA 2003 from the internet (i.e. at home).  Because I want requests to port 80 and 443 to be answered by the OpenBSD box (apache webserver) I have used port forwarding to forward requests for OWA/IIS access to ports 8080 (port 80) and 4430 (port 443) on the openbsd box.  These ports map as follows:

Port 8080 on Unix firewall maps to port 80 on SBS 2003 server
Port 4430 on Unix firewall maps to port 443 on SBS 2003 server

So for example to get to our corporate web site you would type http://www.corporatewebsite.com

However, to get to the IIS box and access remote web workplace, owa, etc, you would type https://www.corporatewebsite.com:4430

So far I have not been successful getting this to work.  I have searched and searched and searched.  Any help you can offer me would be great.  I can get to the remote web workplace screen where I have options to connect to a server, client, email etc, however, I can't get OWA to work...it just sits there and the screen goes blank.

Any ideas?
0
Comment
Question by:lowrycito
3 Comments
 
LVL 6

Expert Comment

by:chumplet
ID: 12164575
Do you have IIS on the Exchange/SBS server listening on those ports, or are they still set to listen on 80/443?
0
 

Author Comment

by:lowrycito
ID: 12164615
I never changed the default settings of the Exchange/SBS server...I believe they have always been set to listen on 80/443.  The firewall rules on the unix box are set to forward port 8080 to port 80 on the SBS box and port 4430 to port 443 on the SBS box.  Does that answer your question or did I misunderstand.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 12170967
OWA doesn't like operating over other ports. I have seen nothing but problems with using other ports - go back to the ports it expects and everything works fine.
You must remember that OWA is a complex web application and there is a lot a communication between the client and the server. It is expecting that traffic to be on port 443 or 80.
Then you may get users on a site where port 80 and 443 are the only ports allowed out and they will not be able to use OWA at all.

If possible I would look at using another subdomain (mail.domain.com) and allowing the connection through on the ports that it expects - possibly 443 only to maintain security.

Simon.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now