Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 801
  • Last Modified:

RDP sessions from NAL not working

We are running NetWare 6.5 Servicepack 2 with Zenworks for Desktops 4.0.1 Interim Release 4a.
Several of our applications run in a terminal server environment and we're using NAL to distribute these applications.
We have a MetaFrame server for legacy applications and a Windows 2000 Terminal Server for new applications, so we use both ICA and RDP.

ICA sessions work just fine, however the RDP sessions are not working at all.
The user doubleclicks on the NAL icon for the RDP session and nothing happens, only the hourglass for a few seconds and then nothing.

I performed a search on the workstations for mstsc.exe and tried to connect using this tool, no problems at all.
Why doesn't it work using NAL?

Any help would be very appreciated.

Ruben
0
RubenvdLinden
Asked:
RubenvdLinden
  • 5
  • 4
  • 3
  • +1
1 Solution
 
DSPooleCommented:
what exactly is the NAL object defined as?
0
 
ShineOnCommented:
DSPoole, are you thinking it might be set up as a "distribute only" instead of a "run program" type of app?  That's what I'm wondering.

RubenvdLinden, do you have any of the application object logging turned on, so you can see if it's doing something besides making the hourglass appear?
0
 
RubenvdLindenAuthor Commented:
The NAL objects are defined as Terminal Server Applications.
I turned on application logging (Common > Reporting) on a test application.

The contents of the logfile:
"Distribution Success","20","29-09-2004 12:57:47","RUBEN.USERS.ZCW.ZORGCIRKEL",".WORKSTATION NOT REGISTERED","100.10.2.231","TEST.APPLICATIONS.ZCW.ZORGCIRKEL","1EC3A878-9328-48D4-9B29-49A48C97BD64","","0","0","","","","","","524288"

"Launch Success","10","29-09-2004 12:57:47","RUBEN.USERS.ZCW.ZORGCIRKEL",".WORKSTATION NOT REGISTERED","100.10.2.231","TEST.APPLICATIONS.ZCW.ZORGCIRKEL","1EC3A878-9328-48D4-9B29-49A48C97BD64","","0","0","","","","","","524288"

"Application Termination","70","29-09-2004 12:57:50","RUBEN.USERS.ZCW.ZORGCIRKEL",".WORKSTATION NOT REGISTERED","100.10.2.231","TEST.APPLICATIONS.ZCW.ZORGCIRKEL","1EC3A878-9328-48D4-9B29-49A48C97BD64","","0","0","","","","","","524288"

Hopefully, it's of any use to you.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
ShineOnCommented:
So, is this a NAL app that is intended to run ON a Terminal Server session or a NAL app that is intended to LAUNCH a Terminal Server session?  I think that's where I'm confused.  Your question led me to think it was one intended to LAUNCH a Terminal Server session.

At any rate, the logfile is telling me that the application is distributing an app, starting it, and it is finishing.  Without knowing more, that really doesn't help much.  

Can you describe the app object a bit more?  Is it for starting a TS session, or for use during a TS session?
0
 
RubenvdLindenAuthor Commented:
The app starts a new Terminal Server Session.
0
 
DSPooleCommented:
I don't think you can put a NAL object out there like that intended to be launched by another application.  For instance, you can't put out a NAL object of an Excel file and expect Excel to launch when the NAL object is selected.

We use something called APPLOAD.EXE (downloadable from Cool Solutions) that allows an application file to be launched by it's registered application.  (ie:  APPLOAD.EXE FILE.XLS would launch Excel and open FILE.XLS)

You could create a NAL object with APPLOAD.EXE and use it's command line parameters to specify the TS Session config file.  That should work.

Another option is to create a NAL object with the application that is registered to use the TS Session config file and use it's command line parameters to properly specify the config file - assuming it takes command line parameters.  If it doesn't, then APPLOAD.EXE is your only solution.
0
 
ShineOnCommented:
If you have a shortcut to an executable on someone's desktop, that launches a new TS session, you should look at the properties for the shortcut and use the same executable in the NAL app.  If you need to, you can also ship out with the app any config files or whatever, to make sure the user's PC has what is required.
0
 
RubenvdLindenAuthor Commented:
With ZENworks for Desktops 4.0.1 it's possible to launch a terminal server session, either ICA or RDP.
The application object type is "Terminal Server Application".

ICA sessions work, RDP sessions don't -> only the hour glass for a few seconds.

I changed some settings in the DeFrame configuration and now at least I get an error message!
The error message is:
dappx
Your DeFrame password was not found. Please contact your administrator.

My user is a DeFrame user and there's also a user account with the same password on the Terminal Server.
0
 
ShineOnCommented:
Could any of these apply?

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10076722.htm
http://support.novell.com/cgi-bin/search/searchtid.cgi?/2966056.htm

And - from 4.01b IR readme:

     9.3 Application Management Issues

          9.3.1 Contextless Login Support on DeFrame Terminal Servers
                 Using Novell Client 4.9

                 In order for DeFrame contextless login to work on a
                 DeFrame terminal server that has the Novell Client for
                 Windows NT/2000/XP version 4.9 installed, you must
                 disable the Novell Client's NMAS Authentication setting.

                 The NMAS Authentication setting is enabled by default
                 when you install the Novell Client. To disable NMAS
                 authentication:

                  1. At the DeFrame terminal server, right-click the N
                     icon in the system tray, then click Novell Client
                     Properties.

                  2. In the Advanced Login tab, deselect the NMAS
                     Authentication check box.

                  3. Click OK to save your changes.
0
 
DSPooleCommented:
ah, that would explain why I didn't know - still using ZfD3.2 here.  Won't move to ZfD6 (which we have) until our network upgrade is done this year.
0
 
RubenvdLindenAuthor Commented:
OK, this is how I solved it:

Turned off the user context and server in the default profile to enable the contextless login; this didn't work.
Opened the HOSTS file on the Terminal Server and added an entry for the eDirectory tree.

Now it works, for some reason it couldn't resolve the tree name.
0
 
ShineOnCommented:
One thing that works for me is to add an A record to DNS that resolves the tree name to the IP of the SLP DA server.  Adding the SLP DA server service type to the DHCP server works, too.
0
 
ee_ai_constructCommented:
Question answered by asker or dialog valuable.
Closed, 250 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 5
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now