USB memory sticks and Windows XP

Hi,

Since upgrading our student computer labs to Windows XP, USB memory sticks aren't working. For some reason unknown to me, Windows XP tries to assign the drive letter F: to the USB memory stick. We never had the problem with Windows 2000.

The student accounts are restricted, so they can not be given rights to set the drive letter themselves in the drive manager, so, is there a way that you guys know of that I can force Windows XP to automatically set USB flash sticks to, say, drive e:?

Any help would be appreciated.

Regards,

Kobus
North-West university
Vanderbijlpark
South Africa
FolkLoreAsked:
Who is Participating?
 
Jupiler78Connect With a Mentor Commented:
Wow, very strange

What is in your registry key HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

for the dosdevices?
0
 
Jupiler78Commented:
As far as I know there isn't any way,  except for inserting the stick and then let someone with more rights change the letter in drive-management or in the registry. But this only works if everybody ahs the same type of USB stick
0
 
FatherErvinCommented:
Maybe if you install each one yourself logged in as admin, then assign the drive letter to E:\ ? when the students log in, and insert the USB stick, it should be redetected as it was installed?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Jupiler78Commented:
FatherErvin, for what I have noticed does Windows see a different device even between 2 USB-sticks of the same company but with different capacity. E.g. 2 sticks of 64Mb and one of 128Mb are different to Windows, so also different drive-letters
0
 
FolkLoreAuthor Commented:
The problem is that we have over 3000 students, and only like 100 computers. That means that setting the value manually for each student is not only impossible, but also impractical. I hope someone else can come up with some other solution!
0
 
Jupiler78Commented:
I found this on Microsofts site: http://support.microsoft.com/default.aspx?scid=kb;en-us;297694

Take a look at it and maybe you can take advantage of it.

How does the list of your drive-letters looks like?
0
 
FatherErvinCommented:
Well, depending on your network drives... maybe you can assign lastdrive=E:\ ??
0
 
FolkLoreAuthor Commented:
We have C: for the harddisk, G: for the CD-ROM, then several drive letters for the network, including F:, H:, X:, Y:, Z:.

What gets to me is the fact that it can choose D: or E: for the drive letter, why does the silly thing *WANT* to use F:?

I will check out the reference on MS's website you provided, thanks!

Kobus
0
 
Jupiler78Commented:
And nothing is mapped to D or E ? MS says this would be the reason: an USB device would take the next availeble drive-letter after all physical drives
0
 
FolkLoreAuthor Commented:
I have read the site, and it will not work for me, because I have no control over how the network drives are mapped. That job is done by the IT department at our main campus when they set up the Novell login scripts, which I am not allowed to change. I saw the note at the end that shows how different this situation is handled between Windows 2000 and Windows XP and that also explains to me why the problem is there, but there is no solution to the problem on that page that I can implement, because I can't change the network drive mappings.

Thanks for your attempts, Jupiler78!

As for your comment, FatherErvin, I will have to check it out, as my network drives start at F:.  I'll get back to you on that one, thanks!

Regards,

Kobus
0
 
FolkLoreAuthor Commented:
Nope, nothing is currently mapped to D: or E:... that is what makes it so confusing for me!

Regards,

Kobus
0
 
Jupiler78Commented:
OK, I'll keep looking. So I can't say more then good luck
0
 
FolkLoreAuthor Commented:
Increasing the value of this question by 50.

Thanks,

Kobus
0
 
rustyrpageCommented:
What about just moving all of the CD-Roms (I know, 50 computers is hard to do that on...but it would work) to D & then automatically & memory device would be put to E (since that is the next letter after the last physical drive).
0
 
FolkLoreAuthor Commented:
Oh, so what you are saying is that the fact that the CD-ROM is currently located at G: is confusing the system, since there is a physical drive after a mapped network drive?

Ok... this is a huge thing to go and do, but I will check it out with one or two and see if this works.

Thanks for the comment. I will keep you posted.

Regards,

Kobus
0
 
rustyrpageCommented:
I am pretty sure that is what the issue is....it can't put removable media on drive letters between other hardware drives...it has to do it after the others.  I know it's a lot of work to do, but I believe it to be the only solution
0
 
Jupiler78Commented:
Rustyrpage, you say you are pretty sure what the issue is, but following the MS documentation and your own it has to put removable drive letters after the other, but as far as I know the alphabet, it is ... D: E: F: G: H: and then I would say it should take H: as the problem letter? Or I'm I thinking completely wrong here ?
0
 
rustyrpageCommented:
I don't know where you are getting that from....it puts the removable drives after the last HARDWARE drive.  (ie, hard drive or CD-Rom).  So, if he moves the CD-rom to drive D:, then what's the next letter in the alphabet?....E:.   So, C = Hard drive, D = CD Rom & E = Removable storage.  Then F, G, H etc would then be network drives (that are mapped via login script or something)
0
 
Jupiler78Commented:
Yes, but at this moment his last HARDWARE DRIVE is G: = CD-ROM so the next one should be H: and not F:
0
 
rustyrpageCommented:
That is true...it doesn't make sense then...but still he should try it.

Read your own article you found & the quote you put:  MS says this would be the reason: an USB device would take the next availeble drive-letter after all physical drives.  

It takes the next available after all physical drives.  The only thing I can think is that it doesn't see the CD-Rom the same way (as a "Physical" storage drive).  However, if you move the CD-Rom to Drive D, then FOR SURE, the next available drive letter is E.  

What would hurt in trying that?
0
 
Jupiler78Commented:
I agree totally with you that he should try that. But I though you knew something more about this exception?
0
 
rustyrpageCommented:
No...it seems VERY strange what is going on...I have experimented on my computer & every time it does assign the memory card to the next available.  For example...I have a 6-in-1 reader...I plug it in...the first drive is letter D (because my CD-RW is letter E), then all the rest come in at F, G, H, I, J....strange, let's see what happens
0
 
Jupiler78Commented:
Good point we will wait for FolkLore to give the answer to the test
0
 
FolkLoreAuthor Commented:
I hate to bring this to you, but after testing this extensively with several computers, this problem still is not solved. The CD-ROMs are set back to D: and there are no logical drives after D:, so logically I'd say that the flash disks should be picked up as E:, but for some reason it doesn't work. I have no more ideas, and to the person who can solve this problem, 400 points is awarded...

What we have noticed, however, is that if you insert the flash stick, and keep it there while rebooting the computer and then log in again, the flash disk works fine. It takes over the mapping of the network drive, which is F:...

Regards,

FolkLore
0
 
FolkLoreAuthor Commented:
Jupiler78,

I haven't forgotten about your suggestion yet. I have been out of office for over a week. When I checked the dosdevices, there were several dos devices, I assume that it was because of the various flash disks that have been put into the machine before.

The letters that were assigned to dos devices were:

C:
D:
E:
G:
H:
I:

When looking in Windows Explorer, Only C: and D: actually shows up, and if I insert my flash disk, it shows E:, and I guess the other 3 are other flash disks that used to be in that machine before.

I deleted all of those "extra" dos mappings and restarted the computer, and will do some further tests. If this solves the problem, I will write a registry script that will delete all those drive letters at startup, and if that works, I will allocate these points to you, as you would have put me on the right track then!

Regards,

Kobus/FolkLore

0
 
Jupiler78Commented:
Thanx. I really hopes it works, Kobus!
0
 
FolkLoreAuthor Commented:
Ok... I have written the registry script to delete the dosdevices upon login, and it seems to work with my flash disk. I am just looking to find a few people with different brands and sizes of flash disks to see if it works as well, and then I will close this question.

Kobus/FolkLore
0
 
Jupiler78Commented:
Ok, let me know
0
 
FolkLoreAuthor Commented:
Tested it with 3 different flash disks. Now I am going to implement it in the labs. But I can't do it now, because there are classes going on at the moment. In the mean time will test with a few more flashdisks if I can find them! I consider this question closed. Thanks, Jupiler and everyone else who contributed!

Regards,

Kobus/FolkLore
0
 
Jupiler78Commented:
So it actually worked. Glad I could help

jupiler78
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.