?
Solved

Guest default login?

Posted on 2004-09-28
27
Medium Priority
?
634 Views
Last Modified: 2008-02-01
When i try to connect to a remote Pc, the default username is <computername>/Guest.  I want to be able to enter the username.  At this point the username field is greyed out and i cant change it from guest.  Is this on the remote PC or the one i am connecting from?

BTW - Both PC were freshly formated with SP1 installed (NOT upgrading to SP2).

Any ideas?
0
Comment
Question by:kmorris1186
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 7
  • 3
  • +4
27 Comments
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170211
Example.  I am at Pc1 (named HomePC1) and i want to connect to PC2 (named HomePC2).  I goto start, Run and type in "\\HomePC2\" to see a list of shares.  Is displates the login box but i cant change the username from HomePC2/guest.

the same thing happens when i try to connect from PC2 to PC1.
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170227
My simple work around was to RE-Enable the Guest Account and give it a password.
0
 
LVL 2

Expert Comment

by:dev8
ID: 12170288
Make sure to run the local security policy editor from control panel admin tools (can also try gpedit.msc from run) and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure that the guest account is enabled.  Hope that helps!
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 
LVL 7

Author Comment

by:kmorris1186
ID: 12170335
And that will stop "<pcname>/guest" from being the default username and/or let me change the username?
0
 
LVL 2

Expert Comment

by:dev8
ID: 12170352
Yes.  That will fix it ;)
0
 
LVL 6

Expert Comment

by:mslunecka
ID: 12170356
Check your permission levels on your shared folders.  Both under the Sharing tab, and under the Security tab.

You may have the Everyone group in the default permissions set with full control.  If that was the case, windows may not feel the need to let you change users.  If you restrict access to administrators only, or create ACL entries (access control list) for specific usernames e.g. "HomePC1\Username" it may allow that field to become editable.

You definitely want to disable that guest account, though.  If you see Guest having any kind of privileges in the security or sharing tabs, pull it out.

You could try this command as well.  start->run->\\HomePC1\c$

This accesses the administrative C$ share.  You don't have to have any file sharing enabled to use it.  You'll just have to type in an administrator's user name and password and you'll be right into your C drive.
0
 
LVL 2

Accepted Solution

by:
dev8 earned 800 total points
ID: 12170379
Err!  Instead of the "Let everyone permissions apply to anonymous users", change the Network Access: Sharing and security model for local accounts by right clicking, properties and changing from Guest only to Classic.  Now that should fix it!

0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170413
That is the problem... if i try to access \\HomePC1\c$, the username is already set to" homepc1\Guest".  I cant change this.. It is greyed out.   i am trying the GPEdit thing now..

I have the Share set up for Everyone, as i am going to use NTFS to control what can/cant be accessed.  Still the Username field is greyed out.
0
 
LVL 2

Assisted Solution

by:dev8
dev8 earned 800 total points
ID: 12170445
Go to control panel, admin tools, and local security policy instead of the gpedit.msc (my mistake).  From there go to local policies, security options, and find the "change the network accesss: sharing and security model for local accounts".  
0
 
LVL 4

Assisted Solution

by:beem4n
beem4n earned 400 total points
ID: 12170457
Hi,

you should do the next:

net use \\homePC1\c$ /user:USERNAME
it will prompt after for password for USERNAME

if you are in domain, then
net use \\homePC1\c$ /user:USERNAME@DOMAINNAME
and again enter password after

good luck!
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170467
Classic was already selected.....
0
 
LVL 2

Expert Comment

by:dev8
ID: 12170497
How about he other option?  The "Let everyone permissions apply to anonymous users"?
0
 
LVL 4

Expert Comment

by:beem4n
ID: 12170526
Really there is one more way,

you should create a user on homePC1 with same login/password as on your PC and make it Administrator on HomePC1 to get to administratives shares (c$, ...)

this way you even wouldnt be asked for a password
0
 
LVL 2

Expert Comment

by:dev8
ID: 12170527
Make sure that you also restart machine for settings to take effect.
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170578
ah.. restart may be the problem...  Well, since i am remotly logged into the machines (Radmin, Destop viewing) i cant reboot it from here.  I will give that a try when i get home from work.  Thanks.
0
 
LVL 2

Expert Comment

by:dev8
ID: 12170602
Not a prob!  You should be able to restart remotely, but I might be wrong ;)
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 12170627
This happens if "Simple file sharing" is enabled in the target computer. With that said, the target PC authenticates every connection as guests.
0
 
LVL 4

Expert Comment

by:beem4n
ID: 12170639
kmorris: have you checked my solutions ?

you havent responded to both of them..
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170731
Update - simple file sharing is turned off on both PCs. (i cant hit PC2 using radmin no outside IP)

beem4n - I have tried the 2nd one a while back.  I have created a username on both PCs named "Keith.Morris" with the same password.  That still tried to log in as the same Guest account.

This idea:
net use \\homePC1\c$ /user:USERNAME
it will prompt after for password for USERNAME

will have to wait until i get home.  I cant get to the 2nd PC using Radmin and i think my roommate turned it off! DOH!

Keep posting ideas, i should be able to get back with you all in about 5-6 hours.
0
 
LVL 34

Assisted Solution

by:sramesh2k
sramesh2k earned 400 total points
ID: 12170788
Classic: local users authenticate as themselves

Microsoft Windows XP - Network access: Sharing and security model for local accounts:
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/506.mspx

Does that help?
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12170852
sramesh2k - Unfortunetly, that is already selected and it still does this Guest thing. That is what  dev8 suggested.
0
 

Expert Comment

by:daleshirley
ID: 12171479
Probably not the answer you want but I simply enabled the GUEST account and gave it a good password - works great for me.
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12171665
That is what i am currently doing as a work around.
0
 
LVL 6

Expert Comment

by:mslunecka
ID: 12172452
Try this:  start ->  Run ->  mmc


File ->  Add snap-in

Click Add

Find Security Templates

Load the Setup Security template.

That will give you out-of-the-box security settings.  If that works, you'll know something changed on you.

You can read up on various default templates here:
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_scedefaultpols.mspx

Hopefully one of them will reset your particular problem.  
0
 
LVL 5

Assisted Solution

by:talphius
talphius earned 400 total points
ID: 12179531
Try disabling the local security policy Network Access: Force Network Logons using Local Accounts to Authenticate as Guest.

"By default, on computers running Windows XP Professional and not joined to a domain, all incoming network connections are forced to use the Guest account. This means that an incoming connection, even if a user name and password is provided, has only Guest-level access to the share. Because of this, either the Guest user account or the Everyone group (the only group to which the Guest account belongs) must have permissions on the share and on the directories and files that are shared. It also means that, in contrast to Windows 2000, you do not need to configure matching user accounts on computers to share files. Because Windows XP Professional supports Anonymous connections, and because it severely limits the use of the Everyone group in file system permissions, granting the Everyone group access to shared folders does not present the security problem that it does on Windows 2000–based computers."  from:  http://www.wown.com/j_helmig/wxpsimsh.htm
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12179892
somthing that i did yesterday worked! it no longer defaults to Guest! I am able to log in and connect to shares!  I didnt have a change to figure out what worked.  When i get home tonight, i will try to backtrack my steps to figure out which answer correctly fixed my problem.

Thanks for your help.
0
 
LVL 7

Author Comment

by:kmorris1186
ID: 12237558
Well, i was not able to figure out what actually fixed it, so i will split them.  Sorry for the delay on this, i was out of state for the past week.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
Can you find a fax from a vendor you saved a decade ago in seconds? Have you ever cursed your PC under your breath during an audit because you couldn’t find the requested statement or driver history?  If you answered no to the first question or yes …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses
Course of the Month13 days, 13 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question