Exchange 2000 mapi32.dll problem can't mount stores

I lost the M: drive yesterday and tried reinstalling exchange but now when i start exchange manager i get Exchange Detected c:/eindows/system32/mapi32.dll is not the current version to run exchange 2000 See Q266418 This question talkes about not having microsoft outlook and exchange on the same machine and i DON'T!

During the install when asked to replace the new files i clicked NO TO ALL, could this be the prob should i re-instal?
philip07Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
moduloConnect With a Mentor Commented:
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0
 
philip07Author Commented:
Can anyone suggest anything please....URGENT we got no email!
0
 
SembeeCommented:
Have you re-applied the service pack and updates to the machine? If you used an original CD then some file versions will be out of date.

Simon.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
philip07Author Commented:
Simon, I applied all service packs and the final rollup. I just re-installed cause i can't wait company is without email. I clicked yes to replace all newer files with originals. I'm still waiting for the install to completeits stuck at Configuring registry entries for SMTP service. It's been at this step for over 15  minutes.
0
 
SembeeCommented:
What was the reason for doing the reinstall in the first place? It might be related.

Simon.
0
 
plimpiasCommented:
Thats funny i ran into this friday with a server that i was restoring windows 2000 server on. To fix the problem i uninstalled outlook from the server. Outlook uses a different version of the dll. Then I stopped all exchange services and renamed the dll file. I reinstalled exchange, saying no to the overwrites. reinstalled exchange SP3 then installed the post SP3 update rollup pack. and my mta stack service started again.

Good Luck!
0
 
philip07Author Commented:
I lost the m: drive after re-boot. I was cleaning the transaction logs and i may have deleted one of those important files. I'm not sure if that was the begining of the problems but the server was working for 2 days after that and when i re-booted i got his issue. I't was rebooted by a datacenter guy, he cut the power.
Is there a way to uninstal and start fresh cause i just used OnTrack and the data files are good. But when i mound it says the data files are inconsistent.
0
 
philip07Author Commented:
This id driving me crazy! What can i do?????HELP!
0
 
SembeeCommented:
If the database files are being reported as inconsistent that will mean they will have to be repaired. That means using the eseutil utility.
There are lot of articles written about using this utility, so I am not going to repeat them here. Get the latest version you can find and then read everything you can.

I probably wouldn't have gone straight for a reinstall but we are past that. I hope you have reported the datacenter operative for cutting the power without shutting down the server correctly - no server likes having its power pulled from under it.

Simon.
0
 
philip07Author Commented:
The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000

This is the first error i get. I'll try the eseutil
Thansk!
0
 
philip07Author Commented:
This is what i got after running the eseutil
Initiating DEFRAGMENTATION mode...
            Database: D:\ExchangeDATA\MDBDATA\priv1.edb
      Streaming File: D:\ExchangeDATA\MDBDATA\priv1.STM
      Temp. Database: TEMPDFRG3164.EDB
Temp. Streaming File: TEMPDFRG3164.STM


Operation terminated with error -550 (JET_errDatabaseDirtyS
 not shutdown cleanly. Recovery must first be run to proper
operations for the previous shutdown.) after 2.53 seconds.
0
 
philip07Author Commented:
What's wrong with this command to repair the database:
D:\Program Files\Exchsrvr\BIN>eseutil /r /l D:\ExchangeDATA\TRANSLOGS\NEWEST
0
 
philip07Author Commented:
SWEET! Repaired BS databases and we are back online!
Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.