Solved

Can't create subfolders inside a public folder

Posted on 2004-09-28
7
8,776 Views
Last Modified: 2011-12-12
I need your help!    I tried creating a public folder both in Outlook or ESM and giving owner permission to a userA.  When userA goes to the outlook, right clicks and selects create new folder, selects the type of content and subfolder name and clicks OK. UserA gets the follwoing error message:  "Unable to create the folder. You do not have sufficient permission to perform this operation on this object. See the folder contact or your systems administrator".  H/She  has owner permission.  However, userA can drag and drop items from his desktop into this folder, rename the folder, delete the folder, add items and everything except create another subfolder or create a new calendar or item directly from folder tree.  I turned on the logging and here is the infor:

Event Type:      Warning
Event Source:      MSExchangeIS Public Store
Event Category:      Access Control
Event ID:      1030
Date:            9/28/2004
Time:            7:42:41 PM
User:            N/A
Computer:      MSX1
Description:
userA@thecompany.com failed an operation on folder /O=THE COMPANY ORG/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=Sales757747492C2040F40 on database "First Storage Group\Public Folder Store (MSX1)" because the user did not have the following access rights:

'Delete' 'Read Property' 'Write Property' 'Create Message' 'View Item' 'Create Subfolder' 'Write Security Descriptor' 'Write Owner' 'Read Security Descriptor' 'Contact'


I remember changing rights on the public folder tree root a while back.  I would really really appreciate why I get this behavior.

Thanks
0
Comment
Question by:timSA
7 Comments
 
LVL 10

Accepted Solution

by:
pcbrat earned 400 total points
ID: 12176478
Because you changed the rights on the pub folder tree you changed the way others can write to the Exchange Metabase in AD. You need to restore the original rights and then YOU need to create an Orginal Folder under the root of Pub tree and then give them (usersA) Owner permissions(Use the ESM) in order for them to create subfolders.
the two links I pasted explain why. First Link is your Error...Second link explains how to fix it :)
see links

http://eventid.net/display.asp?eventid=1030&eventno=1751&source=MSExchangeIS%20Public%20Store&phase=1

http://support.microsoft.com/default.aspx?scid=kb;[LN];Q313866

Dawne
0
 
LVL 13

Expert Comment

by:George Sas
ID: 12177935
Ok , let's try to get some info first.

How many exchange servers you have and how is the Public folders replication set up ?
0
 
LVL 2

Author Comment

by:timSA
ID: 12179171
I have only one exchange server in a single forest, single domain setting.  I recently three months ago moved mailboxes and public folders from exchange 2000 to exchange 2003 server (performed all the adprep, exchange prep, etc).  Everything was working okay.  I wanted to make sure nobody has rights to make a public folder at the root level.  So, I changed the permission to everyone group a bit (not sure what I changed).  

I will try what pcbrat said today and see if it resolves the problem...  GeoSs, please let me know if you have any suggestions.   Thanks
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 2

Author Comment

by:timSA
ID: 12179488
Okay I tried what PCBRAT suggested.  Now everything works fine.  It seemed to have restored the original settings on the public folder root.  But I don't want to give EVERYONE the ability to create public folder in the root.  This was the main reason why I removed the "create public folder" permission for EVERYONE group.  For example,

Public Folders
|
All Public Folders
|
+- Sales Department
|
+- Accounts Department


I don't want everyone have the permission to create public folders under "All Public Folders".  But I would like to have the sales department users to be able to create and delete files, calendars, etc inside the Sales Department folder.  

Any idea?

thanks  
0
 
LVL 13

Assisted Solution

by:George Sas
George Sas earned 100 total points
ID: 12179648
I don't think they will be able to do it anyway.
Log in with a normal user account on the domain , open your outlook and try to create a public folder.
0
 
LVL 2

Author Comment

by:timSA
ID: 12180077
GeoSs-You're right.  now everything is back to normal.  I hope.   Thank you guys.
0
 

Expert Comment

by:LSeven
ID: 37275700
I love you pcbrat.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question