[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now


Real VNC and segmentation faults

Posted on 2004-09-28
Medium Priority
Last Modified: 2010-03-18
Hi there,

I have a network with a linux server, I am attemping to remotely manage the server by using real VNC (this is from a winXP box).  I can connect alright but when I run apps on the server I seem to nearly always get a segmentation fault.  I am aware that this is because the app in question is trying to access an area of memory that it does not have access to.

Why does this occur?  How can it be solved so that I can run all my linux software through VNC?

Thanks in advance to anyone knowledgeable enough to sort this one.

Question by:ryanthemadone
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 40

Assisted Solution

jlevie earned 1000 total points
ID: 12176580
What Linux is this? And is it up to date w/respect to vendor errata & updates?

Is the OS and applications a vendor set, or have you upgraded with packages that didn't come from your Linux Vendor?

Author Comment

ID: 12179007
I'm using mandrake linux 9.1 with kernel 2.4.1, i don't understand the rest of your questions but everything seems pretty up to date on the system.  Apps run fine if I am connected directly to the servers console and monitor, it's only when I vnc in that they crash.



Author Comment

ID: 12179852
LVL 40

Accepted Solution

jlevie earned 1000 total points
ID: 12180791
There's a large number of errata/updates for 9.1 that could well have bearing on this problem. I'd suggest that you update the system (see http://www.mandrakesecure.net/en/ftp.php) and see if that solves the problem.

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question