DNS (BIND) setup problem?

I tried to configure the BIND in Fedora core 1. It seems to work fine with Linux machine with nslookup:

[root@localhost root]# nslookup
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
> scada.net
Server:          66.100.135.166
Address:        66.100.135.166#53

Name:   scada.net
Address: 135.200.1.67

But when I tried to look at it from a Win2K machine with nslookup:

C:> nslookup
Default Server: ns1.abd.com
Address: 66.100.135.166

> scada.net
Server: ns1.abd.com
Address: 66.100.135.166

DNS request timed out.
       timeout was 2 seconds.
Name: scada.net
Address:  135.200.1.67

And the problems:

1) SMTP and POP3 servers quite often have problem identifying scada.net. Mail client will time out.
2) IE quite often cannot identify the site scada.net.

Please help.

ccjongAsked:
Who is Participating?
 
peteysaConnect With a Mentor Commented:
Below is the output from a dig on my web server.  First thing is to dump nslookup for troubleshooing.  Dig gives you all the info you need.  

It looks like scada.net is at a new IP address.  I would recommend restarting bind/named and nscd to flush cache.

The timeout from the XP box is pretty standard on the first resolution.  Just saying hey it took a couple secons to resole the address.

Here is the output from the dig.

bash-2.03$ dig scada.net

; <<>> DiG 9.2.1 <<>> scada.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55146
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;scada.net.                     IN      A

;; ANSWER SECTION:
scada.net.              86400   IN      A       204.251.10.205

;; AUTHORITY SECTION:
scada.net.              86400   IN      NS      ns0.directnic.com.
scada.net.              86400   IN      NS      ns1.directnic.com.

;; Query time: 94 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Sep 29 12:39:32 2004
;; MSG SIZE  rcvd: 92


Cheers!

dan
0
 
pablouruguayCommented:
can you paste in here your zone files ? please and in your need open port 53 in your firewall. check that
0
 
alextesiCommented:
Have you configured the resolv.conf file ??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.