• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 362
  • Last Modified:

.Net Data SQL Provider (System.Data.SqlClient) requires Microsoft Data Access Components(MDAC) version 2.6 or later.

Can somebody give me a good answer to the following:

I just moved aspx pages which accesses a DB to our webServer - we get the following error:
The .Net Data SQL Provider (System.Data.SqlClient) requires Microsoft Data Access Components(MDAC) version 2.6 or later.

-------------------
Source Error does not tell much, I can send the Stack Trace if you want to have a look at it:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

kind regards,
Martin
0
Artform04
Asked:
Artform04
2 Solutions
 
Mohammed NasmanSoftware DeveloperCommented:
Hello

  Try to download Mdac 2.8
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=en

and use this utility to check which version installed
MDAC Utility: Component Checker
http://msdn.microsoft.com/data/downloads/tools/default.aspx
0
 
DotNetLover_BaanCommented:
It is like the framework. but, it deals with database functionalities only. You can download it from Microsoft, it is absolutely free.
0
 
Artform04Author Commented:
works,

we had to install it, first we thought we got it, but we did not.
regards, Martin
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now