Memory used

Hi everybody,

I have an Interbase 7.1 server running on Windows 2003 Server Enerprise Edition. The machine has 4 GB RAM and is used only for the IB server. The problem is that I cannot force the IB server to use all the available RAM. I have played a lot with the settings in the ibconfig file, but the limit of the memory usage was about 400 MB. I've been executed a lot of "hard" queries, which I think are really memory consuming. I have a database, which files are bigger then 4 GB and I have queries, are affdecting amost all of the tables in the DB, but in the Task Manager I see that the ibserver.exe is first increasing its memory usage very fast, but when it pass the limit of ~400 MB it stop to use more memory and I am waiting for some of the queries more than 3 minutes ...

So, my questin is how I can force the server to use all the availabe RAM on the machine ( when it is required of course ) or we spend our money for 4 GB RAM for nothing.

Thanks in advance
LVL 9
tkalchevAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
kacorConnect With a Mentor retiredCommented:
in the borland.public.interbase.general topic search for memory use
0
 
kacorretiredCommented:
Hi tkalchev,

everything what I can help you is:

1. look at http://bdn.borland.com/article/0,1410,29632,00.html. You can download from here the InterBase Performance Monitor Release 1.1. This allows you to easily see (and optionally alter) who and what is consuming resources on your InterBase 7 server.

2. On newsgroups.borland.com select borland.public.interbase.general and ask directly the IB developers.

In the meantime I try to search something useful for you

wbr

Janos
0
 
tkalchevAuthor Commented:
Hi kacor,

I think with IB 7.1 my problem has no solution, since I can increase the database cache only up to 65535 pages. As I've read, in the new IB 7.5 there will be possibility for a bigger limit. Maybe an upgrade to 7.5 will help.

Regards

Tsvetan
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
kacorretiredCommented:
thank for this info

Janos
0
 
Gary BenadeCommented:
Setting a page cache size of 65535 is not recommended and will probably slow your machine down. A setting of 10000-20000 is the recommended max. Interbase 6 will not use more RAM to do its job even if there is more available - it will do all it's sorting in temporary disk files. I highly recommend you install firebird 1.5.1 and see how that makes a difference - It loves RAM and will use all available ram to do its work if needed (you will need to assign more sort ram in the config file). Bear in mind that these database engines are very optimised and happy in low RAM environments so even your "hard query" might not stress them too much, especially if the query uses indexes and has no grouping and sorting.
0
 
tkalchevAuthor Commented:
To hobbit72 :

Where have you seen that I am using Interbase 6 ?!?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.