Solved

PIX 515E - two outside interfaces - one for just vpn

Posted on 2004-09-29
6
289 Views
Last Modified: 2013-11-16
I've added a second DSL line and another outside interface.  I don't want to do load balancing, etc.   I simply want to use the second DSL/OUTSIDE INTF dedicated to a point to point VPN.  Then I thought I could use access-lists to permit communication with the inside, etc.  I'm new to this and I'm having some problems as of now.  Is this possible to do?

Thanks.
0
Comment
Question by:captainpeon
  • 4
  • 2
6 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12184612
Sure, as long as it's a dedicated VPN.
Acls is definately the way to control access.
You need to setup the LAN-LAN VPN, and add route statements on the PIX:

  route <interface name> <public ip of VPN Peer> 255.255.255.255 <next hop IP>
  route <interface name> <Private LAN subnet> <mask> <next hop IP>

What's at the other end, another PIX?
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml
0
 

Author Comment

by:captainpeon
ID: 12186332
lrmoore:  Thanks for the quick feedback!  There is a 515 on the other end as well.  I'll work on this ASAP and post how it goes.
0
 

Author Comment

by:captainpeon
ID: 12194323
lrmoore:  I'm still having some problems.  I'm not sure if I'm doing the routes right.  As I said, I'm really new to this.  Here is a sample of the config.  The second interface is intf2.  It's ADDR for that interface is lets say 206.166.x.145.  The DSL router ADDR is 206.166.x.150.   The ENDPOINT ADDR for the vpn i want to establish a direct/dedicated tunnel with is lets say 65.88.x.50.  The inside subnet for that location is 192.168.x.x.

Thanks

pix01(config)# show running
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security10
enable password bmVUCXx7cvTZmFOl encrypted
passwd bmVUCXx7cvTZmFOl encrypted
hostname pix01
domain-name BLEH
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list acl_out permit icmp any any
access-list acl_out permit gre any host 216.x.x.181
access-list acl_out permit udp any host 216.x.x.181 eq 1701
access-list acl_out permit udp any host 216.x.x.180 eq pcanywhere-status
access-list acl_out permit tcp any host 216.x.x.180 eq pcanywhere-data
access-list acl_out permit gre any host 216.x.x.182
access-list acl_out permit udp any host 216.x.x.182 eq 1701
access-list acl_out permit tcp any host 216.x.x.180 eq 3341
access-list acl_out permit udp any host 216.x.x.180 eq 5900
access-list acl_out permit tcp any host 216.x.x.180 eq 5900
access-list nonat permit ip 192.0.0.0 255.255.255.0 192.0.2.0 255.255.255.0
access-list nonat permit ip 192.0.0.0 255.255.255.0 192.0.1.0 255.255.255.0
access-list nonat permit ip 192.0.0.0 255.255.255.0 10.x.x.0 255.255.255.0
access-list acl_vpn_flo permit ip 192.0.0.0 255.255.255.0 192.0.1.0 255.255.255.0
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.x.x.75
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.x.x.199
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.x.x.56
pager lines 24
logging on
logging monitor debugging
logging buffered debugging
logging trap notifications
logging history debugging
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 216.x.x.177 255.255.255.0
ip address inside 192.0.0.251 255.255.255.0
ip address intf2 206.166.x.145 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 192.0.2.240-192.0.2.250
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1 216.x.x.178
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 216.x.x.181 192.0.0.128 netmask 255.255.255.255 0 0
static (inside,outside) 216.x.x.182 192.0.0.130 netmask 255.255.255.255 0 0
static (inside,outside) 216.x.x.180 192.0.0.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 216.x.x.190 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address acl_vpn_lc
crypto map outside_map 20 set peer 12.140.x.13
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 30 ipsec-isakmp
crypto map outside_map 30 match address acl_vpn_flo
crypto map outside_map 30 set peer 67.44.x.130
crypto map outside_map 30 set transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto map intf2_map 40 ipsec-isakmp
crypto map intf2_map 40 match address acl_vpn_mlt
crypto map intf2_map 40 set peer 65.88.x.50
crypto map intf2_map 40 set transform-set ESP-DES-MD5
isakmp enable outside
isakmp enable intf2
isakmp key ******** address 67.44.x.130 netmask 255.255.255.255
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp key ******** address 12.140.x.13 netmask 255.255.255.255
isakmp key ******** address 65.88.x.50 netmask 255.255.255.255
isakmp identity address
isakmp client configuration address-pool local vpnpool1 outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
vpngroup vpn3000-all address-pool vpnpool1
vpngroup vpn3000-all dns-server 192.0.0.5
vpngroup vpn3000-all wins-server 192.0.0.5
vpngroup vpn3000-all default-domain password
vpngroup vpn3000-all idle-time 1800
vpngroup vpn3000-all password ********
telnet 192.0.0.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
console timeout 0
vpdn group 2 accept dialin pptp
vpdn group 2 ppp authentication pap
vpdn group 2 ppp authentication chap
vpdn group 2 ppp authentication mschap
vpdn group 2 ppp encryption mppe 40 required
vpdn group 2 client configuration address local vpnpool1
vpdn group 2 client configuration dns 192.0.0.5
vpdn group 2 client configuration wins 192.0.0.5
vpdn group 2 pptp echo 60
vpdn group 2 client authentication local
vpdn username tempuser password *********
vpdn enable outside
terminal width 80
Cryptochecksum:869a1ae41f857e5035caa6decb994672
: end
pix01(config)#
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 79

Accepted Solution

by:
lrmoore earned 300 total points
ID: 12194383
I think you just need to add a route statement:

   route intf2 65.88.x.50 255.255.255.255  206.166.x.150

0
 

Author Comment

by:captainpeon
ID: 12194552
lrmoore:  Cool.  I'll add the access list statements, then try establishing the tunnel.  I'll post follow up information asap.
0
 

Author Comment

by:captainpeon
ID: 12202971
lrmoore:  Sorry for the delayed response.   The interfaces at site A and site B are able to communicate now.  I'm having some problems getting the tunnel established, but I'm sure there is something that I'm over looking.  I'll keep pounding it out.  I'll go ahead and close this one out.  Thanks much for your assistance.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now