[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5158
  • Last Modified:

VAIO laptop display is dim after XP install

Hi,

I did a clean install of XP on a VAIO PCG-R505GC laptop.  Everything works exept I have no control over the brightness of the display.  The Fn keys work for PG/UP, PG DN. etc., but do not work for screen brightness.  It is very dim, almost to the point of unreadable.  The Sony website is useless, any ideas?
0
brihaspati79
Asked:
brihaspati79
  • 7
  • 7
1 Solution
 
Sam CohenCommented:
1) does it look bright in safemode?
2) is the video card driver loaded correctly or updated?
3)when you plug in the adaptor does the screen get bright?
0
 
brihaspati79Author Commented:
Thanks for getting back so quickly and accept my apology for not doing the same.  

1) the display is dim in safe mode as well
2) the driver I loaded was from the Sony site, IntelĀ® 82830M Graphics Controller Driver
3) the screen brighness is independant of the power adaptor being plugged in

It does seem dim while booting up as well (before Windows).  It did work fine before the XP install.  I also updated the bios (after I noticed the problem), but that had no effect either.
0
 
Sam CohenCommented:
do this , remove the driver out of the add and remove program first/or from device manager,
the boot up com and see if the default video card that xp assigns screen is britened.

if not then it might not be xp, it your lamp inside or video converter inside,
how long have you have this laptop?
if its still within warranty , get it fix
if not, then
i can give you info on where you can have it fix, if you would like
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
brihaspati79Author Commented:
That did not work, same brightness level, I re-installed the driver. I also just tried to hook an external monitor to the unit, but there is no VGA ouput from the connector.  I feel the problem lies with the Fn keys.  The sound volume,mute, brighness, and vga keys do not work, the Home, PGUP, PGDN, and End keys do.  I do not know how to access the hotkey setup.
0
 
Sam CohenCommented:
did you download all utility her:
http://ciscdb.sel.sony.com/perl/swu-list.pl?template=EN&mdl=PCGR505GC

also did you do a full installation or upgrade of winXp?

because if you are most sure that winXp is causing the problem, and you have chosen "upgrade"
then you can uninstall winXp at the add/remove programs
0
 
brihaspati79Author Commented:
I wiped the drive clean and did a full installation.  I did not download all of the files on that page because some are not relevent (like the Trend Micro) to this installtion.    There is a icon in the control panel of this notebook called Sony Notebook Setup and when I press it I get an error that says"You failed in loading SnyUtils.dll.  Please make sure it is installled correctly."  What do you know about this and why would it be installed incorrectly (there was only one way to do it)?
0
 
Sam CohenCommented:
well it seems like snyutils.dll comes from maybe a file called sony utility for downloads on that site that i gave you
try and download all that is revelent to your system and see if that might fix that error
0
 
brihaspati79Author Commented:
This is not working.  I do not have the CD that came with the laptop and the Sony website does not seem to have a download area for the hotkey application for this model.  Is there a place where I can download the hotkey application for my Sony notebook?  Is the hotkey application dependant on any other Sony utility or application (to be installed first)?
0
 
Sam CohenCommented:
ok here two site for the download of the"hot key utiliy"
it support 2000 though , but should or might work with xp:

http://ciscdb.sel.sony.com/perl/swu-download.pl?template=EN&upd_id=25&os_id=6&mdl=PCGR505TSK

and

http://ciscdb.sel.sony.com/perl/swu-download.pl?template=EN&upd_id=368&os_id=6&mdl=PCGN505VE


see if any of those work and let me know
0
 
Sam CohenCommented:
if none of these work , i would call sony and ask for the updated Hot key drv
and they should give you the right link
0
 
brihaspati79Author Commented:
Sorry I was out of town. No, these drivers do not work.  When I try to install them , they say they are for Windows 2000 only and the setup exits.
0
 
brihaspati79Author Commented:
Also, I tried these drivers using Windows 2000 compatibility mode.  I got a little farther, but then it said wrong model number.
0
 
brihaspati79Author Commented:
I figured this out.  In the BIOS, I reset the values to factory default.  Everything works now.  Thanks for helping out.
0
 
Sam CohenCommented:
ok . im glad you have ....you can request your poim=nts back in the community section
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now