Clear the Run command menu

HI

clicking Start --> Run i have a number of old URLs in the drop down menu. when i start typing www etc.. they appear.

However these old URLs are not in the history or temporary internet files and even editing the registry at:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

which is supposed to clear it out does not remove them.

If i try searching the registry for the URLs the search does not yield any results.

Where can i find where these are coming from and how do i delete them?

Thanks in advance

Kels.
KelsAsked:
Who is Participating?
 
cwkhangConnect With a Mentor Commented:
WinSpy Index.dat Viewer 2.02
http://www.softwarepatch.com/software/indexdat.html
this software can view wat's stored inside index.dat

and you need this software Tracks Eraser Pro 5 to delete index.dat files
http://www.softwarepatch.com/software/trackerase.html

cheers
0
 
Pete LongTechnical ConsultantCommented:
Hi Kels,
Clear Unwanted Entries from the Start Menu's Run Command

Run the Registry Editor (REGEDIT.EXE).
Open HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ RunMRU\.
Delete all of the values in this key (everything in the right pane, except for (Default)).
Close the Registry Editor when finished. You'll probably have to refresh the Desktop or restart Windows for this change to take effect.

Note: To clear the OtherFolder history, repeat the same process in HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ OtherFolder\.
http://www.annoyances.org/exec/show/article05-011

PeteL
0
 
sramesh2kCommented:
In Internet Options Advanced  tab, uncheck "Use inline autocomplete" options.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
sramesh2kCommented:
Not that one. But disabling Autocomplete options in the Content tab should help. The entries basically come from RunMRU and also the Index.dat
0
 
andyb735Commented:
Kels,

One option is to clear recent documents and programs and web sites.  To achieve this right click the Start menu, select properties.  Click customize on the Start Menu tab.  You should see an option to CLEAR the recent documents, programs and web sites.

These are directions for Windows XP
0
 
KelsAuthor Commented:
Thanks for the replies guys.

I tried clearing out the recent docs etc... on the start menu tab.

Also i tried deleting every registry entry in: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

I have auto complete off.

But still no luck.

I did however do a search for index.dat and found about 12 of them. What is the location of the index.dat that feeds the run command?
0
 
KelsAuthor Commented:
Thanks for all your help fella's

It was the index.dat file that was the culprit.

I downloaded a different tool for deleting them called Complete Internet Clean up and now its done.

Thanks

Kels
0
 
JasCruzCommented:
If what you mean is that the history of previous adresses appear in a "drop down menu" whenever you begin to type, I believe it's a very simple process to get rid of them. Simply mouse-over them one at a time: when they appear highlighted,  press the 'Delete' button (not backspace)
0
 
KelsAuthor Commented:
No JasCruz thats not whats happening but thanks for the input anyway.

I already accepted an answer to this.

Kels
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.