Solved

No keyboard function uo boot up

Posted on 2004-09-30
11
4,001 Views
Last Modified: 2008-01-09
This is a strange one,
A friend gives me his computer to fix because it won't boot up. It just says no operating system present. It is a custom built machine, about a year old, that I did not build. The specs are ABIT IT7 with P4 2.53, 1GB Mushkin memory and 2 WD 80GB HD in a RAID 0 array. It seems the RAID controller would not pick up one of the drives. Check the obvious cables PS connections etc. everything looks good. Ran diagnostics on the failed drive in a test bed computer and it did not pass.
This is where it gets weird.
Replaced the drive with an identical one and proceeded to build the array. I could not get into the RAID Controller BIOS. The keyboard seems to not function. I tried to get into the MB BIOS and the keyboard still does not function. This is an interesting MB because it does not have any connections for leagacy devices. No PS2, no serial ports, no parallel ports, just a bunch of USB and Firewire. I tried different keyboards and tried using a USB to PS2 converter with a standard keyboard and nothing.
The next thing I tried was putting a HD on the standard IDE primary channel as master. I couldn't get it to boot off the CDROM. It always wants to boot off the HD and nothing else. I can't get into the BIOS to check the Boot sequence.
My last resort was placing the HD in another computer and installing the OS there then putting the drive back into the machine and it finally boots up. The mouse, keyboard and everything else works in the WinXP environment but will not work when the machine boots up. Only when it boots into Windows.

Any suggestions, been working on this for days and I still need to get into the BIOS
0
Comment
Question by:crazijoe
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 200 total points
ID: 12189775
When you have a USB keyboard, you usually have to enable the legacy USB device setting in the BIOS, in order to use it before it gets into Windows.  But you may have a catch-22 there.
0
 
LVL 69

Expert Comment

by:Callandor
ID: 12189815
This site captured screen shots of the BIOS, so USB keyboards are assumed to work without additional help: http://www.hothardware.com/viewarticle.cfm?page=3&articleid=64&cid=3

Maybe you should reset the CMOS?
0
 
LVL 7

Author Comment

by:crazijoe
ID: 12190322
Yeh, I tried resetting the BIOS. I even tried to update the BIOS but it won't boot to the floppy.
0
 
LVL 69

Expert Comment

by:Callandor
ID: 12190599
Sounds like you got a seriously messed up machine there.  If you can't get to the BIOS, you are going to be crippled.
0
 
LVL 2

Assisted Solution

by:studlyed
studlyed earned 200 total points
ID: 12194864
when resetting the bios did it come up with saying cmos checksum wrong or something like that
make sure there is NO POWER to the board. this means pull the plug from the power supply. otherwise the bios will use power from the power supply and not the battery so all this is useless
try flipping the jumper for about 5 minuutes. still nothing do the folling
if not try puling the battery for 5 minutes. still no go pull it out and leave it over night
now it should deffinately say cmos checksum is wrong and give you the option of pressing f1 for bios and such. it should also be at defaults.

also could it be that your adapter is bad? try aa true usb keyboard.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 7

Author Comment

by:crazijoe
ID: 12199020
I have tried to reset the BIOS serveral different ways. I do get a message that CMOS has changed and to press delete to enter the BIOS but keyboard still does not function. I am almost certain the BIOS is corrupt and it is not the hardware. If there was just some way of getting the machine to boot to the floppy.
0
 
LVL 69

Expert Comment

by:Callandor
ID: 12199057
Can you try setting up a DOS system on that hard disk that worked, using another machine?  Copy the BIOS flash files that you need to it, and then try booting it up.  It should be just as if you had a floppy working.
0
 
LVL 2

Expert Comment

by:studlyed
ID: 12200801
if the keyboard still doesnt work then you would need to set up autoexec.bat with something like this...but i think it wtill requires some input

this is for award. you might be able to put in a text file with the commands it n'eeeds like y then enter then n or something.
awdflash <biosfile>
0
 
LVL 7

Author Comment

by:crazijoe
ID: 12203315
I'll try that this weekend.
0
 
LVL 2

Accepted Solution

by:
DavidMc earned 100 total points
ID: 12212879
From aBit's site:

Switch off the power supply unit or pull off the power cord. There is a CMOS jumper near the battery. Change the jumper position from default 1-2 to 2-3 for one minute to discharge the CMOS data, and then put it back to default 1-2. Switch on the power supply unit or pull in the power cord. Press the power-on button to boot up system. If it works, hit "Del" key to enter the BIOS setup page to do correct settings.
0
 
LVL 7

Author Comment

by:crazijoe
ID: 12216516
I did finally get to flash, and go into the BIOS. Abit has a program called FlashMenu that allows you to flash the BIOS in a Windows environment. The keyboard now works and everything seems fine. I spit the points among everybody who participated in the question.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now