Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

Can't create ASP.NET app in C#. IIS keeps stopping.

I am using Visual Studio 2003 to try and create a new C# ASP.NET Web Application.   I get an error message saying "Visual Studio cannot create or open the application because the Web server on this computer is not running.  Start the Web server before proceeding".  My "Default web site", which was running before I tried this, is now flagged as "Stopped".  I am at work and don't have a firewall on my pc.  This was an NT machine that was upgraded to XP Pro.  Any help is appreciated.  Thank you.
0
tbriggs928
Asked:
tbriggs928
  • 7
  • 3
1 Solution
 
praneethaCommented:
start the webserver and then you should be able to create an web application

go to "services" in administrative tools and start your webserver and try creating a web application
0
 
praneethaCommented:
http://localhost

type this in IE and check if it works...then it means your webserver is running
0
 
tbriggs928Author Commented:
I goto Administrative Tools.. Services.  The "IIS Admin" item is already flagged as Started.  I right click and choose "Restart".  But I still get the error message in Visual Studio when I try to create an ASP.NET application.

I have noticed that if I goto Administrative Tools.. Internet Information Services, my "Default web site" if flagged as Started.  Then, I either try to create an ASP.NET application which fails, or type http://localhost which displays "The page cannot be displayed".  Then, I check and the "Default web site" is now flagged as Stopped.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
praneethaCommented:
is the world wide publishing services...started in the services list...

and do u have c:\inetpub\wwwroot folder in your computer...

or why don't u just reinstall iis on your comp see if it makes any difference
0
 
tbriggs928Author Commented:
yes, the world wide web publishing services is started, and I have the c:\inetpub\wwwroot folder.  I'll contact my IT dep't to have them reinstall IIS to see if that fixes the issue.
0
 
praneethaCommented:
when u say new project in vs.net

can u see http://localhost/WebApplication1 this in the location box...

make sure the localhost shows up....

and after u reinstall you may need this

http://support.microsoft.com/default.aspx?scid=kb;en-us;306005&Product=aspnet
0
 
stu_pbCommented:
You should make sure that ASP.NET is installed on the server.  You can run the tool aspnet_regiis.exe that should be in the folder c:\winnt\microsoft.net\framework\v1.1.4322 (or something close).  Run it from the command line with the -i option to register ASP.NET with IIS.

Good Luck!
0
 
tbriggs928Author Commented:
I reinstalled IIS and it didn't make a difference.

I did some research and found the following article.  I followed the steps to synchronize some passwords, and I can now browse in IE to localhost.com.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;297989

However, I still can not create a Visual Studio ASP.NET Web Application.  When I try to create a new application, I get an "HTTP/1.1 500 Server Error" message.  Event viewer displays the following message "The server failed to load application '/LM/W3SVC'.  The error was 'The specified metadata was not found."

Any help with this error is appreciated.  Thanks.
0
 
praneethaCommented:
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now