Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

At job now kicking off

I am trying to do an at job.  And it never gets kicked off.  I have tried it two different ways and it doesn't work either way

at now +1min < /var/www/html/test.sh

at -f /var/www/html/test.sh now

They just sit in the at cue and never run.  

any suggestions.  

Basically what I am trying to do is.  I run a program called a.php if in that program something happens I call a script call killcue.sh.  This shell script will kill the process where the name is a.php, sends me an email to let me know the a.sh was killed, and then killcue.sh should start a.php agian.

Killcue.sh is killing a.php and sending me an email however it is not restarting the program, so I was going to try an at job to get it going.

a.php is an infinate loop that looks for incoming data from a database
0
jmsloan
Asked:
jmsloan
  • 2
1 Solution
 
liddlerCommented:
Have you looked in the cron log - something like /var/cron/log for errors?
0
 
jmsloanAuthor Commented:
I tried to run the at job right from the command

at -f /var/www/html/test.sh now + 1 minute

it puts the job in the cue but will not run it.

Anyone know why
0
 
jmsloanAuthor Commented:
Well it's looks like the spool directory wasn't there from the log files.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now