Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 285
  • Last Modified:

How do I use Cisco Pix Devise Manager to create rules to allow mail to come to my Exchange 2003 Server

I have a Cisco Pix Firewall 506 and would like to use the Cisco Pix Devise Manager to configure it to allow Exchange 2003 mail to pass through.  How can I do this?

Thanks,
Randy
0
rmefford
Asked:
rmefford
  • 3
  • 3
  • 3
  • +2
1 Solution
 
vandCommented:
Hate to give just URL's, but, this is pretty involved.

http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_v50/config/msexchng.htm

Hope this helps!
0
 
vandCommented:
In anticipation of any future issues, here is another good article.

http://support.microsoft.com/default.aspx?scid=kb;en-us;q320027
0
 
lrmooreCommented:
Much simpler to create a text command in notepad and drop it into the Command Line Tool of the PDM. Using the PDM is actually quite confusing..

Else, the steps involve
- create static port map to map port 25 from interface public IP to private IP
   static (inside,outside) tcp interface 25 192.168.1.100 25
- create inbound access-list to permit inbound port 25
   access-list inbound permit tcp any interface outside eq 25  <== note you must be using 6.3x to use "interface" in the acl
- bind the acl to the interface
   access-group inbound in interface outside
- turn off fixup
   no fixup protocol smtp 25

Using PDM:
- Configuration
- Access Rules
   - new rule
      Action: permit
        source host/network
           interface Outside
           ip add: 0.0.0.0
           Mask:   0.0.0.0
        Destination host/network
            interface inside
            ip add: 192.168.1.100
            mask: 255.255.255.255
        Protocol and Service (*) TCP, source port Service = any
                  Destination port Service = smtp
     - click OK, and you get a prompt "No static Network Address Translation (NAT) rule is configured ....
         - click OK
            NAT tab, chose (*)static     <ip address>(interface PAT)
          - click OK
        -click OK again
        - click Apply
      - Click Save
Then go into configuration | system properties
  + Advanced
       + fixup
           * SMTP  - click "delete" button
     Click    Apply
    - click Save

DONE
       
       





0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
rmeffordAuthor Commented:
Thanks for the help, but that doesn't really discribe how to use create a new rule with the device manager.  Also that example is if I am going to have a second server outside my firewall.  I am not.  I will have just the Exchange Server on the inside.  Am I missing something?  Please help.

Randy
0
 
rmeffordAuthor Commented:
I will try that, thanks everyone.
0
 
lrmooreCommented:
We must have hit submit at the same time...  hehe..
0
 
peteysaCommented:
Quick tip,

if you are using only 2 interfaces your static command do not require you to specify insde,outside in your command line.  Helps expediting programming the pix via commandline.  

static insideip outsideip

Cheers!

Dan
0
 
vandCommented:
Hey rmefford,  

The link is Cisco's suggestion on how to make Exchange work across a PIX firewall.  If all your looking for is port forwarding, Irmoore described that.
0
 
rmeffordAuthor Commented:
Thanks for the help, is that the only port I need to open to get my exchange server mail working?  I can send out but have not been able to receive an email in yet.
0
 
oldhamukCommented:
Hi,

You only need two commands to get this working.  Go to the CLI command input in the PDM and enter these commands. The third command is incase you have switched of the fixup for smtp.

Replace 192.168.0.1 with your public ip on the firewall and 10.0.0.1 with your internal ip of the exchange server.

access-list 101 permit tcp any host 192.168.0.1 eq smtp
static (inside,outside) tcp 192.168.0.1 smtp 10.0.0.1 smtp netmask 255.255.255.255 0 0
fixup protocol smtp 25

I know this works as I use it all the time with my customers.

Any questions please let me know.

Regards

Mark
0
 
lrmooreCommented:
> out but have not been able to receive an email in yet.
Did you disable the fixup protocol smtp 25?
You MUST do this step.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

  • 3
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now