Solved

Can send emails but not receive them

Posted on 2004-10-01
23
331 Views
Last Modified: 2010-03-17
I have looked throughout EE and found some questions that come close to my problem but don’t fix it for me.

My problem is: I have an MS server running Exchange and DNS services (LAN address 192.168.11.3) behind a DSL wireless router.  The router has a LAN address of 192.168.11.1 and a WAN address that is supplied dynamically by the service provider (I don't enter any IP info for WAN side).  I have setup NAT on the router to forward port 25 traffic to the LAN address of the Exchange server.
I have the MX record registered with a domain registration company.
I am able to send emails from my Exchange server, but not receive.

If I try an SMTP session from outside I get ‘Connection refused’.
0
Comment
Question by:funnei
  • 9
  • 4
  • 4
  • +5
23 Comments
 
LVL 15

Expert Comment

by:scampgb
ID: 12198716
Hi funnei,

Can you please try connecting to your Exchange on port 25 from a machine that's on the same LAN?

Instructions on this can be found at http://support.microsoft.com/default.aspx?kbid=153119&product=exch2k

Several ISPs now block incoming traffic on port 25.  You should check whether or not your ISP does this.

If the above telnet test works and your ISP isn't blocking port 25, then it's probably your router configuration.
Can you please let us know the make & model of the router?
0
 

Author Comment

by:funnei
ID: 12198758
Hi scampgb,

I can Telnet to Port 25 on the LAN.
My ISP say they aren't blocking any ports.
The router in question is a Buffalo WBR-G54 (firmware 2.06)
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12198896
funnei,

OK - sounds like a router config issue then.
Can you try the telnet test from a machine outside your LAN?

Can I suggest that you check the port forwarding configuration again?

I'm not familiar with the WBR-G54 myself, but I'll take a look at their website to see if there's anything obvious.

0
 

Expert Comment

by:aj247
ID: 12199838
I might suggest forwarding port 110.
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12200416
aj247: port 110 is used by POP3, not SMTP.  SMTP uses port 25.

funnei: sorry, not had chance to look for the WBR-G54 manual yet...
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12202085
I've just downloaded the manual from http://www.buffalotech.com/downloads/WBRG54Manual.pdf

Page 23 of this manual explains how to configure the port forwarding.
Can you please confirm that you have port 25 for TCP enabled and pointing to your server's Internal IP address?




0
 
LVL 4

Expert Comment

by:sriwi
ID: 12214171
You need to forward port 110 to your exchange server, make sure the mx records points to your internet address, in this case as what you said it is dynamic, there fore it is harder to configure, you need to sign up with those free service www.no-ip.com or dyndns.com, to get your IP updated regulary,

then on your dns server, you have to created the mx records based on your ip ( in this case, use the no-ip or dyndns service).

after that the mail should flow in ok.

cheers
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12219290
sriwi,
I don't quite see how opening port 110 (POP3) will help funnei's problem?
Also - he said that the IP details are provided dynamically.  This doesn't mean that the IP address will change, just that the ISP provides it.
If it is an IP address that changes, then you're right about the DynDNS-type service.

Funnei: any news?


0
 
LVL 2

Expert Comment

by:bacvain
ID: 12224051
Funnei are you on ADSL or CABLE, let me know please.thanks
0
 
LVL 2

Expert Comment

by:bacvain
ID: 12224062
Sorry i just re-read your message and you seem to be on DSL. As a DSL tech support guy, I would give a call to your ISP and ask again to make sure that PORT 25 insnt blocked...reason: SINCE MAY, ALL ISP BLOCKED PORT 25 BECAUSE THE NUMBER OF SPAM EMAILS HAS TRIPPLED. ISP WANT TO PREVENT ANY OVERLAOD ON EMAIL SERVERS, THEY BLOCKED ALL PORT 25. Many tech guys dont know it but it might be an issue.

Unless you upgrade your plan woth your ISP to a so called  SERVER PLAN, which allows you to run on port 25 and send emails, you might be somply blocked.

AGAIN reason is BLOCK ALL SPAMMERS.

I hope this help and btw who is your ISP? Give me a shout <email address removed by CetusMOD per http:help.jsp#99>
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12225506
Bacvain: Not *all* ISPs block port 25 for DSL.  Mine doesn't for example.  However, many ISPs now do.
Funnei has checked with his ISP and they say that they're not blocking the port.  

BTW - posting email addresses in quesions isn't allowed under E-E rules, I'll ask a Mod to remove it for you.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 2

Expert Comment

by:bacvain
ID: 12230186
Oh sorry, didnt know that...I am new, its been 2 days only. I am learning from mistakes bud :)

0
 

Author Comment

by:funnei
ID: 12230866
I have finally managed to try a telnet session from the WAN to port 25 on my WAN address, and get the following:

Connecting To xxx.xxx.xxx.xxx...Could not open connection to the host, on port 25:
Connect failed

My ISP (Bulldog UK) are fairly adamant that they don't block port 25.
They supply me dynamically with a 'static' IP address.

I have checked the setup of the router against the manual, thanks scampgb, and can't see differences to my setup.

To add to the list of where the problem may lie, I am running Windows 2003, with DNS server running and MS Exchange server running.
0
 
LVL 2

Expert Comment

by:bacvain
ID: 12231138
I looked back at the problem again and you guys are talking about Receiving emails as the main issue.

I agree with sriwi, PORT 110 is the POP3  which is the INCOMING mail server not SMPT Outgoing.

So why are you trying to forward the port 25 when your suppose to forward to port 110?

And if an ISP block port 25 , it usually means that customer cant send emails anymore because they want to avoid spammers....but in this case he cant receive, that has nothing to do with port 25...its all about port 110

Again INCOMING is POP3: 110
and OUtGOING is SMTP: 25

Check that out!
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12240296
bacvain: SMTP is often used to send emails FROM a mail client, but it's also what's used as the main method of email transport on the Internet.  In this case funnei's mail server needs to receive incoming emails over SMTP on port 25.
POP3 would be used in other circumstances.

Funnei: Are you running any firewall software on this server (including MS integrated firewall), ISA server or RRAS?
0
 

Author Comment

by:funnei
ID: 12286251
I have setup port 110 also now, just in case.

I'm not running any firewall software on the server.  I am relying on the router to handle this.

From all the responses I have received, and looking at other questions in the Exchange, I believe the port settings on the router are correct now.
I am shifting my focus onto the server now, to see if there is anything obvious I can reset/alter.
0
 
LVL 70

Expert Comment

by:Chris Dent
ID: 12286428

I just wanted to back Scampgb up a bit, since there seems to be a little confusion around this.

> Again INCOMING is POP3: 110
> and OUtGOING is SMTP: 25

This refers to Client Access to Mail Server, not Mail Server to Mail Server communications. The POP3 Service is generally used by clients (such as Outlook Express and Outlook) to Receive E-mail (hence Incoming).

While Exchange can be set up to receive e-mail via POP3 the use of an MX Record indicates that it is being accessed directly by other Servers.

For the rest of it I think Scampgb is fine (although in my opinion I'd still say the Firewall is causing a problem) ;)
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12301915
Chris-Dent:   Thanks for the backup :-)

I think that there's a router/firewall config issue here.

Funnei - any news?
0
 
LVL 5

Expert Comment

by:AutoSponge
ID: 12333165
Try using tcptraceroute to trace on port 25.  You'll need a linux box to run it from, but it should help isolate the problem.

http://www.zone-h.org/en/download/category=49/
0
 

Author Comment

by:funnei
ID: 12422519
I have replaced the Buffalo router, and hey presto, it's all working.  Many thanks to all who tried to help.
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12431079
Glad that it's working - I thought it was a firewall/router issue :-)

0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 12663791
PAQed with points refunded (250)

modulo
Community Support Moderator
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now