Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Slave Hard Drive. Access without having to format.

Posted on 2004-10-01
9
Medium Priority
?
1,634 Views
Last Modified: 2010-04-03
I have a second 100MB Maxtor slave hard drive. I partitioned it with Maxblast. The main system running Windows XP became so slow I decided to re-install. I backed up EVERYTHING using Backup devil to the slave Maxtor drive. It was all copied and accessibility checked. It was all there. Carried out re install and wow the speed now makes it all worth while...BUT initially Windows refused to recognise the slave drive at all. Running Maxbalst got it to recognise the drive as K. But it now says it is a 30 gig disk and wants me to format it! How can I access all my old data on the slave drive without formatting....if I lose all our photos then I am a dead man!
0
Comment
Question by:richardheggie
9 Comments
 
LVL 69

Accepted Solution

by:
Callandor earned 336 total points
ID: 12200555
Try GetDataBack from www.runtime.org.
0
 
LVL 93

Expert Comment

by:nobus
ID: 12201730
What operating system was on it? and what file system?
0
 

Author Comment

by:richardheggie
ID: 12202312
OS is XP. Main boot drive is NTFS but on checking the "Properties" of the slave K drive in My Computer it shows a RAW as the file system. Also it shows that there is neither any used space or free space.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 11

Assisted Solution

by:huntersvcs
huntersvcs earned 332 total points
ID: 12202920
Sounds like it wasn't initialized.  Leftclick on the drive letter in the administration console (not explorer) and see if it's an option.  Have you tried that?  Sometimes Partition Magic can repair bad data.  30GB almost sounds like the jumpers are set wrong.  There is a 30G clip jumper setting on some HDDs.  Does the BIOS show the correct size?  If not, it's most probably a jumper issue.
0
 

Author Comment

by:richardheggie
ID: 12203076
To clarify...this drive has worked perfectly in the recent past...jumpers set properly. It originally started out with capacity issues but Maxblast sorted this out and the full 100Gb was recorded. BIOS shows the drive..I will check what size it shows. As I say the data is all on the drive because I checked it was all there prior to re-installing XP. I will try the initialisation point. Thanks everyone.
0
 
LVL 6

Assisted Solution

by:WhitePhantom
WhitePhantom earned 332 total points
ID: 12206143
Before I even begin, I have made some assumptions, which may be incorrect:
I assume MaxBlast was installed at some point (before you made the backup) to manage the hard drive due to a BIOS that was unable to read its full capacity.
I assume your current BIOS is capable of reading the drive's full capacity and that MaxBlast is still installed as your hard drive manager.

Because this is such a lengthy post, I will give you my suggestion up front, and you can read the rest if you think it could be the solution you need.

Suggested Solution:
I believe you may need to remove the MaxBlast software to let your BIOS take control of the hard drive before you will be able to read the partition that existed when you made the backup.

On to the details, and I apologize for the detail in this post, but it was required for me to make sense. I sympathise with your situation and I sincerely hope you get your data back.  I may or may not be pinpointing your problem, but it's definitely possible.

Back when you had capacity issues and sorted it out with MaxBlast, did MaxBlast augment the system BIOS?  In other words, was the BIOS unable to read the full size of the hard drive until you installed MaxBlast to manage the hard drive?  If that is the case, then that may be why you are having problems reading the data now.  I used to use similar software, which was called EZ-Drive.  I have run into many different types of hard drive management software that has kept me from being able to read the data on a hard drive.  In every case, I used EZ-Drive to replace whatever other software was managing the hard drive, and then I uninstalled EZ-Drive, after which I was able to read the drive's data.  Here is an example of why this had to be done:

Suppose I installed an 80GB hard drive into a computer, but the BIOS was only capable of handling 32GB.  I booted up to DOS and setup EZ-Drive to manage the hard drive and format as FAT32.  After that, every time I  began to boot up the computer I would see a message indicating that EZ-Drive was starting and I could press a couple of keys if I wished to boot to a floppy disk.

Ok, this can get confusing, so I'll explain (trust me, this will bring me to a relevant point).  Why did it give me the option to boot from a floppy disk after EZ-Drive was initialized?  Because at that point, the BIOS had already given the go-ahead to start booting from the hard drive.  Once the BIOS did that, EZ-Drive took over completely.

Here are two scenarios, both booting from a floppy disk, but only one in which the drive would be readable.

1.  If I enable booting to the floppy drive in the BIOS and leave a bootable floppy disk in the 3½" drive, the system BIOS (not EZ-Drive) will boot to a floppy disk, but the EZ-Drive managed hard drive will not be readable in DOS.

2.  If I disable booting to the floppy drive in the BIOS and leave a bootable floppy disk in the 3½" drive, the system BIOS will ignore it and boot to the hard drive.  However, as I mentioned earlier, EZ-Drive will then give me the option to press a couple of keys in order to boot to the floppy drive.  After booting up to DOS from the floppy drive, the 80GB drive is completely readable because the EZ-Drive software was loaded before booting up.

Back to your problem:
As I said before, I believe you may need to remove the MaxBlast software to let your BIOS take control of the hard drive before you will be able to read the partition that existed when you made the backup.  If MaxBlast offers the option to create a boot disk, that may be the best way.  You need to remove it from the drive itself, not Windows.  Even deleting the partition would not remove the software I'm talking about.  I've always removed hard drive managers (including MaxBlast) with an EZ-Drive boot disk (very old software; I only use it for removal).  That is why I suggest a boot disk, but you may know of a better way.  Good luck!

WhitePhantom
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question