Solved

Networking an Windows XP and Win98 together for file and print sharing

Posted on 2004-10-01
4
218 Views
Last Modified: 2010-03-18
I have a small home network consisting of two computers, a broadband cable modem and a Lynksys Router. One machine is running Windows XP Service Pack 2 Home Edition and the other is running Windows 98 First Edition. Both machines are working great and can share the internet without any problems. However, I cannot get the Win98 machine to be able to access files on my Windows XP machine but I can use the XP to access the Win98. I also cannot get the Win98 machine to recognize the HP DeskJet 950C that I have directly connected to the XP machine. I would like to be able to print to it from both machines, not just the XP. I would also like the Win98 machine to be able to access files on the XP machine. I have searched the internet high and low and tried so many different things that people have suggested but there just isn't much out there for this scenario. I've made sure that file and print sharing is enabled on both machines and I've made sure that I named the computers and the network and that I input those names correctly. Why can the XP machine access the 98 but not the other way around? And why can't I print from the 98 machine? Please help! I'm at my wits end!
0
Comment
Question by:dbrooks359
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 10

Expert Comment

by:Luxana
ID: 12204867
In order to print from win98 to winXP you need tha share your printer first and to share fiels you need to enalbel file sharing:

http://www.practicallynetworked.com/sharing/xp/filesharing.htm


then right click to printer on your winXP and enable sharing.
0
 

Author Comment

by:dbrooks359
ID: 12206193
I've already done all of that. When I try to navigate to anywhere on the network through Network Neighborhood on the Win98 machine, it gives me an error that no other users can be found. It's like it can't see the the network at all. The print sharing and file sharing is fully activated. It's the Win98 machine that will not see the network. Please help. What am I doing wrong?
0
 
LVL 10

Expert Comment

by:Luxana
ID: 12206440
did you logon to microsoft network?
right click network neiborhood - properties -
also from win98 try
start-run
\\<ip of your XP>\sharename
paste error here if you get one..
0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 500 total points
ID: 12211402
http://www.wown.com/j_helmig/wxpwin9x.htm
and from a great expert lrmoore
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

-------------

Next, check your XP networking setup:

http://support.chartermi.net/support/pipeline/windows/winxp_network.html

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

-------------

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

----------------

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

----------------

Client for Microsoft Networks needs to be the primary network logon for all other machines

----------------

All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

References:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

http://support.microsoft.com/default.aspx?scid=kb;en-us;314366

http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm

http://www.michna.com/kb/WxNetwork.htm




0

Featured Post

Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Downtime reduced, data recovered by utilizing an Experts Exchange Business Account Challenge The United States Marine Corps employs more than 200,000 active-duty Marines with operations in four continents, all requiring complex networking system…
Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question