Solved

Redhat9 and Windows XP -Internet Sharing...

Posted on 2004-10-02
5
194 Views
Last Modified: 2010-03-18
hello all,

i'm new to linux and i have been having trouble connecting two systems together to share internet.  I have a dell poweredge server running redhat 9 and another box running windows xp. I'm also using a cable connection.  Any assistance to do this is highly appreciated.  I'll post the necessary files for you to view and offer suggestions for corrections.  Thanks in advance for your assistance.
0
Comment
Question by:cossy64
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 16

Accepted Solution

by:
xDamox earned 125 total points
ID: 12208402
0
 
LVL 3

Assisted Solution

by:jacauc
jacauc earned 125 total points
ID: 12210526
I'd assume that your cable connection is connected to the Linux box, and the Linux should act as the gateway?

If this is the case, there quite a couple of configurations that can be done to make this work.
here's a couple common solutions
1) Simply routing all traffic from the other PC back and forth to the internet (not recommended)

2) setting up NAT on the Linux box, so that IP masquerading is done to the internet (MUCH more secure than 1)
more info on http://en.tldp.org/HOWTO/IP-Masquerade-HOWTO/

and then (my favorite) - as an addon to option 2:
3) Having NAT work together with squid proxy to act as a Transparent proxy server (all traffic passes through the proxy - no client config neccessary)
This config is actually much more simple than i thought at first.. :D
In effect all that needs to be done (assuming squid and iptables is installed) is:
  These 4 lines need to be in /etc/squid.conf  
     httpd_accel_host virtual
     httpd_accel_port 80
     httpd_accel_with_proxy on
     httpd_accel_uses_host_header on
  execute the following commands
     squid -z
     service squid restart
     iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128


more info on http://www.faqs.org/docs/Linux-mini/TransparentProxy.html


Hope this helps   :D

Cheers
J
0
 

Author Comment

by:cossy64
ID: 12217800
i'm reviewing the options above and i'll let you guys know how they turn out.  Thanks for your replies...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question