Set hangs at "set-up is now starting windows"

I had win2k domain controller with exchange 2000 on it shutdown unexpectedly. When I started it back up, i received the NTOSKRNL.EXE missing error. I have the ERD disks for it, but when I boot up the server with the install cd, it hangs right before the "option to repair it" page. It states setup is starting windows 2000 at the bottom, but hangs. the keyboard amd mouse do not work. I have to shut it down manually.
This server is in a raid array and we have checked all the hardware. if I place new drives in it and begin the install it gets passed the install point without hanging.
Anybody have any thoughts on how to recover???
infinicom1Asked:
Who is Participating?
 
Worked4meConnect With a Mentor Commented:

  I'm sorry that 2nd link is for Windows hanging at Startup
  This is the link for Windows hanging at setup.
  http://support.microsoft.com/?kbid=234772
0
 
Worked4meCommented:

  I am not sure if you have a Compaq Server or not you can check this.
  http://support.microsoft.com/?kbid=249686

  This is another link for Windows Setup hanging at startup
  http://support.microsoft.com/?kbid=217073
  It refers to Windows hanging because it does not recognize or
  cannot configure the hardware in your computer.

  Good Luck.
0
 
Julian HansenCommented:
Sounds like you might have a disk error - are you sure all the disks are fine?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.