Solved

SBS 2003 Cannot connect to SMTP server

Posted on 2004-10-03
44
622 Views
Last Modified: 2008-05-29
CONFIG:
SBS 2003 Small Business Server Premium (all updates installed) ran email internet connection wizard after updates
Default Exchange SMTP service is running
Port 25 is open on Router and forwards requests to 192.168.1.100 (sbs mail server)
Reverse Lookup is in place with ISP
All clients using xp pro SP2

Default SMTP Virtual server ip is set to 192.168.1.100 (the sbs server)  
Authentication for virtual smtp server is set to "integrated windows authentication" only
Authenticated users have submit and relay permissions
Connections allowed are 192.168.1.100 (the SBS mail server) and 127.0.0.1 (loopback)
Relay allowed same as connections plus all authenticated users

Can telnet to port 110 and connect
Can telnet to port 25 but server does not respond

QUESTION: How do I establish an SMTP connection?

0
Comment
Question by:brm123
  • 20
  • 7
  • 7
  • +2
44 Comments
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
Hi brm123,
 
The problem could be one of a few things, so we'll need to do a test to find out what's going on.

Firstly, can you please try the telnet test from a PC on the same LAN as your server (192 address) and one externally?
Details of what to do can be found at http://support.microsoft.com/default.aspx?kbid=153119&product=exch2k

Can you let us know what happens with this test?  If it doesn't work internally, then it's probably something to do with the SBS machine/Exchange

Do you have ISA or RRAS installed on the SBS server?

Also - go to http://www.dnsreport.com/ and put in your domain name.  Check that it doesn't complain about anything.

Check with your ISP.  Some ISPs block incoming connections on port 25.

Also - you said that you'd configured only to allow SMTP connections from the SBS server itself.  That would stop it responding to SMTP requests from other machines :-)

Does that help?
0
 
LVL 15

Expert Comment

by:vico1
Comment Utility
Just Like Scampgb Said, Some ISP block port 25. There is two ways around that.

1.- make youe clients access the smtp server via port 26.
     then redirect port 26 to port 25 on your router.

2.- If your clients are using outlook 2003, Make them connect to the exchange server by using RCP over HTTP.
If you need more help on configurations, let me know

Good luck!

Vico1
0
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
vico1,

Thanks for your suggestions, but I don't think they're really going to help here.

1 - As the problem is (presumably) receiving SMTP messages from the Internet, changing what port number your Exchange server uses isn't going to help.  Unless you've got a way of pursuading all of the mail servers on the Internet to start using port 26 :)

2 - I don't quite see how this relates to the problem?
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
dnsreports:
domain test found Mx record no problem
email test timed out no connection to server

config:
changed connection to allow all

Telnet:

cannot telnet to server port 25 using computer on internal lan

Router:
does not support port redirection

would prefer to use smtp for client connection

i used all wizards as per the to do list. Including remote access

0
 
LVL 15

Expert Comment

by:vico1
Comment Utility
NO You do not change the port on you exchange server.

Your normal port 25 has to stay open for your smtp server to communicate with other smtp servers so is your port 25 on your router.
in addition to that ,open port 26 on your router and redirect it to port 25 of your exchange.
now configure your client to use port 26.

Now I am assuming that your server is able to communicate with other SMTP and only some of you clients are unable to connect using smtp.

Like i said 2 solutions, and i have done both.

I prefer RPC over HTTP this way you do not worry about port 110 you only need port 443, if you are using outlook 2003
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
road runner does not block port 25
0
 
LVL 15

Assisted Solution

by:scampgb
scampgb earned 100 total points
Comment Utility
vico1: I see where you're coming from now - It wasn't entirely clear.
Not that it matters in light of brm123's post.

brm123:
Are you having any problems sending emails, or just receiving?

Can you please go into Exchange System Manager> Servers > [your server] > Protocols > SMTP
You'll see the SMTP virtual server there.
Right-click and choose Properties.
Can you please let us know what's set up under the "Access" tab?

Also - are there any firewalls (including the MS built-in firewall), ISA server or RRAS installed on the server?

Could you also please do the telnet test from the Exchange server itself - connecting to both it's Internal (192) and Loopback (127) IPs?
0
 
LVL 15

Assisted Solution

by:vico1
vico1 earned 400 total points
Comment Utility
Did you enable email when you ran Internet connection wizard?

If so are you able to send and receive email while in the local intranet?

Do you have ISA 2000 intalled on the server, And did you appy the patches?
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
brm123:
Are you having any problems sending emails, or just receiving? just receiving

Can you please go into Exchange System Manager> Servers > [your server] > Protocols > SMTP
You'll see the SMTP virtual server there.
Right-click and choose Properties.
Can you please let us know what's set up under the "Access" tab?

Default SMTP Virtual server ip is set to 192.168.1.100 (the sbs server)  
Authentication for virtual smtp server is set to "integrated windows authentication" only
Authenticated users have submit and relay permissions
Connections allowed are all
Relay allowed same as connections plus all authenticated users

Also - are there any firewalls (including the MS built-in firewall), ISA server or RRAS installed on the server? only if installed by default. using single network adapter. Linksys router.

Could you also please do the telnet test from the Exchange server itself - connecting to both it's Internal (192) and Loopback (127) IPs? tried it "ould not establish connection to host"
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Did you enable email when you ran Internet connection wizard? Yes

If so are you able to send and receive email while in the local intranet? yes

Do you have ISA 2000 intalled on the server, And did you appy the patches? onlt if it installed byt default

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Could you also please do the telnet test from the Exchange server itself - connecting to both it's Internal (192) and Loopback (127) IPs? tried it "ould not establish connection to host"


SORRY! did not do this correctly will retry.  GOOD i can telnet to port 25 using the 192.168.1.100 address both from the server itself and from naother pc on the lan. DNs issue???
0
 
LVL 15

Expert Comment

by:vico1
Comment Utility
How many network interface card on the SBS Server?
0
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
brm123,
> GOOD i can telnet to port 25 using the 192.168.1.100 address both from
> the server itself and from naother pc on the lan. DNs issue???

Excellent news.  So, you can connect to the mailserver on port 25 when using its IP address, but not its name?
That sounds like an Internal DNS issue.
That shouldn't affect External emails coming in to the network though.

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Excellent news.  So, you can connect to the mailserver on port 25 when using its IP address, but not its name? using it's "internal" ip adress.

That sounds like an Internal DNS issue.

That shouldn't affect External emails coming in to the network though. tried sending myself an email from my yahoo account, failed.

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
How many network interface card on the SBS Server? one
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
I can send email to my yahoo account. But when I reply to the test email the reponse is Message from  yahoo.com.
Unable to deliver message to the following address(es).

{email address removed - ee_ai_construct}
Sorry, I wasn't able to establish an SMTP connection. (#4.4.1)
I'm not going to try again; this message has been in the queue too
long.
0
 
LVL 15

Expert Comment

by:vico1
Comment Utility
I suggest to use two nick cardS; one for your local area and one for your internet connection.

You alrerady said that you are using SBS 2003 premium, therefore you could install the ISA 2000. forwarding ports to your internal network is very dangerous.

SBS 2003 uses yourdomain.local on the internal network that will cause you from receiving email.

By using two nick card you are able to use yourdamain.local on the internal side of your network, and yourdomain.com on the external side.

If you are going to configure SBS for e-mail do it the wasy that Microsoft recommend it: (Two nick cards).
0
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
Hi Vico - where do you get that information from?
It's perfectly normal to have a mail server with one NIC on an Internal IP address with a router performing NAT.
I don't see that brm123 needs ISA server to make Exchange SMTP work.

There's nothing particularly dangerous about forwarding ports to your Internal network, provided you know what you're doing.
0
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
brm123,
Posting email addresses in E-E is discouraged around here.  I've asked a moderator to edit it for you (http://www.experts-exchange.com/Community_Support/Q_21154127.html)

Right - it looks like you've got two issues here:

1 - Internal DNS isn't set up properly.  It doesn't have the name that you're using to access your SBS server listed in the local zone.

2 - Your router isn't correctly configured to forward to your mailserver


(2) is the issue we're trying to resolve here.


Please can you check the router configuration - and that it's configured to "port forward" port 25 with protocol TCP to 192.168.1.100?
If you're having difficulty with this, please let me know the exact make and model of your router.

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
brm123,
Posting email addresses in E-E is discouraged around here.  I've asked a moderator to edit it for you (http://www.experts-exchange.com/Community_Support/Q_21154127.html) ooops Sorry!

Right - it looks like you've got two issues here:

1 - Internal DNS isn't set up properly.  It doesn't have the name that you're using to access your SBS server listed in the local zone. checking this

2 - Your router isn't correctly configured to forward to your mailserver : opened port 25 to forward all requests to 192.168.1.100


(2) is the issue we're trying to resolve here.


Please can you check the router configuration - and that it's configured to "port forward" port 25 with protocol TCP to 192.168.1.100? done
If you're having difficulty with this, please let me know the exact make and model of your router.

tried an nslookup for mx record on amd2000.7497.us, no record found, checking network solutions registration

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Details:
NS75.WORLDNIC.COM. (an authoritative nameserver for 7497.us.) says that there are no MX records for amd200.7497.us.
The E-mail address in charge of the 7497.us. zone is:  namehost@WORLDNIC.COM.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 15

Expert Comment

by:vico1
Comment Utility
Scampgb

I did not say that it cannot be done with one nick card.

You are worrying about just making it work

I am worrying about making it work properly and securely

This server will be wide open as an SMTP relay for Spam e-mail.

Remember this is Small Businees Server 2003 and If not configured properly it will never work properly.

Now To brm123

You are not receiving email because SBS 2003 is not configured with a MX record for your mail ( all your records are .local). You could run the Inernet connection wizard again and make sure to specify that you wnat to send and receive email in the internet. But remember MICROSOFT RECOMMENDATION for SBS server hosting e-mail is: two nick cards.

This info can be found on your small business support disk.

Good luck!

Vico1

0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Actualy I have two cards but when I tried the setup I could not get it to work with wireless router so went back to single which I was experienced with. I am rethinking that for reasons you (Vico1) stated. I have also learned that I should not disable DHCP unitl after SBS setup tells me to. No doubt that caused my problem. May try it again later after I get this issue resolved.

Thanks for the help. I may let it rest while waiting for reponse from Networksolutions engineering. The Mx records is there but their server are reporting it is not.  

0
 
LVL 15

Expert Comment

by:scampgb
Comment Utility
brm123,
You don't need an MX record for "AMD2000.7497.us", you just need one for "7497.us"
According to DNS report you've got this set up correctly.

The mail server for your domain 7497.us is being returned as 24.173.164.234

Is this the Public IP address that your router is configured to forward on to 192.168.1.100?
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
The mail server for your domain 7497.us is being returned as 24.173.164.234 Ok

Is this the Public IP address that your router is configured to forward on to 192.168.1.100? Yes
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
You don't need an MX record for "AMD2000.7497.us", you just need one for "7497.us"
According to DNS report you've got this set up correctly.

According to Network Solutions I do. Their example for MX record setup is"

ADD OR EDIT MAIL SERVERS(MX RECORDS)
 
Currently Managing Domain : 7497.us

Add new e-mail server information or update the order in which e-mail will be attempted to be delivered.
 
Domain: 7497.us  
Priority Mail Server (Example: mail.your-domain.com)
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Curious what's in your HOSTS file.
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Curious what's in your HOSTS file. Wherre do I find it?
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Hosts file has no extension, typically found here (but varies by OS environment) ...
These are the default paths
Windows XP = C:\WINDOWS\SYSTEM32\DRIVERS\ETC
Windows 2K = C:\WINNT\SYSTEM32\DRIVERS\ETC
Win 98\ME = C:\WINDOWS


More about that here:
http://www.mvps.org/winhelp2002/hosts.htm
0
 
LVL 16

Expert Comment

by:Nyaema
Comment Utility
You cannot telnet to port 25 because the interanl IP of the router is not included in the settings of the virtual SMTP server
You have 192.168.1.100 and 127.0.0.1

Change the Connections allowed setting for SMTP virutal server to include the internal IP address of the router
which is? ....
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
You cannot telnet to port 25 because the interanl IP of the router is not included in the settings of the virtual SMTP server
You have 192.168.1.100 and 127.0.0.1

Change the Connections allowed setting for SMTP virutal server to include the internal IP address of the router
which is? ....

Actually I reset this to allow all. Also verified the reverse lookup.  Still cannot connect to SMTP server.
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Curious what's in your HOSTS file. Only references to ip 127.0.0.1
0
 
LVL 16

Expert Comment

by:Nyaema
Comment Utility
What is the exact response you get when you telnet to port 25?
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
What is the exact response you get when you telnet to port 25?

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Braxton Miller>telnet 7497.us 25
Connecting To 7497.us...Could not open connection to the host, on port 25: Conne
ct failed
0
 
LVL 16

Expert Comment

by:Nyaema
Comment Utility
From Exchange System Manager....

Expand Administrative groups->site->servers->server->protocols->smtp
Has the "SMTP Virtual Server" got a cross on it"
If it does the server is not running. right click on it and select start to start it.

Right click on the "SMTP Virtual Server" and select properties
On the General Tab
IP should be all unassigned

On the access Tab
Click on Connection
Select All Except List below

Once you have confirmed the above settings
Try and telnet from the router to the internal IP of the Exchange Server on port 25
Then from a remote PC
This way you should be able to pinpoint where the problem lies.
0
 
LVL 15

Accepted Solution

by:
vico1 earned 400 total points
Comment Utility
brm123

Your SBS Server will not allow  an external ip to connect to the local area network that's why I told you to use two nick cards. SBS configure exchange to relay messages only for local IP.

You need to add a second nick card, Identify it as your internet card in the wizard. (Note that it has to be on a different subnet not to interfere with NAT):

Do the following:

1.- Add a second Nick card Give it a Static IP and point the DNS server to your server:
IP Address          10.0.0.2
NET MASK          255.255.255.248
Default Gateway  10.0.0.1
DNS                   192.168.1.100

After doing so Reconfigure your router like follow:
  a.- Wan IP Stay (No change)
       LAN IP         10.0.0.1
       NET MASK    255.255.255.248  (That gives you 6 available IP) OR You could change the mask to suite you need
  b.-Redirect port 25 to 10.0.0.2
      Redirect any port of your choice to your server. For SBS 2003 you will need the following: (HTTPS 443), (RWWP 4125), (SMTP 25) (VPN 1723).

2.- Run the internet wizard.
     Make sure to enable email
     If you need any help let me know
     
Vico1



2.-
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
From Exchange System Manager....

Expand Administrative groups->site->servers->server->protocols->smtp
Has the "SMTP Virtual Server" got a cross on it"
If it does the server is not running. right click on it and select start to start it.

Right click on the "SMTP Virtual Server" and select properties
On the General Tab
IP should be all unassigned "Correct"

On the access Tab
Click on Connection
Select All Except List below "Correct"

Once you have confirmed the above settings
Try and telnet from the router to the internal IP of the Exchange Server on port 25 "How do I telnet form Router?"
Then from a remote PC
This way you should be able to pinpoint where the problem lies.
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Your SBS Server will not allow  an external ip to connect to the local area network that's why I told you to use two nick cards. SBS configure exchange to relay messages only for local IP. "not correct  have had this configuration up and runnng fine. So far the only difference I can see is when I did the reinstall I used a newer veson of the CDs."

You need to add a second nick card, Identify it as your internet card in the wizard. (Note that it has to be on a different subnet not to interfere with NAT):

Do the following:

1.- Add a second Nick card Give it a Static IP and point the DNS server to your server:
IP Address          10.0.0.2
NET MASK          255.255.255.248
Default Gateway  10.0.0.1
DNS                   192.168.1.100

After doing so Reconfigure your router like follow:
  a.- Wan IP Stay (No change)
       LAN IP         10.0.0.1
       NET MASK    255.255.255.248  (That gives you 6 available IP) OR You could change the mask to suite you need
  b.-Redirect port 25 to 10.0.0.2 "my lnksys wireless g does not support redirect"
      Redirect any port of your choice to your server. For SBS 2003 you will need the following: (HTTPS 443), (RWWP 4125), (SMTP 25) (VPN 1723).

2.- Run the internet wizard.
     Make sure to enable email
     If you need any help let me know
     
Vico1

Thanks for help. Please keep tryng really want to award the points.
0
 
LVL 16

Expert Comment

by:Nyaema
Comment Utility
What kind of router do you have?

From a Cisco
assuming not telnet secuirty limitation...
-ip address of router (192.168.1.xxx)

start->run
telnet 192.168.1.xxx

telnet 192.168.1.100 25

The above telnets to port 25 of your server


And are you really sure port 25 on router is forwarded to 192.168.1.100??
I think the problem is with the router forwarding.
Anyway try the above and we will know for sure

0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
And sometimes, after verifying the elements in the Router; a reset helps.
0
 
LVL 1

Author Comment

by:brm123
Comment Utility
Sorry guys. Server was down. no email!!!. I reinstalled SBS2003 using 2 nics the problem did go away. All services i need are working. I hope you all thnk the point split is fair.  
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
I think it's totally fair, and happy you're back with "issue resolved".  ":0) Asta
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now