?
Solved

PIX 501 SMTP and WWW

Posted on 2004-10-03
1
Medium Priority
?
466 Views
Last Modified: 2012-06-14
Hi,

I've just got a PIX 501 and have no experience of configuring one of these devices.

Please could some tell me how to create a nice and simple setup which will allow my network traffic out and only SMTP and HTTP traffic in.

Regards

Jon.
0
Comment
Question by:jonnyenglish
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 3

Accepted Solution

by:
oldhamuk earned 500 total points
ID: 12212202
Hi jon,

Below is a simple PIX 501 config for you firewall. It allows SMTP and HTTP traffic in and your traffic out.

Replace the follwoing:

192.168.100.1 with the external ip address of your firewall.

192.168.100.254 with the ip address of your router.

10.0.0.1 with the internal ip address of your firewall.

10.0.0.2 with the internal ip address of your SMTP server.

10.0.0.3 with the internal ip address of you HTTP server.

10.0.0.4 with the internal ip address of the client machine you will use for managing the firewall.

firewall with the hostname of your firewall.

domainname.local with the internal domain name of your network.



-- copy the below and paste it into a console session while in config mode. --

interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname firewall
domain-name domainname.local
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 101 permit tcp any host 192.168.100.1 eq smtp
access-list 101 permit tcp any host 192.168.100.1 eq www
access-list 101 permit icmp any any echo-reply
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.100.1 255.255.255.0
ip address inside 10.0.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.0.0.4 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 192.168.100.1 smtp 10.0.0.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 192.168.100.1 smtp 10.0.0.3 www netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.100.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.0.0.4 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
console timeout 0
terminal width 80


0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question