Solved

Won't connect to my own running FTP or even any other!

Posted on 2004-10-03
13
287 Views
Last Modified: 2013-11-29
I have Windows XP PRO Sp2, I installed the FTP Service from the IIs using the ADD/Remove Programs (Add Windows Components) in control panel, then I loaded IIs from Administrative Tools in the start menu.

1. I stopped the FTP site (the one included by default)
2. I loaded its properties, made some basic changes.
a. changed from default directory to shared folder
b. changed from "all unassigned address" to my IP from the drop down menu (i dont have a static IP)
c. changed ftpname (called description I think)

Everything else the same (default): IIs controlled password, anonymous enabled, etc..

3. Finished and Started it again. Loaded IE and typed in the address "ftp://myiphere"

It keeps searching but it finds nothing!

I cannot even connect to other ftps of my friends. It keeps searching and it does not find anything, although their ftps working fine and they connecting to each other. My ZoneAlarm firewall is also disabled (I temporarily disabled it just to be sure its not the reason).

I also have my router port forwarding (tcp port 21) to my ip address that was listed in the FTP settings, even port 20 port forwarded as well as it is for the transfer and 21 for establishing the connection itself.

Whats blocking me to access any ftp at all? What is blocking me from accessing even my own ftp which I'm running on the same computer?!! What exactly do I have to do to solve this situation? I have also tried Serv-U once, did not work.. but I prefer the XP IIs, unless you have a really good I should change to something else.

I just need to get this working, I've read a lot on the net on this issue, but I am still totally stuck. Thanks in advance for the help!
0
Comment
Question by:Archmudo
  • 6
  • 3
  • 3
13 Comments
 
LVL 2

Expert Comment

by:cwisofsky
ID: 12213427
Check to make sure that the Windows XP firewall is not on.  Since you have XP SP2, it's typically on by default.  Windows firewall is configurable via the control panel in SP2.

Use all IP addresses if you do not have a static IP.
0
 
LVL 2

Expert Comment

by:cwisofsky
ID: 12213432
You can also test connectivity to a port by using TELNET IP space PORT, i.e:

     TELNET 10.1.1.1 21

0
 

Author Comment

by:Archmudo
ID: 12213460
The XP firewall is turned off ofcourse. Dont know what u mean by testing the port by TELNET, is it important, and should I change back to "All Unassigned" not my IP address? Will that make it work, or is it just a tip? Besides, if I change it to "all unassinged", will I still need to connect using ftp://myipaddress?

I also heard others tell me something no-ip.com address or something. Whats that about? Can it help me since I dont have static IP?
0
 
LVL 2

Accepted Solution

by:
VertigoRay earned 50 total points
ID: 12214591
no-ip.com can help you by assigning a dynamic IP address to a Statics DNS name.  You simply run a program on your computer, and whenever your IP address changes, it sends the changes to the DNS servers owned by no-ip.com.  However, this will not help your current issue.  Personally, I use http://www.dyndns.org/

As for the TELNET ordeal, just type the command he gave you at the Command Prompt.  Your screen should black out and as you type you probably won't see anything.  You can exit the TELNET session by simply typing "exit" (You won't see the typing).
0
 
LVL 2

Expert Comment

by:VertigoRay
ID: 12214592
Also, you may want to try connecting to your own FTP site using "localhost" or "127.0.0.1"
0
 
LVL 2

Expert Comment

by:cwisofsky
ID: 12216510
Archmudo, yes change the setting back to "All Unassigned Addresses".  This will help alot with testing since it removes one more potential set of problems.  It does not limit the way you connect at all.  It actually increases the options that the FTP service will respond to.  Such as ftp://xx.xxx.xx.xxx assigned by the DSL / Cable provider.  Or the 127.0.0.0 mentioned above.  Or FTP://198.162.1.3 assigned by an internal router (The 192.x.x.x addresses can only be used for testing inside your home, it will never translate across the internet).

0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 2

Expert Comment

by:VertigoRay
ID: 12239278
So, did you fix everything?  Got an update?  More issues?  Fell off the face of the earth?

Let us know if we can be of further assistance.
0
 

Author Comment

by:Archmudo
ID: 12264511
Sorry for late reply.. I did as you told me, opened command prompt, and typed the following..

telnet 68.214.39.230 21

I got the message below:

Connecting to 68.214.39.230...Could not open connection to the host, on port 21: Connect failed

You should know that I have a network, my lan IP is 192.168.1.1

my router has port 21 forwarded to that LAN IP

soo.. any more ideas?
0
 
LVL 2

Expert Comment

by:cwisofsky
ID: 12264844
You will not be able to do an 'inside - out' telnet or other connection.  To test internally, you have to use the interal IP of you computer, in your case you mentioned it was 192.168.1.1.  So try telnet 192.168.1.1 21.  If that command gives the same message (or a similar message), then you know that you have a firewall issue OR the FTP service is not laoding properly and you can check the Application Event Log for errors on that.  
0
 
LVL 2

Expert Comment

by:cwisofsky
ID: 12264848
Oh, and I was able to telnet into 64.214.39.230 port 21 from this PC, so you are probably closer than you thought and need to look at username password and other configuration steps.  Remember, do all you testing to the 192.168.1.1 address as long as you are doing it at home.  The outside world will see the same view on port 21 of your IP address even though it seems like the wrong IP to you.
0
 

Author Comment

by:Archmudo
ID: 12269435
ok this time I did "telnet 192.168.1.1 21"

and nothing is happening.. cursor blinking and that's it
0
 
LVL 2

Assisted Solution

by:cwisofsky
cwisofsky earned 75 total points
ID: 12289073
Sounds good to me, you 'connected' to your ftp server.  Use that IP address when you continue your testing.  

For example to test from Internet Explorer use:

     ftp://username:password@192.168.1.1

Since that is currently not working, I would try removing IIS via the add/remove programs interface and then readding it with the default settings.  They work fine and you should always test them out before you make changes to FTP settings.
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Join & Write a Comment

Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now