Solved

Load balance using both ISDN and Leased Line on Cisco 2621 router

Posted on 2004-10-04
8
569 Views
Last Modified: 2013-12-29
Our branch office is connected to the HQ through a 64K leased line and is having a ISDN BRI as the backup line. Due to the nature of the business, the link becomes very congested over the month end period due to heavy business transactions.

Is there anyway I can configure the ISDN to kick in when the load on the Serial Interface has reached certain percentage and share the load with the leased line? I have done some testing on the router and the ISDN does kick in when the load on the router Serial interface has reached 60%, however the load is not shared after the ISDN has kicked in, because I can see all the traffics still flow through the Serial Interface.

Your expert advise is very much appreciated. Thanks.

Joe
0
Comment
Question by:pogt
  • 4
  • 3
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12216309
If the ISDN link comes up, but you don't send traffic over it, then you may have a routing problem. Can you post your complete config? (remove passwords and any public IP's)
0
 
LVL 5

Expert Comment

by:zerofield
ID: 12217066
ive never done it with BRI/PRI lines, but i'd imagine it'd still be in the DDR section.  it goes without saying you'd be better off bumping that line up to a fractional t1 or something :/
0
 

Author Comment

by:pogt
ID: 12223147
Following is the configurations, all public ip addresses aren't the real one.


Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname branch
!
logging buffered 10000 debugging
logging console critical
!
!
!
!
!
ip subnet-zero
no ip finger
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
!
!
interface Loopback0
 ip address 202.106.200.250 255.255.255.255
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 202.106.200.225 255.255.255.240
 no ip directed-broadcast
 speed 100
 full-duplex
 fair-queue 64 256 0
 no cdp enable
!
interface Serial0/0
 backup delay 10 30
 backup interface Dialer1
 backup load 60 30
 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache same-interface
 no ip route-cache
 no ip mroute-cache
 no cdp enable
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no keepalive
 dialer pool-member 1
 isdn switch-type basic-net3
 no cdp enable
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Dialer1
 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no keepalive
 dialer remote-name Hq_Router
 dialer pool 1
 dialer idle-timeout 180
 dialer string xxxxxxxxx
 dialer load-threshold 1 outbound
 dialer-group 1
 no cdp enable
 ppp authentication chap
 ppp multilink
!
router ospf 1
 log-adjacency-changes
 network 202.106.200.224 0.0.0.15 area 1
 network 202.106.200.250 0.0.0.0 area 0
!
ip classless
no ip http server
!
logging trap debugging
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
 
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12223208
One suggestion would be to use separate IP subnets on the Serial and Dialer interfaces instead of using IP unnumberd with both interfaces using the loopback0 interface IP
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:pogt
ID: 12223837
If I were to use different subnets for the Serial and Bri interfaces, how should the OSPF configuration be changed to accomplish the load balance goal? I am new to OSPF, may be you can provide me some guidance on this. Can I create another loopback interface, says with ip address 202.106.200.251/32 and assign this new loopback interface ip for the dialer, will it work?

Your kind help is very much appreciated. THanks.

Joe
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12229145
Here's how I would set it up:

interface FastEthernet0/0
 ip address 202.106.200.225 255.255.255.240
!
interface Serial0/0
 backup delay 10 30
 backup interface Dialer1
 backup load 60 30
 ip address 192.168.222.2 255.255.255.252  <== other end of this link would be 192.168.222.1 255.255.255.252
                                                                         Should not matter if you use public or private if these are internal
!
interface Dialer1
  ip address 192.168.123.2 255.255.255.0  <== mask depends on if you are connecting to PRI at the other end. Use /30 if BRI
!
router ospf 101
  192.168.222.0 0.0.0.3 area 0
  192.168.223.0 0.0.0.3 area 0
  redistribute connected subnets
>> network 202.106.200.224 0.0.0.15 area 1<< not sure why you have the LAN interface participating in a different area...
!
You might also want to keep the OSPF from dialing up the BRI on it's own by denying ospf in the interesting traffic....
!
access-list 101 deny ospf any any
access-list 101 permit ip any any
!
dialer-list 1 protocol ip list 101


0
 
LVL 79

Accepted Solution

by:
lrmoore earned 175 total points
ID: 12280319
Any luck with this? Do you still need more information?

0
 

Author Comment

by:pogt
ID: 12293627
I am sorry for not being to come back to you earlier. Yes, it works, thank you very much.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now