How to include '+' symbol when using PromptEx

Hi All:

Have a Crystal Report where I am trying to pass 2 arguments: computer program name and version using PromptEx. Almost all of the computer program names display except for one with a version name of "4.0.4a+".  I am assuming the '+' symbol is what is causing the problem.

I tried in my asp page first doing a Server.URLEncode on the version so the portion of the URL string looked like this: ?CodeFamily=GRT33&CompCode=GRT33&Version=4%2E0%2E4a%2B

It did not display any data.

I tried putting quotes around the version like so:
?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a+"

It did not display any data.

Does someone know how you can do this...HELP!
LVL 1
mathew_sAsked:
Who is Participating?
 
CetusMODCommented:
Closed, 50 points refunded.
CetusMOD
Community Support Moderator
0
 
mlmccCommented:
Try using


?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a++"

or


?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a\+"

mlmcc

0
 
mathew_sAuthor Commented:
I tried

?CodeFamily=GRT33&CompCode=GRT33&Version=%224.0.4a++%22

?CodeFamily=GRT33&CompCode=GRT33&Version='4.0.4a++'

?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a++"

?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a+"

?CodeFamily=GRT33&CompCode=GRT33&Version="4.0.4a\+"

Nothing worked. However if I refresh the Crystal Report and enter the values in the Crystal Report when it prompts me for the parameters there is no problem there...I don't get it.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mlmccCommented:
The HTML is grabbibg the + for some reason and not passing it to Crystal.

Where is the problem?  Is it in the report or the ASP page?

mlmcc
0
 
mathew_sAuthor Commented:
Maybe I should change my selection formula for version to 'like' <version> ...or something like that...

But get a load of this.

After I refreshed the Crystal Report and entered the values it worked right. I then looked at the URL and it showed the following:

&promptex-Version=%224%2E0%2E4a%2B%22

I then went to the URL area in IE and just hit enter again and it should just display the same report...but it displays nothing again.
0
 
mlmccCommented:
Sorry.  I don't know enough about Crystal and ASP to be any further help

mlmcc
0
 
mathew_sAuthor Commented:
Here's an update for those of you who want to know how I got this to work. Since ASP kept giving me problems, I decided to go to the selection formula in Crystal and manipulate this to grab the 4.0.4a+ record.

stringvar ASDVersion;
ASDVersion := Left({?Version},6);

If ASDVersion = "4.0.4a" then
   {ASD_Code.Computer Program Name} = {?ComputerProgramName} and
   {ASD_Code.Version} ="4.0.4a+"
Else
   {ASD_Code.Computer Program Name} = {?ComputerProgramName} and
   {ASD_Code.Version} = {?Version};
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.