• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 191
  • Last Modified:

URL defaults to FTP instead of HTTP.

Here's something that's been annoying me for a while...

As my company's webmaster, I often FTP into our company website to upload/download files.  Instead of using a third-party FTP client, I find it's often more convenient to open up a browser, and type ftp://www.companyname.com in the address bar instead of http://www.companyname.com.

Here's my problem:  Somewhere along the line, my browser has assumed that FTP is my default.  When I just tap in "www.companyname.com", it loads up the FTP site.  If I want to view my company's web site, I have to EXPLICITLY type out "http://www.companyname.com," making sure to include that HTTP://.

Annoying!  I've searched high and low, but can't find a way to make it ASSUME I'm trying to visit the WEB site when typing www.companyname.com.  It's a minor annoyance, but those are the ones that make Mondays so rough.

Any help would be much appreciated.

Thanks,
Steve

0
HeitmanProgrammers
Asked:
HeitmanProgrammers
  • 7
  • 5
1 Solution
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Hi

Try Tools --> Internet Options..  Advanced and untick Inline Autocompelete.. That should do it.
Then also delte all temporary internet files.. too.
0
 
HeitmanProgrammersAuthor Commented:
No dice.  I already have Inline Autocomplete un-ticked.  It doesn't "auto-complete" the URL as I type it... it just changes it once I hit enter.

I type "www.companyname.com" and hit enter.

My browser automatically logs in to ftp://ftp.companyname.com/web.

Anyone else?
0
 
SheharyaarSaahilCommented:
Hello HeitmanProgrammers =)

Have u checked in registry yet if ur default prefix has changed to ftp or not ??
if NO then try this !!

goto Start>Run>regedit>and navigate to the following key
>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix
look in the right pane... is the value set to "http://"

if yes then select the below folder of  Prefixes in the left pane,
look in the right pane for www key, can u see "http://" infront of it ??

coz these are the reigstry keys which handles the default prefix for internet explorer.... if they are wrongly assigned, u get this problem !!
and if this is the reason in ur case, u can either correct them manually, or download this registry file and it will do it automatically for u !! :)
http://mvps.org/winhelp2002/RepairDefaultPrefix.reg

Post Back and Good Luck :)
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
HeitmanProgrammersAuthor Commented:
Still no dice.

My default prefix in my registry is set to http://.

Again, this works FINE with every single url EXCEPT that for my company home page.  I believe that I visited my company's FTP site before I ever visited the WWW site, which is likely the cause of this problem.

Anyone else?
0
 
SheharyaarSaahilCommented:
have u deleted all ur History files yet from Internet Options ??
0
 
HeitmanProgrammersAuthor Commented:
Yes.  I have deleted all history files many times since this problem began, as well as all Internet files.
0
 
SheharyaarSaahilCommented:
when in IE, u hit F4 key,,, can u see ftp://ftp.companyname.com/web listed there in the list ??
0
 
HeitmanProgrammersAuthor Commented:
Yes and no.

I see "www.companyname.com" with an FTP icon next to it instead of a WEB icon.

I think you're on the right track... where do I edit this list?
0
 
HeitmanProgrammersAuthor Commented:
Nevermind, we're not on the right track... that's just my history, and it shows up because I've been testing this out.

I just cleared my history, and now it's gone... but www.companyname.com still sends me straight to the FTP site.
0
 
SheharyaarSaahilCommented:
:)

yeah, close all browser and explorer windows and then goto Start>Run>type  regedit  (hit enter)
and navigate to the following key

>> HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs
in the right pane u will see all those F4 addresses, look for the ftp://ftp.companyname.com/web registry key, and u can delete it from there to remove it from that list !!

close regedit, and reopen IE to check now for the problem ??
Post Back :)
0
 
HeitmanProgrammersAuthor Commented:
Nope, that did the same thing as just clearing my history... so no dice.
0
 
HeitmanProgrammersAuthor Commented:
I just solved the problem.

There was a shortcut on my Desktop to the FTP site, and the shortcut name was "www.companyname.com."

So when I would type "www.companyname.com" in my address bar, it would think I was running the desktop shortcut.  The shortcut, was, of course, a link to the FTP site.

Thanks for your help on this!  I'll pretend you got it right and award you the points.
0
 
SheharyaarSaahilCommented:
lol.... how minor things can screw our brains !! ;-)
glad u got it atlast.... thanx for the points and Cheers ^_^
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now