Solved

PIX-to-PIX VPN dedicated to additional outside interface

Posted on 2004-10-04
3
416 Views
Last Modified: 2013-11-16
I added a second DSL line / Interface to set a pix-to-pix vpn up between two locations.  Both locations are running 515e's with 6.3.  lrmoore helped me establish communication between the new interface and interface of the remote pix. ( http://www.experts-exchange.com/Security/Firewalls/Q_21150126.html#12184612 )   Now I'm having problems establishing the tunnel.  It's like its not even attempting to build a connection.  I'm at a stand-still right now.  Any help would be greater appreciated.

Here is a sample of the config.  

#####
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security10
enable password bmVUCXx7cvTZmFOl encrypted
passwd bmVUCXx7cvTZmFOl encrypted
hostname pix01
domain-name DOMAIN
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list acl_out permit icmp any any
access-list acl_out permit gre any host 216.185.x.181
access-list acl_out permit udp any host 216.185.x.181 eq 1701
access-list acl_out permit udp any host 216.185.x.180 eq pcanywhere-status
access-list acl_out permit tcp any host 216.185.x.180 eq pcanywhere-data
access-list acl_out permit gre any host 216.185.x.182
access-list acl_out permit udp any host 216.185.x.182 eq 1701
access-list acl_out permit tcp any host 216.185.x.180 eq 3341
access-list acl_out permit udp any host 216.185.x.180 eq 5900
access-list acl_out permit tcp any host 216.185.x.180 eq 5900
access-list nonat permit ip 192.0.0.0 255.255.255.0 192.0.2.0 255.255.255.0
access-list nonat permit ip 192.0.0.0 255.255.255.0 192.0.1.0 255.255.255.0
access-list nonat permit ip 192.0.0.0 255.255.255.0 10.40.x.0 255.255.255.0
access-list nonat permit ip 192.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list acl_vpn_flo permit ip 192.0.0.0 255.255.255.0 192.0.1.0 255.255.255.0
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.40.x.75
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.40.x.199
access-list acl_vpn_lc permit ip host 192.0.0.5 host 10.40.x.56
access-list acl_vpn_mlt permit ip 192.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging on
logging monitor debugging
logging buffered debugging
logging trap notifications
logging history debugging
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 216.185.x.177 255.255.255.0
ip address inside 192.0.0.251 255.255.255.0
ip address intf2 206.144.x.145 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 192.0.2.240-192.0.2.250
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1 216.185.x.178
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 216.185.x.181 192.0.0.128 netmask 255.255.255.255 0 0
static (inside,outside) 216.185.x.182 192.0.0.130 netmask 255.255.255.255 0 0
static (inside,outside) 216.185.x.180 192.0.0.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 216.185.x.190 1
route intf2 65.67.x.50 255.255.255.255 206.144.x.150 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address acl_vpn_lc
crypto map outside_map 20 set peer 12.125.x.13
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 30 ipsec-isakmp
crypto map outside_map 30 match address acl_vpn_flo
crypto map outside_map 30 set peer 69.223.x.130
crypto map outside_map 30 set transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto map intf2_map 40 ipsec-isakmp
crypto map intf2_map 40 match address acl_vpn_mlt
crypto map intf2_map 40 set peer 65.67.x.50
crypto map intf2_map 40 set transform-set ESP-DES-MD5
crypto map intf2_map interface intf2
isakmp enable outside
isakmp enable intf2
isakmp key ******** address 69.223.x.130 netmask 255.255.255.255
isakmp key ******** address 12.125.x.13 netmask 255.255.255.255
isakmp key ******** address 65.67.x.50 netmask 255.255.255.255
isakmp identity address
isakmp client configuration address-pool local vpnpool1 outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
vpngroup vpn3000-all address-pool vpnpool1
vpngroup vpn3000-all dns-server 192.0.0.5
vpngroup vpn3000-all wins-server 192.0.0.5
vpngroup vpn3000-all default-domain domain
vpngroup vpn3000-all idle-time 1800
vpngroup vpn3000-all password ********
telnet 192.0.0.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
console timeout 0
vpdn group 2 accept dialin pptp
vpdn group 2 ppp authentication pap
vpdn group 2 ppp authentication chap
vpdn group 2 ppp authentication mschap
vpdn group 2 ppp encryption mppe 40 required
vpdn group 2 client configuration address local vpnpool1
vpdn group 2 client configuration dns 192.0.0.5
vpdn group 2 client configuration wins 192.0.0.5
vpdn group 2 pptp echo 60
vpdn group 2 client authentication local
vpdn username thisvpn password *********
vpdn enable outside
terminal width 80
Cryptochecksum:402b0fc8f346d280373664c2dbe031ce
: end
#####

The remote pix is pretty standard configuration.

If you need any additional info, let me know.

Thanks.
0
Comment
Question by:captainpeon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12221733
We need one more route entry for the remote LAN subnet:

route intf2 192.0.0.0 255.255.255.0 206.144.x.150 1
0
 

Author Comment

by:captainpeon
ID: 12221925
lrmoore:  You had mentioned that on the previous post.  Failure on my part.  Thanks again though!  
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12221942
Glad to be of service!
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question