Solved

Cannot connect to network / internet- Win 98

Posted on 2004-10-04
14
412 Views
Last Modified: 2013-12-07
Hello:

Just got another computer off of ebay.

I reformatted, installed windows and:

Connected to cable modem w/static IPs (6 on network)
Confirmed LAN cable is live.
Intel PROSet II software confirms Link & activity; passes EEPROM, Loopback etc.
Driver stats continue to show packets sent & received.
winipcfg shows internal address - not one of my statics (169.254..)
cannot ping

Interestingly, on all of my other machines, when I look at DHCP server in winipcfg, it shows the same address of 10.96.192.1;  must be road runners DHCP server(?) - but with *this* (new) box, the DHCP says 255.255.255.255.

Seems to me - (the *non* -expert) - that it is simply not finding an address from the DHCP server for whatever reason.

Knowing my IP addresses for each LAN cable, I connected one and instead of allowing it to try to find an address, I specified the known address as well as subnet, DNS and gateway.  Surely *this* would solve it, providing the problem was that it was not being addressed properly!

Nope... Hence, my post.  Hoping someone can assist.

-t
0
Comment
Question by:dakine007
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
14 Comments
 
LVL 32

Expert Comment

by:LucF
ID: 12221211
Hi dakine007,

You most likely have a corrupted winsock or tcp/ip stack, try this tool to fix this:
http://www.bu.edu/pcsc/internetaccess/winsock2fix.html

If that doesn't work, please try it manually by following the guide at this page:
http://support.earthlink.net/mu/1/psc/img/walkthroughs/windows_9x_nt/dialers/dun_1.3/5289.psc.html

Greetings,

LucF
0
 
LVL 8

Expert Comment

by:holger12345
ID: 12221581
I think you'll need a new driver for your NIC. Even if some things may be ok when the NIC looks onto the ethernet - i've seen a lot of faults beeing gone by just installing the newest driver.

As you don't tell your cardname, i can just point to the downloadpage of intel -> http://downloadfinder.intel.com/scripts-df/support_intel.asp

If you don't find it there, you should try other resources like windrivers.com etc.

check this out before installing too much

good luck, Holger
0
 

Author Comment

by:dakine007
ID: 12221644
Hi LucF;


The bu.edu.// site says that the winsock fix is for :
This program is designed to fix a situation where all of the following are true:

the computer can get a valid IP address
the computer can ping DNS numbers
the computer can be pinged from other computers
all other network services do not work (Telnet, ftp and Web browsers)

....and in fact, none of the above is true.  Despite this, I went to the earthlink site and followed the instructions to do it anyways.  

Still not working.

Any other ideas?
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:dakine007
ID: 12221669
Holger:

Thanks for the reply - I should have mentioned that I did in fact, re-install the latest drivers for the onboard NIC - downloaded from the MSI site.  Also tried one from Driveguide

...   NIC tests out fine with loopback etc - it appears it is working / installed properly

Thanks!
0
 

Author Comment

by:dakine007
ID: 12222019
Sorry - was re-reading my post above to Holger - it may appear to some users that my problem is solved by the way it reads.

Not so.  Still cannot connect.  

Suggestions?
0
 
LVL 12

Expert Comment

by:Mazaraat
ID: 12222045
If your getting a 169.x.x.x address then its having some type of network communication problem.
I would start with the basics, check your cable? Is it a standard cable or crossover?
Is your router configured for this many IP's?
Sometimes they limit the # of IP's by the subnet mask, what subnet mask do you have on the other PC's?
Check the port the cable is pluged into on the Cable modem, is it a LAN port?

Check this it has some good info:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q220874
0
 

Author Comment

by:dakine007
ID: 12222092
Mazaraat:

Thanks for the reply.

Standard cable is confirmed - working.  When connecting this LAN cable to any other machine on the network, it connects fine.

Router is OK - this nubmer of machines is supported -

0
 

Author Comment

by:dakine007
ID: 12222134
The "problem" that I can see is that all of my other machines show a different DHCP server address.  This one shows 255.255.255.255.

The question of how to change the DHCP address is now raised.

-t
0
 
LVL 1

Expert Comment

by:idez_rsp
ID: 12222494
The 255.255.255.255 is really saying that it doesn't see your DHCP server.  The computer listens or brodcasts for a DHCP server.  It's not seeing yours.  The 169.x.x.x is a IP built in to winsock now so computers that can't see a DHCP server still get an IP.

Since you got this computer from E-bay and as I can see have not been able to verify the NIC's function I would say pop in a new / verified NIC.  ($10).

Also, another thing to try is to manually (via the NIC driver) set the Speed of the card.  I have seen too many that do not properly autosense and don't negotiate the speed properly.

Try setting it to 10MB Full, or 10MB Half.  Cold Boot (No power at all) and see.  Also, you might try releasing the IP on another machine (command prompt:  IPCONFIG /RELEASE)turning off the other computers and rebooting your cable modem just to make sure it's not a Cable Modem config issue.

Good luck!
0
 

Author Comment

by:dakine007
ID: 12222598
Idez:

Have tried another confirmed good PCI NIC - removed the on board and disabled then installed 3com with latest drivers.

I have released other IPs on network... even connected direct from cable modem to NIC.

Odd, because I have added/ changed / moved machines in the past and never had this problem!

Any other ideas?
0
 
LVL 1

Accepted Solution

by:
idez_rsp earned 200 total points
ID: 12222747
Ok.  Try an existing cable from another machine, Use a known good port.  And power down (cold) your Cable modem.

I have seen RoadRunner (in NY) hold a MAC address and not allow another IP to get a lease because the allowed IP's 6? in your case were assigned to existing NIC's.

If that doesn't work try this Tech doc for Troubleshooting Winsock...
http://support.microsoft.com/default.aspx?kbid=314067



0
 

Author Comment

by:dakine007
ID: 12223179
Idez:

Despite releasing IPs from all the other machines, it wasnt until I power cycled the cable modem that this machine found an IP.

Geez!  Seems so obvious!  

Problem solved.  Thank you.
0
 
LVL 1

Expert Comment

by:idez_rsp
ID: 12226546
I've seen it happen all to often.  The Cable company / cable modem locks the IPs to the MAC Address of the computers NIC.  Even when it's down for a while.  RoadRunner (Time Warner Cable) recomends powering down for 20 Minutes in some cases.

Glad I could help.  :)
0
 
LVL 1

Expert Comment

by:idez_rsp
ID: 12226732
Oh, one last thing.  Please remember to close this question out.  :)  

Take care.
0

Featured Post

Report: Liquid Web beats Amazon, Rackspace & More

A study by performance analyst firm Cloud Spectator finds that Liquid Web beats rivals Amazon, Rackspace and DigitalOcean when it comes to website and cloud application performance.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
connect to cisco 2690 series 6 71
Outlook PST (cloud) backup 3 87
Dell SonicWall Connection 18 58
Setting up two DCs 4 46
Let’s list some of the technologies that enable smooth teleworking. 
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question