Solved

Modem problems

Posted on 2004-10-04
23
245 Views
Last Modified: 2013-12-06
Hi we're having trouble dialing out through our modem connected to our HPUX box.  The phone line is good and I believe the modem is good. Below are the commands we are trying. Any suggestions?
Thanks

-# /usr/bin/cu -s9600 -l /dev/ttyd0p7 dir
Connected
at
OK
atdt6109999999
NO DIALTONE
atdt916109999999
NO DIALTONE
atdt16109999999
NO DIALTONE
0
Comment
Question by:timothyking
  • 9
  • 5
  • 5
  • +1
23 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 12223938
The "NO DIALTONE" originates in the modem itself. So you either have a bad modem that can't take the phone line off-hook, a bad phone line, or a phone line not configured for ordinary dial usage. To figure out which it is connect an ordinary phone to the line and see if you get a dial tone.
0
 

Author Comment

by:timothyking
ID: 12228373
The modem and the phone line are worrking. It's a MultiTech 28.8 modem. Anything else I can try?

Thanks
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12229198
Something about the modem and phone line aren't cooperating or you would not be getting a "NO DIALTONE" error from the modem. As I recall, that modem has a speaker, so if it hasn't been disabled you should hear the modem take the line off-hook and hear the dialtone an dialing tones. If you don't hear that something isn't right and it might be that the modem config isn't correct or something just isn't working.
0
 

Author Comment

by:timothyking
ID: 12229495
I tried unplugging the modem cable from the sever and got the same message!

Thanks
0
 
LVL 61

Expert Comment

by:gheist
ID: 12229838
Modems wear off. Sometimes ATA goes first, sometimes ATH1, Sometimes ATS0=1. This is all vacuum tube contancts that burn because of sparks, you can fix it, but it is less time consuming to get new modem instead
0
 
LVL 61

Expert Comment

by:gheist
ID: 12229848
> I tried unplugging the modem cable from the sever and got the same message!
Disable fifo for serial driver to get rid of that
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12229898
Hmm, so maybe that says it is comming from cu. Do you hear any activity on the modem's speaker when you try to dial? If not it might indicate that cu isn't passing the dial command to the modem. Are you using a modem cable?

If you hook a terminal up to the modem will it dial?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12230023
gheist made a good point about the FIFO. Unplugging the modem just caused the last message in the FIFO (NO DIALTONE) to be echoed out again. So we're back to it being a modem/phone line problem.
0
 
LVL 61

Expert Comment

by:gheist
ID: 12230125
One modem at work displayed alike behavior - dialed just fine, but did not ath1 or ata, so I opened it and found that one of two vacuum switches is burn out, so we purchased new cheap no-name serial modem with rockwell chipset, and it still works fine and everyone enjoys havin 56k speed instead of 14.4 from this time, and admins are happy that new modem does not heat up server rack anymore ( at least give another modem a try, not necessarily a brand new modem)
0
 

Author Comment

by:timothyking
ID: 12230744
We have tried about 5 different modems. No luck. Are there any commands to detect the port? or device?

Thanks
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12231900
What I'd try is to take an ordinary PC running windows and connect it to the modem and see if you can get the modem to dial from something like hyperterm. If you can, the problem is with the port setup or cable on HPUX. However if you can't get that combo to dial with any of the modems, try them on some phone line at a residence. If they work there you know it has to be the phone you are using now.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 61

Expert Comment

by:gheist
ID: 12234367
You may recreate serial ports to get clean buffers, disable login via getty on serial port etc( there must be some way to bring serial port to consistent state)
It is much easier to have general-purpose PPP dial-in server for remote connections.
0
 
LVL 6

Expert Comment

by:Panjandrum
ID: 12347201
Can you tell me which type of modem you are using? Which type of HP server + Unix version?
0
 

Author Comment

by:timothyking
ID: 12347295
We've tried a few different types, Multitech Multimodem 33.6, 28.8 Practical Peripheral 28.8. The server is a HP 9000 K Class,  OS version:  11i

Thanks
0
 
LVL 6

Expert Comment

by:Panjandrum
ID: 12347659
I don't want to be a pain in the ass but can you tell me the type of K-Class server? (K100, K220, ...)
If you don't know it, it should be in the little door facing the server.

I imagine that you used the parallel port on the core I/O? Did you try using the internal modem port on the core I/O?

I have some documents on configuring them but I need some more info.

By the way, I prefer the Multitech modem, they're the HP prefered.


 

0
 

Author Comment

by:timothyking
ID: 12347774
It's a K570. We are using the parallel port labeled "External modem", I've looked at the internal modem port but don't recognize it. I don't think I have a cable to fit it.

Thanks
0
 
LVL 6

Expert Comment

by:Panjandrum
ID: 12348092
If you use the K570 'External Modem' port, you must first disable the internal modem.  The internal modem and the 'External Modem' port share the same connection to the I/O board (port 7).

You can do this by setting the K570 in 'service mode' (with the key) and hitting the CTRL+B on the keyboard.
You will have access to the Command mode.

If the console is locked, press 'ur' to unlock it.

Once this is done you can alter the modem config with the command 'ca'

- Enable Remote
- Use external modem
- Make sure you set the speed to 19200kbps, more is not supported on the K570

After you did this you can exit the PDC menu and put the key back to on

Then check again... if this fails, still a lot to come





 
0
 

Author Comment

by:timothyking
ID: 12373093
I took a look at what was suggested for the modem.
1)  the CA command allowed
 config of terminal mode id
 remote console config  and
 remote support of modem port.
2) When I selected to change remote support of modem port, there was only 1 option to change - the new system id
3) There were no places I saw to enable remote, use ext. modem or set modem speed.

Thanks
0
 
LVL 6

Expert Comment

by:Panjandrum
ID: 12378884

How to Setup the EXTERNAL MODEM PORT on the K Series?


From the master console type <CTRL> B to get access to the CM>
prompt. Make sure the IN SERVICE key switch is turned on/keyed on the
HP9000 system.

CM> CA     (Configure system remote support modem port.)

Current terminal mode identification:  HP mode terminal

Do you wish to change it?  (Y[N]):  y
Select new terminal mode:  (0=HP, 1=NON_HP, 2=AUTO_PWON) :  0
             [This is typically set to 0 (HP) or 2 (AUTO)]
The terminal mode is now :  HP mode terminal

Current remote console configuration :  Auto identification at power on
     (Internal modem is currently selected)
Do you wish to change it?  (Y[N]):  y
Select the new configuration (0=Internal Modem, 1=External modem 2=AUTO):
1

The new selection is now :  AUTO Identification at power on
     (Internal modem is currently selected)

NOTE:  Auto is the default setting for this configuration. It will always
       select the internal modem if it is available and the Line Adapter
       Module is installed. If you wish to force the selection of the
       external modem, you must choose option 1.

Current remote support modem port configuration:
System identification:
Do you wish to change the configuration?  (Y[N])y
Current system identification:
New system identification (limited to 1 to 20 display-able characters
     or space for none):  <Hit the enter key>

New configuration:  (takes effect at next remote connection):
System Identification:  <Hit the enter key>

CM> CO   (This will exit out of the CM session configuration complete)

Set the switch/key from IN SERVICE to NORMAL on the HP9000





Can you tell me the firmware version of the PDC? Latest one is the 42.01
If you don't have it, check on itrc.hp.com for the following patch PF_CBHK4201h (Reboot required)  





Also, check which cable you are using. It shoud be a 40233a cable (25 pin, 25 pin)

These pinouts are for the 40233a cable:

     CPU            Modem    
(25-pin)        (25-pin)  
------------------------  
GND  1 ---------- 1  GND *
 RD  2 <--------- 3  RD  *
 TD  3 ---------> 2  TD  *
RTS  4 <--------- 8  CD  *
DSR  6 ---------> 20 DTR *
GND  7 <--------> 7  GND *
 CD  8 ---------> 4  RTS  
 RI  9 <--------- 22 RI  
DTR 20 <--------- 6  DSR  
 RI 22 <--------- 5  CTS  



Make sure it is not a digital line, this is not supported.

Alternatively you can use a Line adapter module which is normally connected to the internal modem port.

0
 

Author Comment

by:timothyking
ID: 12422470
I found a HP cable that came with the system. One end fits into the internal modem port on the back of the unit, and the other end is a small rectangle box that excepts a rj11 phone line. Is this cable familiar to you? Can this be set up in SAM?

Thanks
0
 
LVL 6

Accepted Solution

by:
Panjandrum earned 50 total points
ID: 12431647
yep, that's the LAM module

You can configure it with sam!

1] Run SAM

2) From the SAM Menu, select “Peripheral Devices”

3) From the next SAM Menu, select “Terminals and Modems”

4) Tab to “File” Menu and use the right arrow key to select the “Actions” drop
down Menu.  Then select “Add Modem”

5) From the “Mux/Serial Card” List, select the Hardware Path or the Description
of one of the following:
     A) MUX 3 port (for setting up the Internal Support Modem)
     B) MUX (8 ports) (for modems connected to an MDP Mux Panel
        port 7 is reserved for the Internal Support Modem or for
        the External Modem Port -- which also uses port 7)

NOTE: port 7 cannot be used for both the Internal Modem AND the External Modem
at the same time

6) Tab to the “Port Number” label and hit the Enter key.  A list of available
ports appears.  Select the desired port number.

7) Tab to the “Speed (Baud Rate)” label and hit the Enter key.  A list of Baud
Rates will be produced.
     A) Select a maximum speed of 9600 Baud for use of modems using xon/xoff
       (aka: software flow control) protocol.
     B) or Select a speed of 19200 Baud for use with the Internal
        Support Modem
     C) or Select a speed of 19200 which is the maximum baud rate for use of
        modems using RTS/CTS (aka: hardware flow control) protocol on a
        K-Class computer.

NOTE: Current versions of SAM on 10.XX, and 11.00 do not automatically create
modem device files for RTS/CTS protocol.  Such device files will need to be
manually created using the mksf or mknod commands and setting the hardware flow
control bit, (bit five) to the HIGH or “1” condition of the minor number for
the port desired.  Beginning with HP-UX 11.i or 11.11, SAM will offer RTS/CTS
device file creation as a selected option under the “Add Modem” and “Modify
Modem” options

8) Tab to “Use Device for Calling Out”  Use an “X” if you desire to allow the
modem to dial out (“X” selected is the default)

9) Tab to “Receive In-coming Calls (start getty process)”  Use an “X” if you
desire to allow the modem to accept dial in  (“X” selected is the default)

10) Tab to “CCITT Modem (European standard modems)”  Use an “X” if you are in a
European country and CCITT protocol is being used  (“X” is NOT selected as
default)

11) If you have HPUX 11.i or 11.11, tab to “Use Hardware Flow Control Device
files (RST/CTS protocol)”  Use an “X” if you desire to use modems configured
for hardware flow control (“X” is NOT selected as default)

12) Tab to OK to accept the configuration

13)  Sam will create three device files for modem use.  You may still need to
physically connect the device and turn it on

14) Exit SAM (use the f8 function key, if you don’t see an Exit selection)

15) Done
0
 

Author Comment

by:timothyking
ID: 12445164
In SAM - Terminals and Modems - the following was listed:

Device            Type         Hardware  Port  Speed
/dev/console  Console     10/4/0        0      0
/dev/tty0p7    Terminal   10/4/0        7      9600
/dev/ttyd0p7   Modem     10/4/0        7      9600

I highlight the 3rd option and choose Actions and Edit and receive the following Error:

There are no available ports on the highlighted (selectied) device.
NOTE: One of the possible reasons this may happen is if you are trying to add a modem to a mux port that doesn't support modems.
0
 

Author Comment

by:timothyking
ID: 12445190
Also, the same error is received when Actions - "Add Modem" is chosen.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now