Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9679
  • Last Modified:

message refused by my exchange 2003 server

I am running a single Exchange 2003 Server. I have one domain. I occasionally have customers mailing me get the following message:

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

me@mycompany.com
SMTP error from remote mailer after end of data:
host mail.mycompany.com [X.X.X.X]: 550 5.7.1 Requested action not taken:    message refused

or

The message reached the recipient’s e-mail system but delivery was refused. Attempt to resend the message. If this still fails contact your system administrator. The MTS-ID of the original message is XXXXXXXX@notmycompany.com
mail.notmycompany.com #5.2.0 SMTP; 550 5.7.1 Requested action not taken: message refuse

So I logged on to an external account (Earthlink in this case) and tried mailing my company. Most e-mails go through the ones that don’t were messages that I tried forwarding with graphics (not obscene).

Everything I read tells me to check my recipient filtering. I also checked Symantec’s content filter policy. Does anyone have any ideas?
0
oceanjim
Asked:
oceanjim
  • 2
  • 2
1 Solution
 
BNettles73Commented:

You should make sure your MX IP isn't on an RBL (either at http://www.dnsreport.com or http://mail-abuse.org/cgi-bin/lookup) - Read through this article to find more information (http://support.microsoft.com/default.aspx?kbid=300580)

Something else to consider ...

I was reading not long ago about an Exchange admin had this issue when receiving from a Sendmail server ... they ended up forcing the sendmail server to use HELO instead of EHLO ... and I believe they disabled ESMTP verbs on the Exchange 2003 box ...

You may consider disabling 8BITMIME first (ESMTP Verbs) ... http://support.microsoft.com/default.aspx?scid=kb;EN-US;257569

"Because of compatibility issues between Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003 and other Simple Mail Transfer Protocol (SMTP) mail servers, you may have to turn off individual Extended Simple Mail Transfer Protocol (ESMTP) verbs that are advertised during the initial SMTP connection."

Do you use an SMTP connector? Do you have it configured for HELO instead of EHLO? (http://www.msexchange.org/tutorials/Configuring-SMTP-Connector.html)


Brian

0
 
oceanjimAuthor Commented:
Brian thanks for the response. Thankfully I am not listed in a RBL. When I look at the SMTP log for a transmission that was rejected I see the HELO what I don’t see are the data and an end of transmission.

I don’t have the send HELO instead of EHLO turned on.

I use a virtual SMTP connector.

I’ll try turning off the 8bitmime setting.

Below is a copy of my SMTP log for a rejected message. The names have been removed to protect the innocent.

138.163.X.XX - - [06/Oct/2004:09:26:17 -0800] "xxxx -? Gate5-sandiego.xxxx.xxxx.com SMTP" 500 32
138.163.X.XX - Gate5-sandiego.xxxx.xxxx.com [06/Oct/2004:09:26:17 -0800] "HELO -? Gate5-sandiego.xxxx.xxxx.xom SMTP" 250 43
138.163.X.XX - Gate5-sandiego.xxxx.xxxx.com [06/Oct/2004:09:26:17 -0800] "MAIL -? FROM:<martha.xxxxx@xxxx.com> SMTP" 250 47
138.163.X.XX - Gate5-sandiego.xxxx.xxxx.com [06/Oct/2004:09:26:17 -0800] "RCPT -? TO:<RDamon@mycompany.com> SMTP" 250 38

Jim
0
 
BNettles73Commented:

Have you looked at the security settings on the SMTP virtual server and connector? (Delivery Restrictions)
0
 
oceanjimAuthor Commented:
After turning off 8bit mime I now get the following tag on the rejection.

SMTP error from remote mailer after end of data:
    host mail.xxxxxxxx.com [64.xxx.xx.xxx]: 550 5.7.1 Requested action not taken:
    message refused

I'm researching the SMTP error above.

SMTP VS Security settings are set to default. Authentication is set to anonymous. Delivery is set to anonymous access.
Connectors settings are also default. Accept messages from everyone. Bridgehead is set to default SMTP virtual server.

Thanks again for the assistance,

Jim
0
 
interactivewebsCommented:
You may find that exchange (with the later service packs) is using message filtering to block your inbound message.
We found that even if we had the IP for the sending server enabled as a relay IP address (web server senind email from website) this would only work sometimes. It depended on the delivery address and the sending email address and content.
The solution was to enable another IP address on the SMTP server, and to ensure that message filtering was turned off on this IP address (in the exchange smtp settings). Then to use this ip address as the smtp server for the website.
Fixed all the strange things that were going on.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now