Solved

Windows 2000 Advanced server with 10 clients DHCP does not work.. Unable to connect clients

Posted on 2004-10-04
10
253 Views
Last Modified: 2010-03-18
I have windows 2000 advanced server and 3 clients running windows XP Pro.

I have a Linksys wired router with 4 ports

I have tried to set up the server and have gone through the wizard to setup up active directory, dns and dhcp.

But when I connect the clients I get the message that the domain controller is not available.

When I check to see if any ip address have been leased the list is empty.

Help :)

Thanks

0
Comment
Question by:gturco
  • 3
  • 3
  • 3
  • +1
10 Comments
 
LVL 20

Accepted Solution

by:
Debsyl99 earned 400 total points
Comment Utility
Hi
Have you configured a correct scope including dns server addresses (which should be the same as your main dc's IP) and have you authorised the dhcp server? The clients need to be set to obtain an Ip address automatically, and also DNS server address automatically.
How To Install and Configure a DHCP Server in an Active Directory Domain in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb;en-us;300429&sd=tech
Windows 2000 Configure DHCP Server
http://www.windowsnetworking.com/j_helmig/w2kdhcpc.htm

Let us know which bits you are having a problem with,

Deb :))
0
 

Author Comment

by:gturco
Comment Utility
Hello Deb

To be honest this is the first windows 2000 server I have tried to setup.  I was much more familar with Win NT 4.

So to your question did I configure a correct scope I just tried to follow the setup wizard.  

If I remember I used the following IP address in the scope : 192.168.100.1 to 192.168.100.100.

With regards to the DNS I don't remember that coming up in the wizard.  However, what do you mean it should be the same as the main dc's IP?

The clients network TCIP properties are all setup to obtain automatically.

I will read over those articles

Thanks again

0
 
LVL 5

Assisted Solution

by:napoleon41
napoleon41 earned 33 total points
Comment Utility
This may sound funny, but is the Linksys router configured to provide DHCP?  It usually is by default.

When a client needs an IP address, it sends out a broadcast for a DHCP server.  The first DHCP server to answer begins the process.  If your Linksys router answers before your 2000 server, the clients will use the router instead.  Just a thought.
0
 
LVL 20

Expert Comment

by:Debsyl99
Comment Utility
Hi

That's a good point about making sure that the router isn't assigning addresses too. You need to disable dhcp on the routerif it isn't disabled already. Your advanced server - if it is the only server on the network - will be the dns server and have a fixed IP address.

The dhcp scope needs to be configured so that the addresses it allocates are on the same subnet as the dc but excluding any fixed IP's so

Server IP - say it's 192.168.100.1
Router - say it's 192.168.100.254
Then your scope should allocate addresses in the range 192.168.100.2 - 192.168.100.253
In scope options in dhcp you can set the dns server, router and wins server amongst other things. You need to set the dns server in the scope as the same IP of your server ie 192.168.100.1 (in my example), the router as the same ip as your router etc. That way the clients will be allocated valid addresses on the subnet, but they need to know the dns server for name resolution on the network, router ip for internet access/mail etc.

Work through the links, and let us know if you have any trouble.

Deb :))
0
 
LVL 18

Assisted Solution

by:crissand
crissand earned 67 total points
Comment Utility
What is the result of ipconfig /all on one of the workstations? You can see there if the dhcp server works.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:gturco
Comment Utility
Crissand

When I do Ipconfig /all I get autoconfiguration Ip and subnet 255.255.0.0

Napolean  

Thanks for the info but I did turn off DHCP on the Linksys router.

Deb

I followed the instructions  in your links and you last comment and inputed the following:

Server IP: 198.168.100.2
Address Pool : 198.168.100.3 to 198.168.100.254
Router IP: 198.168.1.1
DNS server ip: 192.168.100.2 (what should have I put for Server Name?)
Wins: Nothing was added

Then I made sure to activate the scope.

I then checked the other workstations..and did Ipconfig /renew and got the autoconfiguration IP Info.

I then rebooted the server and when it was starting back up it a device driver failed to load.

When I checked the Event Log the last thing that failed was DHCP.  There were also some errors related to time check, smtp, wins, etc..

When I went back to look at the DHCP manager in admin tools I noticed that the following:

DHCP
Server(127.0.0.1) This had changed from the Server IP i had inputed earlier :(
Scope (198.168.100.0)
Address Pool (198.168.100.3-198.168.100.254)
Scope Options
      006 DNS Server (192.168.100.2)
      003 Router (192.168.1.1)
Server Options
      003 Router (192.168.1.1)

I then tried to delete all this information and everytime I restarted the DHCP manager the same info reappear

Help :)

Thanks

0
 
LVL 18

Expert Comment

by:crissand
Comment Utility
The options can be entered in the general server or in the specific dhcp server's options tab. Be sure to check both tabs. Preferabilly the router/default gateway should be in the same network.

I suppose the network topology is like this:

            router
    +-----+ ++----+
    |          |        |
server      ws     ws
0
 

Author Comment

by:gturco
Comment Utility
Crissand

The network Topology is like that :)

When I get back home I will look for the general server and dhcp server option tab and get back to you.

How does one check what the domain name is on the server?  I want to make sure what i originally inputed.

Thanks again
0
 
LVL 18

Expert Comment

by:crissand
Comment Utility
Administrative tools/Active directory domains and trusts.
0
 
LVL 20

Expert Comment

by:Debsyl99
Comment Utility
Hi

Could you check your event logs on the server and post any errors that you find? If this is a completely new setup (and it sounds like it is your first time maybe) then there's all sorts of potential problems that can happen (Control panel - administrative tools - event viewer - check all logs and post what you find exactly). Your router Ip address should be on the same subnet too and can you confirm you've disabled router dhcp.

Could you post the results of doing the following from a command prompt on the server too just in case:-

ipconfig /all

Oh and although you activated the scope did you authorise the server? No authorisation no dhcp! In the scope options you could also add the domain name - no.015 of the options in dhcp.

Right-click my computer on the server, properties and network identification tab. You should see your full server name there in the form of

servername.mydomain.com

The domain name is
mydomain.com

If the domain name is just in the form of mydomain (ie no .com, .net or .anything) then you have a single label which will cause big problems,

Deb :))

0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Nslookup is a command line driven utility supplied as part of most Windows operating systems that can reveal information related to domain names and the Internet Protocol (IP) addresses associated with them. In simple terms, it is a tool that can …
This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now