Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6130
  • Last Modified:

SMTP Relaying denied. IP name lookup failed

We are currently experiencing delivery problems to several domains. Below is an SMTP Connection test that shows Relaying Denied by this servers (69.72.176.188).  Test was done on site (From the Exchange server) with this utility.  http://www.zoneedit.com/smtp.html? To see why we cannot get email to this domain (@AOL.com) Login on the exchange server, browser at the link above, tested the valid email address customerservice@vjbooks.com sending email to valid email address vjbooks2@aol.com

I do not know why this server would be involved at all and why the delivery failure?  
 

Details:  We are sending an email from our Exchange 2000 server SP1 (SBS2000), Verizon DNS servers 4.2.2.1 and 4.2.2.2. We have a Sendmail server as part of the Firewall (VJBFW) that all mail is forwarded to. , Static IP 66.14.52.102: MX pointing to VJBFW.vjbooks.com at 66.14.52.102

Test results.
SMTP Connection:
OK, connected to 66.14.52.102...
< 220 VJBFW ESMTP Sendmail 8.11.3/8.11.3; Mon, 4 Oct 2004 21:01:47 -0700
> HELO edit.dnsvr.com
< 250 VJBFW Hello [69.72.176.188], pleased to meet you
> MAIL FROM:<customerservice@vjbooks.com>
< 250 2.1.0 <customerservice@vjbooks.com>... Sender ok
> RCPT TO:<vjbooks2@aol.com>
< 550 5.7.1 <vjbooks2@aol.com>... Relaying denied. IP name lookup failed [69.72.176.188]

Whois results for 69.72.176.188
This utility is provided by ZoneEdit.Com, the industry leader in DNS and domain mangement solutions.
OrgName:    Pegasus Web Technologies
OrgID:      PWT-5
Address:    1719 Route 10E
Address:    Suite 220
City:       Parsippany
StateProv:  NJ
PostalCode: 07054
Country:    US

NetRange:   69.72.128.0 - 69.72.255.255
CIDR:       69.72.128.0/17
NetName:    PEGASUSHOST
NetHandle:  NET-69-72-128-0-1
Parent:     NET-69-0-0-0-0
NetType:    Direct Allocation
NameServer: NS1.PWEBTECH.COM
NameServer: NS2.PWEBTECH.COM

 
0
mspencer100
Asked:
mspencer100
  • 3
  • 2
2 Solutions
 
SembeeCommented:
You need to ask the ISP to setup a reverse DNS entry for your IP address. If they tell you that you need to do this, then unless own the IP addresses (which I doubt) then they are wrong.

If you are on a dynamic IP address range - even if it is static - which usually means you are connecting by DSL this may not help and you will end having to use an SMTP connector to send the email via your ISPs SMTP server.
http://www.amset.info/exchange/smtp-connector.asp

Simon.
0
 
susanzeiglerCommented:
Hmm, well I looked at the testing site and checked my own mail servers. I would have been very annoyed if it would have worked since I have relaying blocked on all my servers. That is the error you are seeing--which is the same as what I got. The IP that you are seeing is the IP of the zoneedit server (where you are doing the test) and your server is rejecting it because it is not an allowed relay server. Any properly configured mail server should result in the same error:)

Now, as to the real issue. AOL has automatic blacklists which include any dynamic address space reported by ISPs to them. I have had this issue before. Check with Genuity--whom your IPs are allocated through and verify that they have not reported your IP block to AOL as being dynamically assigned. The following link has information on AOL failures - http://postmaster.aol.com/selfhelp/index.html   You may also contact AOLs postmaster and ask to be whitelisted, although this is more difficult to get action on :) The link for whitelisting is here: http://postmaster.aol.com/whitelist/index.html

One other thing to note, although your forward and reverse somewhat match for your mail server, I do see one thing that could possibly cause issues. When I do an MX lookup for your server, I get the MX reported as VJBFW.vjbooks.com -- note the capital letters. On some systems, VJBFW.vjbooks.com and vjbfw.vjbooks.com would be seen as different hosts. The reverse is done as vjbfw.vjbooks.com so a machine that is case-sensitive and requireing forward and reverse matching might reject email from your server. Rule of thumb is not to use capital letters in a host name.
0
 
mspencer100Author Commented:
The other thing I noticed is that I get this error when in do a DNS reports. Is this significant in your eyes?  Do you think it could be what is stopping email from getting to AOL , Earthlink and other domains?  
 
 http://www.dnsreport.com for vjbooks.com

Mail server host name in greeting
    WARNING: One or more of your mailservers may be claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). This probably won't cause any harm, but may be a technical violation of RFC821 4.3 (and RFC2821 4.3.1).

VJBFW.vjbooks.com claims to be host VJBFW.
 
Thank you for your help.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
SembeeCommented:
That isn't unusual and is easily fixed.

ESM, Admin Groups, <your admin group>, Servers, <your server>, Protocols, SMTP. Right click on default SMTP virtual server and choose Properties. Click on the last tab "Delivery" and enter advanced. In the box marked FQDN, enter the name that the server is known as on the Internet: mail.domain.com or whatever. This should match the name that you are using for your MX record.

Simon.
0
 
mspencer100Author Commented:
Sembee, currently the Delivery/Advanced/FQDN = vjbnt01.vjbooks.local and when I click on Check DNS I get Domain name is valid. If I try to match my MX record with vjbfw.vjbooks.com when I click on Check DNS I get domain name is not valid.  Also I looked at the default connector properties / general tab and the "Forward all mail through this connector to the following smart hosts" = vjbfw.vjbooks.com

   Local bridgeheads: = VJBNT01 Default SMTP Virtual Server.
0
 
SembeeCommented:
Unless you have a zone for "vjbooks.com" on your internal DNS servers then getting domain name not valid will be expected. A .local name should not be in there otherwise you will get the error message from remote sytems that you have reported.

Furthermore, the SMTP Connector that you ahve created is useless. You are telling it to use itself for email routing. If that is the case you may as well get rid of it. If email is being delivered directly then you don't need a connector. A connector is used for telling Exchange to deliver the email to a different place than the one it can find on its own.
If you are on a Dynamic IP address range then you will need to leave the connector in place and change the SMART HOST to the SMTP server of your ISP.

Simon.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now