Deploying a finished application

I recently finished developing an application. I created an executable for it and put it on several different machines, all with different make ups. The application works great. Except for one part. I have a form that calls another form with crviewer on it. When I try to pull up this second form during run time it gives me an error about the crviewer.dll not being correctly registered. Does anyone know a simple way to resolve this? Is it possible to just move this dll to the machines getting this error? If so, where?

I've tried packaging my application and I've gotten a couple PCs to work using this method. Downside is that we have some screwy policies as far as admin rights go, etc. If I can get around the admin stuff I should be fine. Anyone?
Mike MillerSoftware EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Click start, run and enter this line in the command line:

regsvr32 c:\where the dll is\crviewer.dll

It should register the dll.


It would probably be safer to use the Package and Deployment wizard to package your app with all related dlls.  That will register the dlls, and un-register them if the user runs the un-install.  That's also useful in case one of the pcs you install it on has an older version of a dll that you're using.

Also, there is a patch that you'll need for Crystal Reports 8 to use it properly with a VB6 executable.  The file is called:

I forget if there's a way to attach files to comments here, but you should be able to find that patch either through Google or on the Crystal Reports site.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike MillerSoftware EngineerAuthor Commented:
I'm running CR 10. I'm assuming I don't need that patch???
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Oh, sorry, guess I'm out of date.  Have to remember to update.  No, you don't need that patch.

You should probably remember to get the latest critical updates and services pack, though.  See here:

Anyways, my comment still stands, that you should package your exe properly, so you know that the correct dlls get registered every time, and to give users the option of easily removing your app and those dlls.
Mike MillerSoftware EngineerAuthor Commented:
That was the way I was originally trying to deploy it. I kept getting the following errors though:

Visual Basic 6.0 Setup Toolkit: Setup1.exe - Unable to locate DLL
The dynamic link library cxlibw-1-6.dll could not be found in the specified path
(gives like 8 different paths)

An error occurred while registering the file C:\Program Files\Common Files\Crystal Decisions\2.5\bin\crqe.dll

And then:
The file c:\path\msftqws.pdw\$(DLLSelfRegisterEX) could not be registered because it was not found.

Then it forces me to unregister the dlls, delete the temp files from the install, and exits the setup unsuccessfully.
P&D is not a very reliable tool for packaging. Try InnoSetup, It is considered the best, and its for free, and it has online help.

Business Objects (formerly Seagate) says they've fixed that problem, with patch number 35962148.  If your Crystal Reports critical updates and service packs are up to date (see link in my previous comment), then I suggest you report the problem to the Crystal Solutions team.

In the meantime, Shauli's solution may be your only option.
You could also move this question to the Crystal Reports section.  There are some super smart people there, too.
Mike MillerSoftware EngineerAuthor Commented:
After some research, I've found that the last error has to do with the Calendar control I'm using in my VB app. I'm working on that one now. I have all the most recent updates/sp so I'm going to try again with the P&D.
Mike MillerSoftware EngineerAuthor Commented:
Ok, I repackaged my application and when I went to install it I still got the 1st error from my comment above. I clicked 'Ignore' for this .dll and the installation completed successfully. The program ran great just as it had when I just copied the executable initially. Same error, however, when I ran the form with the CR Viewer on it. So I guess I'm back to square 1!!!
Have you tried to register the dll manually as in my first post?

Mike MillerSoftware EngineerAuthor Commented:
Yes I tried that. I was unsuccessful as a user. I successfully registered the file as an admin, but got the same error.
Do you get the same error if you try to install under admin priv?


Mike MillerSoftware EngineerAuthor Commented:
Can't think of anything other than P&D screwing things up. If you have the time, try to create a package with innosetup and see if you have the same problem. Many problems with P&D were solved for me using inno. Other than that, sorry, I don't have any new ideas.

GP-Install 5.0 is a freeware install maker, it is very simple to set paths and imply self registering dll's, ocx's, and lib's . Hope this helps. :)
Mike MillerSoftware EngineerAuthor Commented:
Sorry it took so long for me to this has been fun! :-(

I repackaged my app using Visual Studio Installer. I got even more errors when I tried that. Anyhow, researched the errors (unrelated to this issue) and got those fixed. Still got the same error. After changing some things in my installer, I started getting different errors. One of them led me to an article about corrupted MDAC. I uninstalled MDAC and reinstalled it. Ran the installer and it completed without error. Ran the exe and it ran great. I could even pull up the report like I've been trying to do all week! I just wanted to thank everyone for the suggestions on here...this was a tough one! If anyone would like me to explain anything in further detail, just leave a comment.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.