Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2061
  • Last Modified:

Manually Adding DNS

I am currently having to add the 2 DNS IPs my ISP gave me to each computer on our network manually.  When I select "Obtain IP Address Automatically" I do not have internet connectivity.  I have tried to go through AD and setup the DNS Servers to be broadcasted along with the assigned IP address for each computer from DHCP but cannot get it to work....

Any help?

Thanks
0
r270ba
Asked:
r270ba
  • 8
  • 8
  • 6
  • +1
2 Solutions
 
lrmooreCommented:
You should only have to add those DNS entries to the primary DNS server in the "forwarder" options. Each client should not have to have public IP DNS servers..
0
 
r270baAuthor Commented:
Can you give me some guidance on do so?  Website or your personal knowledge?  Thanks!
0
 
zerofieldCommented:
lrmoore is right, i think you've misinterpreted what those should be used for.  you CAN use them, but it'd likely make life difficult for the inside users, as your internal DNS isnt always (or often at all) the same as external DNS.

right click on each DNS server in your ip management under admin tools (or login to each server, go to manage computer, and do it from there)

right click the dns server -> properties -> forwarders

click on the box that says "selected domain's forwarder ip address list"

put in those IP's the ISP gave you.

in your DHCP settings, you should be distributing the INTERNAL dns servers, not the external.  all requests that the two internal machines dont recognize will then query the forwarder references.  Here in my domain, i forward to the linux DNS/IDS servers.  for the average domain, they just dont forward or forward to their ISP.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
hehewithbracketsCommented:
In addition to the comment above, you should have your internal DNS server added to your DHCP server options.  This will automatically assign your internal DNS server to your client computers.  Any requests for domain names outside of your domain will be forwarded to your ISP's DNS servers that you added as forwarders.

The link below has a link to an article that explains how this is done, but the link appears to down at the moment.
http://www.petri.co.il/no_forwarding_or_root_hints_on_dns_server.htm
0
 
zerofieldCommented:
thats what i said :P  "in your DHCP settings, you should be distributing your INTERNAL"

i didnt specify that was in scope options, but it sounded like he already knew that from the question.
0
 
hehewithbracketsCommented:
Sorry, I got interrupted in the middle of my comment and didn't refresh before posting.  Only lrmoore's comment was posted when I was trying to respond.
0
 
zerofieldCommented:
oh, yea, i hate it when that happens to me at work.  its even worse then the guy that beats you to it said the exact same thing ;)
0
 
r270baAuthor Commented:
Yes I did know that that was in the Scope Options

When I go to the DNS Server->Properties->Forwarders

I do not see the "selected domain's forwarder ip address list"

It says "Forwarders are not available because this is a root server"

I am running Win2K Server.
0
 
zerofieldCommented:
what the..?  does this thing act as an internet DNS server, or only as an internal DNS server?  i was under the asumption that it was an internal only?
0
 
r270baAuthor Commented:
supposed to be internal only???  I do not use it as a external DNS server.

I went to the DNS MMC and clicked on the Server TSPPUMP->Properties->Forwarders

It shows where I can add IP addresses but they are just grayed out and that is the message I get at the top.  It isn't like an error message though...just plain text along with everything else (just everything else is grayed out).
0
 
r270baAuthor Commented:
"supposed to be internal only????" meant yes it is meant to be internal only...the ???? made it look like I was asking you :)
0
 
zerofieldCommented:
is this server a DC?  even if it is, check on the other DC's you have there.  all of them should be running the DNS service - it's just a best practice kind of thing as well as possibly bein the solution to this.
0
 
hehewithbracketsCommented:
Actually, the link I posted above is specifically about your problem.  Your DNS server should not be a root server.  Once you correct that, you can add the forwarders.
0
 
zerofieldCommented:
i was hesitant to say "dont make it a root server" in case for some bizarre reason it should be.. but honestly i dont think it should be.  now that we can blame hehewithbrackets, ill agree ;p

but honestly i'd follow that link and fix it up, add the ISP's NS's as the forwarders.  not too big of a deal.
0
 
r270baAuthor Commented:
Zerofield -  Yes it is a DC and is the only one here.

hehwithbrackets - How do I correct it?  If I correct it will that change any other aspect of my network and cause something not to work?
0
 
zerofieldCommented:
it may not work til you have it backup as a DNS (but not a root DNS server) server.  trust us, this is the thing to do.
0
 
hehewithbracketsCommented:
It definitely should not be a root server and should not affect anything else.  As zerofield already suggested, just follow the article above.  The link is working now and it does a good job of walking you through the screens.
0
 
r270baAuthor Commented:
hehewithbrackets...i just read the article and did what it said.

Now when I want to distribute my internal DNS I go to

DHCP->Scope Options->Configure Options

DNS Servers

Add the IP of my DNS (non root) Server.

===========================

Ok I did all that and then changed the "Manually Assign DNS" to "Obtain Automatically" on one of the machines and I can reach the internet...this is workign now correct???
0
 
hehewithbracketsCommented:
Sure looks like it.
0
 
r270baAuthor Commented:
Also sorry for being "lazy" and asking you to tell me what to do....I forgot about the link you posted above :)
0
 
r270baAuthor Commented:
Thanks guys....I will award 250 and 250 (this is always the hard part) b/c you both helped me out.  I really love this place!!!!
0
 
hehewithbracketsCommented:
Not at all, but the article does it alot better with screenshots and everything.  I assume you also added the forwarders after removing the root and now all is well?
0
 
zerofieldCommented:
im not here for the points, no biggy.  i just try to make EE a place to get real help from real administrators from.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 8
  • 6
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now