[Webinar] Streamline your web hosting managementRegister Today


Run .bat file on remote Linux

Posted on 2004-10-06
Medium Priority
Last Modified: 2006-11-17
Hello Experts. I need to run a .bat file on a dedicated Linux Root Server. Any of you Experts know how to do this, using either WinSCP or Putty?  Or even a regular FTP client, if that's possible?

Many kind thanks in advance,
Question by:John Account
LVL 38

Expert Comment

ID: 12245405
You can ftp (or use putty etc) transfer your script to the Linux box, and then use ssh to run
the script. (you can run command with FTP client).

have a look at:

FTP script:

Author Comment

by:John Account
ID: 12245632
Yuzh, I'm new to Linux, Putty, and WinSCP...so I'm having a real hard time following you. I'll explain my situation a bit more, and hopefully you'll be able to help me.

I've managed to install the Java Runtime on my Dedicated Linux Root Server. I needed the Java JRE because I'm using a Java Chat Server. To start the Java Chat Server, there are a couple .bat files that I need to execute. When I was hosting these on a local (physical) windows2000 server, there was no problem, because all I needed to do was double-click the .bat files. But now, my server is Linux and it's remote--and I just can't, for the life of me!--seem to be able to run those .bat files.

In WinSCP I right-clicked the file, selected Custom Commands/Execute...only to get error saying: Command "run.bat" failed with return code 127 and error message -bash: line 140: run.bat: command not found.  (Btw, yes, the file has read,write,execute permissions)

In Putty, I tried with: chmod a+x run.bat run.bat....but that apparently doesn't work either, 'cause the chat server isn't running.

I've increased the points to 500, and hope very much that you'll be able to help me out here. Many thanks in advance.
LVL 38

Accepted Solution

yuzh earned 2000 total points
ID: 12245820
For script to run in a Linux box, the syntax has to be Linux/Unix shell command syntax, the
DOS/windows batch file command syntax will not run on Linux!

>>In Putty, I tried with: chmod a+x run.bat run.bat....but that apparently doesn't work either, 'cause the chat server isn't running.

Do you want to keep the "chat server " running all the time? I can help you to write
a script to make it run at start up so you don't have to worry about to start it in your

Please let me know the program name for your chat server and the FULL path to the

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.


Author Comment

by:John Account
ID: 12246324
Thanks, yuzh. I appreciate it very VERY much. As I don't know anything about Linux, I'll explain these paths best I can:
When I log in, I'm in the root folder. Then, when I go up a folder, that seems to be the real root--since all the other folders (and, by extent, subfolders) derive from this point forward. Hence, therein, is my home folder; henceforth these following paths leading to the .bat files I need executed.



I need to get some sleep now, as it's 3:30 am here; so I'll check back later. If you want to email me any scripts, my email is < # Email address removed by yuzh, Page Editor # >
Many thanks,
LVL 38

Expert Comment

ID: 12246437
Please do a test for me:

login as root, and then try in the following command:

/home/httpd/vhosts/videopersonals.info/httpdocs/LoveLine/Server/run.bat <Enter>

/home/httpd/vhosts/videopersonals.info/httpdocs/Server/run.bat <Enter>

Please post the screen error messages, and the contains of the two run.bat files.


Author Comment

by:John Account
ID: 12246521
Couldn't sleep, 'cause had this haunting thought: Maybe those .bat files won't work on Linux. So these are the contents of the .bat files--if that means anything to you, as indicated by their respective paths provided earlier:
     * /home/httpd/vhosts/videopersonals.info/httpdocs/LoveLine/Server/run.bat
java -jar socket.jar 9999
     * /home/httpd/vhosts/videopersonals.info/httpdocs/Server/run.bat
java -jar socket.jar 8082

As you see, the only difference is the port number.

Also, I did your test, and it rendered the following results:
/home/httpd/vhosts/videopersonals.info/httpdocs/LoveLine/Server/run.bat: line 1: java: command not found
/home/httpd/vhosts/videopersonals.info/httpdocs/Server/run.bat: line 1: java: command not found

--going to try to get some sleep, again. Many thanks to you, yuzh.
LVL 38

Expert Comment

ID: 12246695
Let's find out is you have java installed in your box first, login as root, and type in the following

find / -type f -name java -print

If the about command can't locate java, you need to install java.

Do worry, someone at EE will help you out, have a nice sleep.

Since we are in different timezone, I suggest that you post a link in the Linux TA and
point to this questions, you might get better responses.


Have a nice sleep!

Author Comment

by:John Account
ID: 12249678
I get the following path  when I type in what you suggested...


Expert Comment

ID: 12251632
You should open the files in a text editor and replace "java" with the full path

Again - post the output here...
LVL 38

Expert Comment

ID: 12255421
please modify the two .bat files as bytta suggested, and test it again.

Expert Comment

ID: 12256143
you might want to execute a 'whereis java' to find out the exact path of the java binary.
then you can try putting the whole path in the bat file
e.g. /usr/bin/java  -jar socket.jar 9999

>>> Make sure that "socket.jar" is for Linux NOT the Windows version!
Yuzh, isn't that the way Java works, (not platform independent) ... so i'd assume it should make a difference.

JohnLucio, are you sure that the .jar file is not actually really corrupt as it states?



Author Comment

by:John Account
ID: 12258632
no it's not corrupt... I have this software running on a windows machine and it's working just fine.

Author Comment

by:John Account
ID: 12406192
Hi yuzh. Yours was the solution that worked. I discovered that the reason it wasn't working before was because my jar files don't work with the newest version of the Java JRE. So, after, installing an older JRE, and using your help, everything was smooth. Thank you.

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Periodically we have to update or add SSL certificates for customers. Depending upon your hosting plan you may be responsible for the installation and/or key generation. In the wake of Heartbleed many sites were forced to re-key. We will concen…
The Super Bowl is just days away. Millions of advertising dollars will be spent in just a few hours to drive people to websites around the globe. Optimizing your site in anticipation of a big event like this (and the traffic surges that follow) will…
Planning to migrate your EDB file(s) to a new or an existing Outlook PST file? This video will guide you how to convert EDB file(s) to PST. Besides this, it also describes, how one can easily search any item(s) from multiple folders or mailboxes…
The video will let you know the exact process to import OST/PST files to the cloud based Office 365 mailboxes. Using Kernel Import PST to Office 365 tool, one can quickly import numerous OST/PST files to Office 365. Besides this, the tool also comes…
Suggested Courses

640 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question