Solved

Groupwise 6.5 MTA Edir Sync not working

Posted on 2004-10-06
13
701 Views
Last Modified: 2012-06-27
Hi, I have a problem with no MTA EDIR sync. I can't turn it on! In Console 1.3.6C, GW 6.5 Sp2, Netware 6.5 (single server site) I go to "tools" then "system operations" then "edirectory user syncronisation" "Configure Agents" Edir access is set to "NO", so I go to "setup edirectory access" and put in the server details, which are accepted. Edir Access remains at "No". I've tried restarting the MTA, no Help. It appears that the problem is the link between the MTA and the edir Object. When I used the /tracelogin -2 switch I see that the MTA is trying to log in with the wrong ID??. I have bypassed this bit by using the /dn switch to direct it to the right name, and so it then loads without the error. But if i press f4 from the MTA screen it appears to run edir sync correctly, but on looking in the log file, nothing is processed! It  also still says NO in CS1 under edir access...
Any help would be really appreciated...

Thanks
Matt

0
Comment
Question by:mattpaulin
13 Comments
 
LVL 34

Expert Comment

by:PsiCop
ID: 12248794
Is this NetWare v6.5 SBS?
0
 

Author Comment

by:mattpaulin
ID: 12252711
Yes, 6.5 SBS SP2
0
 
LVL 8

Expert Comment

by:waybadmojo
ID: 12256312
1) User sync is usually done on an email server holding a replica of the tree
Does your server have any replicas on it?

2) Does the troublesome MTA have sufficient rights to eDir?
Here's an easy test to see: Grant the MTA rights to the root of your tree and if the problem goes away, you know that it was a rights issue.

3) If no replica, are you launching the MTA with /user and /pass switches?
These switches are mandatory for user sync if teh box has no replicas on it.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mattpaulin
ID: 12256810
Hi Waybadmojo,

This is a single server install, it has the one (and only) master replica
I have granted the MTA rights at the root of the tree

However, I just went back thru and granted all rights to the root including supervisory, and when I tred to enable the MTA for EDIR sync, it said that an ACL already existed for the object? This is a change.... Help said reboot, so I'm doing that... I am not using the /user /pass switches althoght the problem IS inthis area. With no switches set it tries to connect to NDS with an invalid name - I'm currently using the /dn switch to avoidthis problem.....

Matt
0
 

Author Comment

by:mattpaulin
ID: 12263310
OK, the reboot did not help, but the change in rights has now given me an error message to work with. This error comes up in CS1 when selecting the server for the MTA eDir Sync;

(Error - 678) An ACL for the object already exists. This ususally happens only while merging a tree. The Error indicates that the context is invalid

I've tried seachind the Novell KB, but found nothing usefull yet. Any ideas?

0
 
LVL 34

Expert Comment

by:PsiCop
ID: 12277444
Hmmm....you *may*...and I stress the word *may*...want to consider dis-associating and then re-associating the GroupWise objects.
0
 

Author Comment

by:mattpaulin
ID: 12291780
Hmm, I don't want to screw upt the system so it does not work at all.... I think I might log a call with Novell....
Thanks for your suggestions guys..
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 12292510
That's not a bad idea. I suspect they may advise you to do just that - disassociate and re-associate the object - but I'd rather have them tell you that. They may have some troubleshooting item I've overlooked.
0
 

Author Comment

by:mattpaulin
ID: 12458334
Ok, I have fixed this with Novell's help. Problem was that when SP2 was added (not by me!) the wrong dir was specified for the domain/PO, and the SP had created another domain/SP under the original! So the GW PO loaded was not the one the the DS was trying to look at. Anyway, copied out the databse files, removed the addtional dirs, checked that the system worked Ok - it did. Had to log in as each user (painful!) to recreate empty databases for everyone - by each user sending a message to the group everyone. Then copy the data back from the backup I'd made. End result was all is now well - but if you are doing an SP to GW 6.5 make sure you specify the correct Dir!
Thanks for you suggestions everyone.
Matt
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 12475014
Glad to hear its resolved. If none of our suggestions helped, then post a (free) Question in the Community Support TA (http://www.experts-exchange.com/Community_Support/) and request that this Question be PAQed and your points refunded. Be sure to include a link to this Question.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 12842342
Fine by me.
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 12867175
PAQed with points refunded (500)

modulo
Community Support Moderator
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
outlook search indexing 6 28
exchange 2010 shell commands 2 55
Clients download Emails from other exchange servers. 14 112
Outlook:  Sent on Behalf of 4 94
If you are anything like me, you install many apps on your phone and have your life on it, sometimes literally.  When I bought my current phone, a Samsung Galaxy S5 from Verizon, they were only selling the versions with 16 GB internal.  I didn't rea…
We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question