There has to be a better way to do what I want to do.
I am currently doing this:
-In my Flow.h file I have this -
virtual int SocketReceive(HardwareType1Startup* pHardware1StartupObj);
virtual int SocketReceive(HardwareType2Startup* pHardware2StartupObj);
virtual int SocketReceive(HardwareType3Startup* pHardware3StartupObj);
-So now in my Flow.cpp file I have this-
int CFlow::SocketReceive(HardwareType1Startup* pHardware1StartupObj)
int CFlow::SocketReceive(HardwareType2Startup* pHardware2StartupObj)
int CFlow::SocketReceive(HardwareType3Startup* pHardware3StartupObj)
Is there a better way to combine the function headers so that I don't have 3 different ones depending on what build I am using?